Support in other languages: 
Reply
Blue Screen Again
Lone
Posts: 4
Registered: ‎02-06-2012
Location: Germany
0

X1 GPS does'nt work (Errorcode: WPG01-EG2)

[ Edited ]

GPS port (COM 6) is activated, WWAN is activated, a Vodafone SIM is inside and all drivers are up to date.

ThinkVantage Toolbox GPS communication test fails, error code is WPG01-EG2-and I don't receive any satellites.

Does anyone know the error code or has a solution?

 

RMattoo
Posts: 1,241
Topics: 3
Kudos: 91
Solutions: 91
Registered: ‎11-02-2011
Location: India
0

Re: X1 GPS does'nt work (Errorcode: WPG01-EG2)

Hi

 

Please Share the Firmware revision of your WWAN card?
How to get it:
- go to Device manager (start->run-> type devmgmt.msc)
- expand "Modems" and select the properties of the below standing Ericsson...
- select Diagnostics Tab-> click on "Query Modem"
- now it will take some time and once you will see the results right next to the option called "ATI1" you see the Firmware revision

Also please let me known the driver version of the WWAN driver, that you have installed.

 

 

If you have time, then it would be great, if you could test following situation, that seems to be from one site obvious and in the same time strange.  But as I was told by one of my colleagues, which have encountered the same issue, this was the fix for him.
Ok, so here is what I would ask you to test:
- go to Control Panel->Hardware..->Location and Other Sensors and make sure, that you have the GPS device Enabled
- check if you are using in the Windows side bar some gadget like weather indicator, or similar and dissable them
- now try to use the GPS device, if it still reports the same issue

Explanation:
the Weather gadget is is some way also detecting the location of your system (it detects if you are in France, or Germany,...) And these two location devices are interfering.

Please test this situation and let me know you restuls.

 

 


I hope this helps

 

Blue Screen Again
Lone
Posts: 4
Registered: ‎02-06-2012
Location: Germany
0

Re: X1 GPS does'nt work (Errorcode: WPG01-EG2)

[ Edited ]

Hi,

thank you for the reply.

In the device manager under modems there is the only one device specified as:
F5521gw Mobile Broadband Modem Port

The driver installed is from Ericson AB
Version 5.28.4.0 (date 13.04.2011)

Firmware revision is as follows:
ATI1: R2A07(R2A07)

I have closed all gadgets (I dont use the wheater gadget).
And i looked for background-processes which may detect the location but didn't found any suspicious.

It still doesn't work and the ThinkVantage Toolbox GPS communication test still fails with same error code.

Do no one knows what the error code WPG01-EG2 stands for?

RMattoo
Posts: 1,241
Topics: 3
Kudos: 91
Solutions: 91
Registered: ‎11-02-2011
Location: India
0

Re: X1 GPS does'nt work (Errorcode: WPG01-EG2)

Hi

 

Thanks for providing the details , Please update the following

 

1. F5521gw Mobile Broadband Driver

http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS018764

2. Update Think vantage GPS

http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS015017

 

Please Let me know the result

 

 

Hope this helps

 

 

 

Blue Screen Again
Lone
Posts: 4
Registered: ‎02-06-2012
Location: Germany
0

Re: X1 GPS does'nt work (Errorcode: WPG01-EG2)

Hi,

thank you for the drivers but:

It is NOT possible to install the Ericsson F5521gw/F3607gw Wireless WAN Driver Version 6.5.1.5 !!!
It still stays on version 5.28.4.0 with the Firmware-revision R2A07(R2A07) and the tests fail!


I've tried the following methods (with a admin-account):

After starting the setup-process it appears the setup-display (choose features/repair/uninstall).
I tried all three ways (the last in 2 Steps) - each with the necesssary restart of the computer.
-> No change

After that I manually uninstalled the old driver from the device manager (with deleting the files!) and try to install the new driver.
-> No change (question: from where do it take the old drivers??? I thought I have deleted them!)

After that I tried to update the driver from the device manager manually with manually choosing the path C:\DRIVERS\WIN\WWANER\driver
-> here it says that the driver is uptodate and do nothing.


Each time there is the following curious situation:

In the programs and features table the driver appears as:
Mobile Broadband Drivers Ericsson AB Version 6.5.1.5

But in the driver tab of the device in the device manager there still appeares Version 5.28.4.0 (date 13.04.2011) with the same old Firmware-revision R2A07(R2A07)

I don't know what happens here.
Can you please check if the downloadable update file contains the correct driver version?
Or I only do a few rookie mistakes?

Blue Screen Again
Lone
Posts: 4
Registered: ‎02-06-2012
Location: Germany
0

Re: X1 GPS does'nt work (Errorcode: WPG01-EG2)

Did You read my last answer?

GPS still doesn't work and the situation is still the same as I described before.

 

Any news?