Support in other languages: 
Reply
Blue Screen Again
johnmaine
Posts: 4
Registered: ‎03-18-2011
Location: VA, USA
0
Accepted Solution

X120e ABGN Driver issue in Windows 7 Pro x64

I recently purchased an x120e and installed an SSD with my own copy of Windows 7 Professional 64-bit. I managed to install all drivers but my 2x2 ABGN wlan card driver refuses to install correctly. I keep getting a code 10 this device cannot start message and have tried to reinstall the drivers several times, and tried a fresh Windows install as well using my Win 7 Ultimate 64 DVD with the same result. I called Lenovo support and they remoted in and tried as well and couldn't get it to work. They sent me a replacement 2x2 wlan card and it too won't accept the drivers. Has anyone run into this issue?

 

I'm going to try installing a copy of Windows 7 32 next and see if its a 64-bit driver issue. If that doesn't resolve this, I'm guessing my only option is to call the warranty guy on-site and replace the system board. If anyone knows another fix or some other source for these broadcom drivers, please let me know. Thanks

 

Maliha
Posts: 3,224
Registered: ‎07-31-2008
Location: Pakistan
0

Re: X120e ABGN Driver issue in Windows 7 Pro x64

Hi and welcome to the forum!


Try this, install the Hotkey Features, do a mandatory reboot, thereafter press Fn-F5 to radio on the wireless device, once that's done install the wireless driver.

 

Would be a good idea to check in the BIOS if the card is enabled in there.

 

Let us know the outcome.

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Punch Card
debacler
Posts: 10
Registered: ‎03-15-2011
Location: USA
0

Re: X120e ABGN Driver issue in Windows 7 Pro x64

[ Edited ]

I ran into this exact same issue. Replacing the system board isn't likely to help as this is a driver problem. I played around with a fresh load of 64-bit sp1, but couldn't get wireless to work. I'm almost positive that I tried enabling the radio first. I ended up reverting to the system image. I may try to get a clean install working again but I'm holding off for now as I'll probably have to send my x120e back for its flickering backlight.

Blue Screen Again
johnmaine
Posts: 4
Registered: ‎03-18-2011
Location: VA, USA
0

Re: X120e ABGN Driver issue in Windows 7 Pro x64

[ Edited ]

Thanks for the replies.

 

I installed a 32-bit copy of Windows 7 and the 2x2 ABGN driver off Lenovo's website installed properly and the card is working perfectly now. There seems to be an issue with the 64-bit driver they have posted on the x120e driver matrix. Lenovo is mailing me recovery CDs for Win 7 64 which I'll have to use on my SSD until they release (hopefully) a new version that fixes the code 10 issues on Win 7 64 fresh installations

 

Here's the link to the driver I am referring to:

 

Version 5.100.82.27 (84W007WW)

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-75618

 

If the mods can escalate this to Lenovo to fix the x120e's x64 drivers for fresh Win 7 installations, I'd appreciate it. 

 

Hope this info helps others that run into this same problem.

Punch Card
wyld
Posts: 77
Registered: ‎03-13-2011
Location: Atlanta, GA
0

Re: X120e ABGN Driver issue in Windows 7 Pro x64

When I installed my copy of WIn 7 SP1 64 bit, I downloaded the latest driver from Lenovo at the time and it is 5.60.350.21.  It worked great for me.

 

The product code is the same as yours 802.11a/b/g/n - broadcom 2x2 84W007W

 

I don't see it on Lenovo's site anymore so I uploaded it here if you want to give it a try:

http://www.megaupload.com/?d=76UQYCEG

x220 | 4286-CTO | i5-2520M | 8Gb G.Skill | OCZ SSD
Win 7 Home Premium SP1 64bit
Blue Screen Again
johnmaine
Posts: 4
Registered: ‎03-18-2011
Location: VA, USA
0

Re: X120e ABGN Driver issue in Windows 7 Pro x64

Thanks, tried the driver you uploaded. Unfortunately I had no luck. Same code 10 issue :smileysad:

Fanfold Paper
kubel
Posts: 21
Registered: ‎06-05-2010
Location: Michigan, USA
0

Re: X120e ABGN Driver issue in Windows 7 Pro x64

[ Edited ]

I too can confirm this is an issue.

 

Error code 10 after installing the driver from Lenovo's site on Windows 7 Professional 64-bit. I would appreciate it if Lenovo would escalate this issue and release drivers that work.

 

UPDATE: Since I still had my factory hard drive (I upgraded to SSD), I plugged it in via USB and tried installing the drivers that I know were working on that factory install. They didn't work. Same error 10.

Lenovo Staff
LANOgre
Posts: 287
Registered: ‎11-28-2007
Location: North Carolina, USA
0

Re: X120e ABGN Driver issue in Windows 7 Pro x64

Punch Card
debacler
Posts: 10
Registered: ‎03-15-2011
Location: USA
0

Re: X120e ABGN Driver issue in Windows 7 Pro x64

[ Edited ]

???

 

Nobody had a problem finding the driver on the download page. That same link appears a few posts up. The issue is that installing that driver results in a code 10 error in device manager for the wireless card.

Lenovo Staff
LANOgre
Posts: 287
Registered: ‎11-28-2007
Location: North Carolina, USA
0

Re: X120e ABGN Driver issue in Windows 7 Pro x64

Just put a 2x2 card (FRU 60y3251) into my X120e running Win7 Pro 65.

I uninstalled the previous wireless drivers, installed the card and booted.  Installed the Lenovo drivers, card works fine.