Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
ilzigum
Posts: 3
Registered: ‎03-02-2012
Location: Germany
0

X220 sound problems

[ Edited ]

Hello guys.

I'm hoping you can help me with some sound problems i occured.

I just don't get any sound from the build-in speakers from my x220.

Not even the test sound from windows.

If i plug in my external soundcard device i have no problem with the sound.

Also when i'm plugging in headphones directly to the notebook.

But when i remove them i still have no sound from the speakers.

 

Du you have any ideas what could be wrong?

I've already gone through the Support Website but nothing there helped (Might it be a hardware-fault? Doesn't seem like a software problem to me, because the sound on my headphones without extra drivers worked on the sound output).

 

greets

ilzigum

 

ps: just checked the microphone and this one does work very good

 

ps2: sound in oracle vm virtual box with the newest lubuntu doesn't work either...

lead_org
Posts: 20,905
Topics: 128
Kudos: 1,254
Solutions: 1,343
Registered: ‎12-19-2008
Location: Australia, Melbourne
0

Re: X220 sound problems

you have go into your sound option in control panel, and reselect the laptop speaker as the primary playback device, this option maybe disabled when you use usb sound cards.
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Paper Tape
ilzigum
Posts: 3
Registered: ‎03-02-2012
Location: Germany
0

Re: X220 sound problems

Yes, i tried this before and it didn't work.

Tried it again still doesn't work.

Bought the notebook just a few days ago and it didn't work from the beginning.

Fanfold Paper
jotero
Posts: 11
Registered: ‎02-14-2012
Location: Spain
0

Re: X220 sound problems

Hi: I had the same problem a few weeks ago after a motherboard replacement: they forgot to plug the internal speakers. Maybe yours is unpluged too. Regards
Paper Tape
ilzigum
Posts: 3
Registered: ‎03-02-2012
Location: Germany
0

Re: X220 sound problems

[ Edited ]

Thank you for your answer.

I have already thought about something like that.

I think i have to send the notebook to the support crew and let them check it...

Hope it's simple like that.

greets

Punch Card
Zerius
Posts: 16
Registered: ‎03-04-2012
Location: Vancouver
0

Re: X220 sound problems

I have the same problem with my speakers, except they sometimes work and sometimes don't. I could be surfing the web and running youtube in the back (silently because speakers don't work) and all of a sudden they start playing, and then cut out randomly in 10 minutes and not work again for a few days. 

The headphone jack always gets sound out though and I am familiar with speaker output settings.  

Punch Card
Zerius
Posts: 16
Registered: ‎03-04-2012
Location: Vancouver
0

Re: X220 sound problems

To further help the techs troubleshoot, it seems to be when I install the lenovo drivers for sound that this messes up. When I install Windows 7 normally it works fine, but after I use system update to install the Connexant software the sound never worked the same after, even when I uninstalled the driver from devmgmt

Punch Card
timpel_800
Posts: 23
Registered: ‎11-12-2012
Location: Nederland
0

Re: X220 sound problems

I found my X220 tablet also having sound problems this morning, when I and the laptop came out of sleep mode.

Yesterday everything worked fine. I've put the machine in sleepmode (just closed the lid) with headphones in. When trying to play music this morning, the haedphones still work, but no sounds trough the speakers. 
I did a reboot, but did not work. 
I reinstalled the drivers (latest connexant drivers from lenovo website) and a reboot, but no sound. 


Any more options to try?

I'm running windows 8.

 

Tim

What's DOS?
kakawa
Posts: 3
Registered: ‎06-21-2013
Location: United States

Re: X220 sound problems

this works for me:

Workaround is to select the Multistream mode from Realtek control panel, Device advanced settings

 

solution is from:

 

http://forums.lenovo.com/t5/X-Series-ThinkPad-Laptops/X230-No-Sound-Until-I-Go-To-Settings-To-Play-S...