Support in other languages: 
Reply
What's DOS?
Hibbelharry
Posts: 1
Registered: ‎06-01-2011
Location: Germany
Accepted Solution

X220 with USB3.0, no mSata SSD possible ?

Hello Board,

we have some i7 based X220 Notebooks here, equiped with integraded USB3.0 Controller. While we successfully upgraded the smaller variants of the X220 with mSATA SSD Drives from Intel, these aren't recognized in the i7 Configurations.

We tried this with multiple SSD Drives and multiple Notebooks, so I don't think we're talking about faulty units here, this seems to be a general problem. We also tried different bios versions, up to 1.16

 

Has anybody else made similar experiences ?

 

My simple assumption is the following: All WWAN Cards which share the same socket are USB based devices, while the mSATA SSD Drives are PCI Express baesd. My first guess is that the PCI Express Lane connected to the mini Express Card socket in the smaller configurations is wired to the USB 3.0 Controller Chip. If this is right, i guess there is no solution to our problem.

 

Any Input appreciated.

 

Greetings!

Hibbelharry

 

 

Community SuperMod
bananaman
Posts: 3,643
Registered: ‎04-25-2008
Location: San Francisco
0

Re: X220 with USB3.0, no mSata SSD possible ?

Hi Hibbelharry, and welcome to the Lenovo User Community!

 

Interesting. I only have an i7 X220 without mSATA to look at here. Can you compare what you see for the USB 3.0 controller and mSATA in Device Manager>View>Devices by connection on the i7 and i3/i5 types?

I don't work for Lenovo. I'm a crazy volunteer!
Retired Employee
JameZ
Posts: 3,110
Registered: ‎07-11-2010
Location: Malaysia

Re: X220 with USB3.0, no mSata SSD possible ?

@Hibbelharry,

Katarina (German Lenovo Community Lead) told me something similar about this topic yesterday. Were you the one which was discussing this matter on the German forum?

I did a quick search on google and found this a similar discussion too on NBR forum.

http://forum.notebookreview.com/lenovo-ibm/582887-x220-msata-not-possible-i7-usb3-0-a-4.html

Andrew,

Is it possible to request the guys at NBR to discuss it here so I can escalate this issue to engineering for their feedback on the mSata drives? I went through the NBR Forum last night and some mentioned their i7 is able to detect the mSata drive.

Maybe just post a link there to point them here to discuss this issue at our forum?

Thanks heaps Andrew.

//JameZ

Check out the Community Knowledge Base for hints and tips.


Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!




W520 | 4176-38U | i7 - 2720QM | Quardo 1000M | 8GB RAM | 60GB OCZ Agility 3

SCSI Port
NSGundy
Posts: 32
Registered: ‎06-03-2011
Location: UK

Re: X220 with USB3.0, no mSata SSD possible ?

[ Edited ]

Hi everyone,

 

I do have a X220 i7 with USB 3.0 and an Intel 310 80GB mSATA that I installed myself. The X220 was purchased in the US, the mSATA was delivered from Germany. I am using AHCI and not the UEFI mode in the BIOS (this was the factory default). The mSATA as well as the USB 3.0 port are both working fine, although I have only tried USB 2.0 devices so far.

 

Best Regards,

Gundy 

X220 4286 CTO, i7-2620M, 8GB RAM (2x4), 320GB HDD+Intel mSATA 80 GB, IPS display, BT 3.0, Intel 6205 WiFi, Finger Print Reader, Win7 Pro 64
Retired Employee
JameZ
Posts: 3,110
Registered: ‎07-11-2010
Location: Malaysia
0

Re: X220 with USB3.0, no mSata SSD possible ?

@NSGundy,

Thanks for posting your feedback here. Maybe you can provide us your MTM and the i7 Processor here so we can compare more when customers are posting about their issue.

Thanks
James

Check out the Community Knowledge Base for hints and tips.


Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!




W520 | 4176-38U | i7 - 2720QM | Quardo 1000M | 8GB RAM | 60GB OCZ Agility 3

Community SuperMod
bananaman
Posts: 3,643
Registered: ‎04-25-2008
Location: San Francisco
0

Re: X220 with USB3.0, no mSata SSD possible ?


JameZ wrote:

Andrew,

Is it possible to request the guys at NBR to discuss it here so I can escalate this issue to engineering for their feedback on the mSata drives? I went through the NBR Forum last night and some mentioned their i7 is able to detect the mSata drive.

Maybe just post a link there to point them here to discuss this issue at our forum?

Thanks heaps Andrew.

//JameZ

Done!

I don't work for Lenovo. I'm a crazy volunteer!
Punch Card
vnwhite
Posts: 1
Registered: ‎06-09-2011
Location: USA

Re: X220 with USB3.0, no mSata SSD possible ?

[ Edited ]

UPDATE: Yesterday I received my new X220 with a Core-I7 and installed a new Intel 310 80GB mSATA drive from Newegg and the BIOS would not detect the mSATA SSD.   I updated to the latest 1.16 BIOS and tried every BIOS setting I could think of and the drive will not appear as a valid BIOS boot drive.

 

I tried reseting the BIOS to factory defaults multiple times, changed the SATA mode to compatibility and AHCI, disabled and enabled H/T, enabled and disabled every option under "I/O port access", tried different sticks of memory, removed the Wifi card, with and without the 320GB stock drive and the 310 SSD will not appear as a detected device under the "Startup->Boot" area and nothing is excluded from the boot priority.  Pressing F12 and bringing up the boot menu will only ever show the spinner drive "ATA HDD0" and PCI LAN and the Diagnostic splash post screen only shows the Fixed Disk spinner drive.



MTM# 4286CTO

FRU# 04W2109

CPU Intel Core I7-2620M

BIOS 1.16

 

INTEL 310 80GB SSD from NEWEGG

PART# SSDMAEMC080G2C1(on box) SSDMAEMC080G2 (on part sticker)

SA: G11970-503

FIRMWARE# 02M3

DATE 03-APR-2011

 

Thanks,

Vince

Lenovo Staff
someotherguy
Posts: 2,399
Registered: ‎10-29-2009
Location: NC
0

Re: X220 with USB3.0, no mSata SSD possible ?

[ Edited ]

I have a 4286 with core i7 and USB 3.0.  I installed the the Intel 80GB mSATA drive and it works fine for me.  So I wonder about the following things:

 

1.  can you please go to BIOS F1 setup, press F9 to load default settings, and then F10 to save and exit.  Does the behavior change?

2.  how exactly are you determining that BIOS does not detect it as a valid boot drive?  Are you trying F12 boot or something else?  Please be specific.

3.  if you remove the 2.5" HDD as an experiment, does the behavior change?

4.  what is the exact model number of the mSATA SSD as reported on the sticker?  I am using SSDMAEMC080G2L with firmware 02M3

Paper Tape
supermiguel
Posts: 3
Registered: ‎06-09-2011
Location: Tampa, FL
0

Re: X220 with USB3.0, no mSata SSD possible ?

i have 4286, installed an tested msata drive (the one that comes with the samsung 9 series laptop) and it doesnt get recognized.. tried installing it multiple times and the bios doesnt detect it, i did loaded defaults and same thing...

erik
Posts: 5,013
Registered: ‎11-23-2007
Location: United States

Re: X220 with USB3.0, no mSata SSD possible ?

as a note for everyone,

 

please be as detailed as possible when reporting any issues you're having with mSATA devices.   lenovo engineers cannot read minds, tea leaves, or crystal balls to know exactly what you have in your systems.   the more info provided upfront, the better.   if you don't have the info you need available, please take the time to gather it before posting.   quick notes only take longer in the end.

 

 

here is a preliminary list of information to provide:

- 4-digit machine type (ie: 4286, 4287, 4289, etc.)

- processor

- BIOS revision

- whether or not you see the drive in BIOS > Startup > Boot (checking both the Enabled and Disabled lists)

- tests performed (if any)

- mSATA device manufacturer

- mSATA device model number

- mSATA device firmware revision

- whether the mSATA device was purchased through a reseller or came installed in another system

 

thanks! :smileywink:

this is the least untruthful answer i can give.Microsoft MVP