Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
redletter
Posts: 5
Registered: ‎08-09-2012
Location: Maryland
0

Re: X230 expresscard adressing (eGPU)

I too am standing by for this bios update to support eGPU functionality.  On a related tangent, what exactly are we dealing with here in terms of the speed of the expresscard slot.  I'm reading a bunch of different x1 1.0/opt, etc and have not seen any direct comment on what speeds the expresscard slot is capable of working at.  I've seen the release notes of expresscard 2.0 in 2009 and I can only hope and assume this has been implemented with the new x230t. 

 

I wish they would annouce their plans to release new itterations of laptop models... With thunderbolt and other technologies coming out, it would be nice to know if there is another update for the x230 series or if there will be another tablet pc slated to release.

 

Paper Tape
redletter
Posts: 5
Registered: ‎08-09-2012
Location: Maryland
0

Re: X230 expresscard adressing (eGPU)

No longer standing by, I purchased my X230T.  I'm excited to get it here in a couple weeks and I look forward to the work the Lenovo Bios guys are putting into this fix.  THANKS

Paper Tape
redletter
Posts: 5
Registered: ‎08-09-2012
Location: Maryland
0

Re: X230 expresscard adressing (eGPU)

Any updates to the timeline for the release of this fix?

Lenovo Staff
someotherguy
Posts: 2,555
Registered: ‎10-29-2009
Location: NC

Re: X230 expresscard adressing (eGPU)

It was released yesterday.

 

X230 Windows:  http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS029187

X230 ISO:  http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS029188

 

new BIOS for X230 Tablet is coming soon...

 

Paper Tape
redletter
Posts: 5
Registered: ‎08-09-2012
Location: Maryland
0

Re: X230 expresscard adressing (eGPU)

Thanks for the update and putting the effort into this fix, can't wait to try out the tablet version soon.  Anyone using this fix try out the eGPU fuctionality?

Ctrl-Alt-Del
celli
Posts: 9
Registered: ‎07-09-2012
Location: Germany

Re: X230 expresscard adressing (eGPU)

I am using the new Bios and my eGPU is runnig fine :smileyhappy:

Paper Tape
redletter
Posts: 5
Registered: ‎08-09-2012
Location: Maryland
0

Re: X230 expresscard adressing (eGPU)

Good to hear, what is your setup and is yours running at 2.0 speeds?

What's DOS?
bradburnc
Posts: 3
Registered: ‎07-31-2012
Location: Saint Louis, MO
0

Re: X230 expresscard adressing (eGPU)

Please share your configuration with us.  Inquiring minds want to know.

Ctrl-Alt-Del
celli
Posts: 9
Registered: ‎07-09-2012
Location: Germany

Re: X230 expresscard adressing (eGPU)

My Configuration is no secret so here we go:

X230

I5 3320

4 GB RAM

500GB HDD + 128 GB Msata

 

And for GPU Power a Nvidia GTX 560 with a PE4L 2.1b. The GPU is running fine and witch PCI Express 2.0 Speed.

http://www.imagebanana.com/view/vtkmtkoj/runnigegpu.png

This picture show PCI Express 1.1 because the eGPU is ideling on the Desktop bus as soon as I start a 3D Game it changes to PCI Express 2.0

Lenovo Staff
someotherguy
Posts: 2,555
Registered: ‎10-29-2009
Location: NC

Re: X230 expresscard adressing (eGPU)

BIOS for X230T that fixes this issue:

 

ISO:  http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS029684

Windows:  http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS029683

 

I'm marking this thread as "solved".