Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
farzan
Posts: 2
Registered: ‎03-03-2010
Location: Sweden
0

X301 Win7 x64 Ericsson F3507G WWAN issues

A lot of posts on this topic...

 

Context:

fresh Win7 x64 install on Thinkpad X301 4057-WBR. All downloads & drivers applied. All devices visible and working properly according to device manager. All prereqs for AT&T WWAN HSPA driver installed, except KB948278 as this is a patch for Vista - not Win7.

 

Problem:

Fn+F5 shows WIFI and BLUETOOTH but not WWAN radio. Immediately after reinstalling hotkey driver, or chipset driver, WWAN radio is visible and powered off. Pressing Power on does nothing. Press Fn+F5 again and WWAN radio is gone.

 

Conclusion: unable to power on Ericsson F3507G device when running Win7 x64. Device was working perfectly under Vista. A patch is urgently needed - I'm sure I'm not alone on this one.

 

Reading other posts on same topic:

- BIOS reset to defaults does nothing. All ports/devices are already enabled.

- Installing Ericsson MD400 modem driver which includes Wireless Manager does nothing. Device not detected.

 

Seriously, this is the only reason I got this laptop to begin with - and now it's the only thing not working.

Paper Tape
Sitkarev
Posts: 2
Registered: ‎08-07-2009
Location: Cyprus
0

Re: X301 Win7 x64 Ericsson F3507G WWAN issues

I'm experiencing the same issue. It's very annoying.

Fanfold Paper
drorx301
Posts: 4
Registered: ‎11-26-2009
Location: Israel
0

Re: X301 Win7 x64 Ericsson F3507G WWAN issues

Hi

 

I experienced with the same issue , I reinstalled my x301 again win WIN 7 x64

but I exclude lenovo Power managment applicatoin , I installed only the power mangment driver 1.6

 

and since them (4 month) i don't have this problem ..

 

Dror

Fanfold Paper
farzan
Posts: 2
Registered: ‎03-03-2010
Location: Sweden
0

Re: X301 Win7 x64 Ericsson F3507G WWAN issues

[ Edited ]

Thanks for feedback. Here's my status:

 

I installed system update 4.0 which made it a lot easier manage drivers etc. I have also manually uninstalled the power manager application, but unfortunately this does not help. Here's what happens with/without power manager:

 

1) after boot, all three radio icons above F6-F7 are on

2) hitting Fn+F5 shows wifi on, bluetooth on, and wwan off

3) clicking power on for wwan does nothing (some hdd acivity), window closes

4) repeat steps 2-3 and wwan status changes to "disabled"

5) hit Fn+F5 again and wwan radio is gone. Repeat.

 

Suggestions? This laptop is heading for early retiement...

Paper Tape
Sitkarev
Posts: 2
Registered: ‎08-07-2009
Location: Cyprus
0

Re: X301 Win7 x64 Ericsson F3507G WWAN issues

Dear Support I didn't receive any news on how to fix the problem.
billbolton
Posts: 1,861
Topics: 69
Kudos: 203
Solutions: 104
Registered: ‎12-02-2007
Location: Sydney, Australia - Best Address on Earth
0

Re: X301 Win7 x64 Ericsson F3507G WWAN issues


Sitkarev wrote:


Dear Support I didn't receive any news on how to fix the problem.


This forum IS NOT a Lenovo support channel, it's a user mutual support forum.

 

Please refer to the user guidelines for the forum.


Cheers,

 

Bill

------------------------------
I don't work for Lenovo
Paper Tape
TomPaine
Posts: 5
Registered: ‎02-09-2009
Location: Australia
0

Re: X301 Win7 x64 Ericsson F3507G WWAN issues

Still no answers? I've been strugglling with this for about three whole days

 

X301 2777CTO

Windows 7 64 bit

 

And thank you billbolton for your valuable observations