Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Dug
Fanfold Paper
Dug
Posts: 10
Registered: ‎04-07-2008
Location: USA
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

Maybe the update to the bios made it worse.  For me when I updated the video driver, I didn't notice the flicker for a few days.  But once I downgraded to an old one it went away right away.  To be safe, I won't be updating my bios any time soon either  :-)
I'm still on BIOS 2.1.5.
Punch Card
dewey134
Posts: 11
Registered: ‎05-25-2008
Location: Charlotte, NC
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

I just picked up an X60 and overall this is a great step up from my X31 and T42, but I have noticed this exact same problem as what you mention.
It seems like the screen flickers and then fades to black screen while on battery power. I have used the machine for hours straight plugged in and have had no occurrences of the flicker/die. I will then just power off the machine and restart it. It will work fine for awhile and then ever so often the screen will begin to flicker every 5-10 minutes or so.

I've only had the lappie for less then 2 weeks so I really haven't put it thru the its paces..........

Hope someone comes up with a definite solution, cause I have no idea what it could be.


Paper Tape
brovig
Posts: 4
Registered: ‎05-26-2008
Location: Toronto, Canada
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

I am also having this problem - not so much with flickering but with complete screen blackouts. It's happening quite frequently (2-3 times a day) and it seems to be limited to, or certainly more common, when I'm on battery power.
 
I thought first that it was related to a recent update of the Presentation Director (v 3.06) but after reading the posts here I'm wondering if it's related to the Intel graphics driver or the BIOS, both of which had updates in the past few weeks.
 
I have spoken to Lenovo tech support and they had no recommendation other than re-installing the operating system! They were not able to point me to older versions of any of the drivers.
 
Is the previous BIOS available for download somewhere? Or/and the previous graphics driver? I think Intel may have older versions available on their site.
 
Any other ideas?
dsp
SCSI Port
dsp
Posts: 40
Registered: ‎04-05-2008
Location: Germany
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

[ Edited ]
Hi,
you might just want to give it a try to roll back your video driver (in windows device manager there is this option for each listed device in properties). Depending on what the latest release before the current was, you might be successful. Unfortunately for me it was a very backlevel driver from 2005. However this fixed this problem.

I run the latest BIOS and this doesn't seem the reason.

I was not successful, finding a place where to download specific versions. Lenovo Support in Germany could also not help.

There is one more recent driver from Intel, and one backlevel (that Lenovo never issued). I'm not sure, if we can just take the plain Inteldriver. Don't know if something has been adjusted in the Lenovo provided ones?

regards


Message Edited by dsp on 05-27-2008 01:22 AM
Paper Tape
aruoba
Posts: 7
Registered: ‎06-03-2008
Location: Chevy Chase, MD
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

Hello all...
 
I am having EXACTLY the same problem with my X60, which is about 1.5 years old now. I have not had this problem until recently (2-3 months). I have extended warranty with Lenovo and I sent my laptop for repairs TWICE. My understanding is they changed the planar card at least once. And I have the same problem still. To confirm a few things, this ALWAYS happens when I am on battery power and putting on stanby solves the problem. This smells like a software problem, especially after being "repaired" twice. And Lenovo tech support does NOT know about this issue.
 
I will try rolling back my driver for the display card and will keep you posted.
 
 
Punch Card
dewey134
Posts: 11
Registered: ‎05-25-2008
Location: Charlotte, NC
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

Rolled back my video drivers and the flicker appears to have gone away. Started with driver 4926 dated 2007 and rolled back to 4450 dated 2005.
Been using my machine heavily for the past 3-4 hrs and no flicker and dying.

Thanks to all of you guys for doing the deep dive to figure out what this was. Hopefully this is the real deal fix......
Paper Tape
vy0123
Posts: 3
Registered: ‎06-07-2008
Location: AUS
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

I have the exact same problem and more, hope someone at lenovo is noticing.

1) the x60 laptop screen flickers/skips intermittently
2) it then goes blank completely which I work around by having both internal and external video on
3) windows media player video is blank, I only get the audio stream
Punch Card
dewey134
Posts: 11
Registered: ‎05-25-2008
Location: Charlotte, NC
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

You may want to try what some have suggested here. Roll back your video drivers to an earlier version. I waited a bit to determine what the problem was, then decided to try this and since I have rolled mine back, no flicker and die. So I must assume it had something to do with that vid driver version.

I don't know what it takes for Lenovo to start looking into issues, problems, workarounds but they may come up with a fix/solution or download one of these days.  

I guess that's a question for one of the Lenovo folks to address..
Administrator
Mark_Lenovo
Posts: 7,972
Registered: ‎11-19-2007
Location: RTP, North Carolina
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

All,
 
We can try to recreate the symptom this week - is there consensus on what actions trigger the flickering or blackout with regularity?
 
I understand the opinion that the variable may be the video drivers. 
 
Thanks.
 
Mark
 
 
____________________________________________

ThinkPads: S30, T43, X60t, X1, W700ds, IdeaPad Y710, IdeaCentre: A300, IdeaPad K1
Mark Hopkins
Program Manager, Lenovo Social Media (Services)
twitter @lenovoforums
English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество
dsp
SCSI Port
dsp
Posts: 40
Registered: ‎04-05-2008
Location: Germany
0

Re: X60 - Screen flickers and screen shutoff - problem with power management or hardware failure?

[ Edited ]
Hi Mark,
for me, I did a couple of tests. I initially though it would be either BIOS or graphic card, which both were updated about the same time to the latest level (I did that in spring time).
Video: v6.14.10.4926
Colleague of mine is still using one level of older drivers. I tried to find a backlevel driver from Lenovo to pin this problem to one particular release of the driver, but failed to obtain it from any source, nor from Lenovo support.

I than rolled back the video driver to a very old one (the only one that was available on my machine):
6.14.10.4450 from 14.12.2005
but still have the latest BIOS (2.16) installed. The problem doesn't show up anymore...

... looks really like the graphics driver would cause this, as I didn't change any other driver than this one to "workaround" the problem. Descriptions of other useers in this thread look similiar.

regards dsp


Message Edited by dsp on 06-08-2008 01:53 AM