Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
AdamAmodeo
Posts: 8
Registered: ‎02-11-2013
Location: Toronto Ontario Canada
0

Re: x220 does not resume from sleep

[ Edited ]

All those hard resets couldn't have been good for your harddrive. Keep us posted if you can fix it again with drivers and bios updates. Sakowitzm you mentioned your problem spontaneously resolved? Is that still the case? When did you buy yours?

Fanfold Paper
sakowitzm
Posts: 18
Registered: ‎05-13-2012
Location: Chantilly, VA
0

Re: x220 does not resume from sleep

Yes, it is still the case, thank goodnes..

I got my brand new x220 in late April, 2012.  Problem began about two weeks later.

At the same time, began having keyboard problems.  So they replaced the keyboard.

When they came out to replace the motherboard, I refused to let them swap out/in -- the one they wanted to swap in was refurbished, and undoubted older than my brand new motherboard.

 

Problem spontaneously resolved about four weeks after replacing the keyboard.  Not sure of relationship to that.

 

Good luck.

mjs

Fanfold Paper
ch_123
Posts: 6
Registered: ‎06-18-2008
Location: Ireland
0

Re: x220 does not resume from sleep

This started on my X220 (which I bought in August 2011) a few weeks ago. Ironically, it started about 2 weeks after I sent it to Lenovo to get its screen replaced. What really pisses me off about this whole thing is that I've already had to get the motherboard replaced in June 2012 - due to a variety of problems such as the system clock randomly slowing down, the system refusing to turn on sometimes, and intermittent problems with the SATA controller that caused the laptop to think that it no longer had a disk drive...

Fanfold Paper
AdamAmodeo
Posts: 8
Registered: ‎02-11-2013
Location: Toronto Ontario Canada
0

Re: x220 does not resume from sleep

Sakowitzm thanks for the quick reply, any chance you know which version BIOS and ME firmware you're running?

Fanfold Paper
sakowitzm
Posts: 18
Registered: ‎05-13-2012
Location: Chantilly, VA
0

Re: x220 does not resume from sleep

Sure thing.  BIOS is LENOVO 8DET59WW (1.29), 4/2/2012.

Don't know how to find ME firmware.  Is it associated with the disk drive?

That looks like EC2ZB70R.

 

mjs

What's DOS?
nsnellma
Posts: 1
Registered: ‎03-22-2013
Location: Finland
0

Re: x220 does not resume from sleep

Is there still no working solution to these problems? I've been having the same issues as everybody else in this thread for the past year or so. Running Ubuntu 12.04 on an SSD. Updated to the latest BIOS last week. No change.

Blue Screen Again
daragh
Posts: 19
Registered: ‎05-21-2010
Location: Chicago, IL, USA
0

Re: x220 does not resume from sleep

What worked for me was Network Connections | Wi-Fi Properties | Configure... | Power Management | "Allow the computer to turn off this device to save power" - Check the box.
I tried a LOT of other things, but this was my magic 'bit'.

 

I have seen other solutions referring to BIOS, Video and SSD drivers, but I believe I have the latest.

 

Win8 64-bit Lenovo T430 Samsung SSD

Fanfold Paper
AdamAmodeo
Posts: 8
Registered: ‎02-11-2013
Location: Toronto Ontario Canada
0

Re: x220 does not resume from sleep

[ Edited ]

New systemboard installed a couple days ago and it's been working fine so far on BIOS 1.28

Fanfold Paper
AdamAmodeo
Posts: 8
Registered: ‎02-11-2013
Location: Toronto Ontario Canada
0

Re: x220 does not resume from sleep

The problem has returned

What's DOS?
wereHamster
Posts: 1
Registered: ‎04-06-2013

Re: x220 does not resume from sleep

Linux user here. For me the problems started about a month ago after I updated the kernel and created a new EFI boot entry using efibootmgr. A few days ago when a new kernel came out I tried to update it like always, but now efibootmgr refused to create the boot entry. You may have heard that linux can brick samsung laptops when booted with EFI. The bug is in the EFI firmware which can not handle if the EFI storage is near full, so the linux kernel now won't let you write to it if it's >50% full, and that's what was happening to me. That meant the EFI storage in my X220 is >50% full. So I looked what's there and what I can delete. Turns out, the kernel writes crash logs into the EFI storage (because it's persistenst it survives reboot so you can inspect the stacktrace etc). I had a few of these. I deleted them all and since then the laptop can resume!

 

Relevant info about EFI variables/pstore: http://womble.decadent.org.uk/blog/the-terrible-state-of-efi-variable-storage.html and http://lwn.net/Articles/421297/

 

 

TLDR: Try to free some EFI variable storage, it may help.

 

Instructions for linux. Run everything as root. Don't hold me responsible any of these commands brick your laptop.

 

# First clear the pstore

mkdir -p /dev/pstore

mount -t pstore pstore /dev/pstore

ls /dev/pstore # <- Nothing important should be here, but check first anyway

rm /dev/pstore/*

 

 

# Next some EFI variables. These are used/created by pstore, but I've had them even though I deleted the pstore data using the above commands. YMMV.

rm /sys/firmware/efi/efivars/dump-type0-*