Support in other languages: 
Reply
Paper Tape
db3344
Posts: 4
Registered: ‎01-12-2009
Location: Portland, OR
0

x61s wifi doesn't work with power cable unplugged from computer

i purchased an x61s in november and one of the things i read was it has a weak wifi antenna.  i thought this was the main problem when i traveled with the computer and certain internet sites wouldn't connect at airports, coffee shops, etc.  i just thought maybe those routers were being overloaded. 

 

however, i have recently discovered that while sitting at home right next to the wireless router with a 100% signal that i can get on the internet and go to any site i like, but if i pull the power cord out of the side of the computer i can no longer go to certain sites like ebay or i might not be able to get on the internet at all.

 

i took it into a lenovo tech guy today and the thing worked perfect for him in his shop running off battery power.  it connected to the internet and was able to go to sites like ebay no problem.  but when i got home i was still having the same problem i did before.  works fine plugged in, not so well unplugged.

 

has anyone had this happen.  i'm have no idea how it could work in one place and not the other.  and why would unplugging the power cause the wifi card to have limited connections or none at all.  i have the power setting at max so its not like the computer is trying to save enrgy.

Community SuperMod
bananaman
Posts: 3,635
Registered: ‎04-25-2008
Location: San Francisco
0

Re: x61s wifi doesn't work with power cable unplugged from computer

Two things to try:

 

1. Make sure you have followed the instructions to install the latest drivers for your particular WiFi card.

 

2. Go to Device Manager, Select Network Adapters/Wireless card, Advanced tab and set Power Save Mode Off.

 

Where did you read that the X61s has a weak WiFi antenna? That's just not true. I've used an X61s all over the planet (North America, Europe, Asia), and the WiFi has been awesome!

I don't work for Lenovo. I'm a crazy volunteer!
Paper Tape
db3344
Posts: 4
Registered: ‎01-12-2009
Location: Portland, OR
0

Re: x61s wifi doesn't work with power cable unplugged from computer

thanks for the tips.  i just tried all this and the results are still the same.  i checked my router and its a "g" router so i know thats up to speed.  it just seems funny that it worked at the IBM service center yesterday but does not work at my house when on battery power.  it boggles me that unplugging the ac cord limits the access to certain sites or it just won't work at all.   

 

as far as hearing about the weak wifi, i read that in a couple reviews when researching the computer before i bought it.  even yesterday when i took it in for service it was getting 80% signal strength and the T61 sitting right next to it was at 99% and the router couldn't have been 20 feet away.

Paper Tape
metoo
Posts: 1
Registered: ‎08-10-2011
Location: US
0

Re: x61s wifi doesn't work with power cable unplugged from computer

I have the same problem with my x61,

when I am next to a router it works fine however when I am away or in another room, it does not work..

 

I suspect the antenna or cable inside of the laptop might be the reason of weak reception because my iPhone works in any place that my laptop cannot connect.

 

Have you found the reason?

lead_org
Posts: 20,352
Topics: 128
Kudos: 1,201
Solutions: 1,277
Registered: ‎12-19-2008
Location: Australia, Melbourne
0

Re: x61s wifi doesn't work with power cable unplugged from computer

try to take off the keyboard and palmrest, and check whether your wireless card cables are all correctly connected.

http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles_pdf/42x3550_04.pdf
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft