(826 Views)

L220x SoftOSM screen rotation problem

Compatibility, Configuration Settings, Display Modes, How To, Troubleshooting

Question

I was showing off the screen rotation feature on the L220x but then found that it would not return to landscape orientation. I tried using the SoftOSM but the orientation button was greyed out. It had been OK before.
 
Then I remembered I had recently been prompted to download and install an update to the SoftOSM.
I uninstalled it and reinstalled the original version and at once the screen returned to landscape.
 

Answer

While regressing to a prior, known to work conifiguration of video driver and SoftOSM may resolve a particular situation, the general recommendation is to update all components to latest level.
1. make sure you have the latest softOSM version (use the Live update button)
2. check the rotation and resolution buttons to see if they are enabled - they should be, but if not, you may need to reboot
 
In the very first software versions, Windows screen orientation would be sync'd to physical orientation.  But that was deemed confusing because there was no way to override with the user's preference (i.e., you couldn't rotate the screen to portrait mode if you were physically in landscape mode).
 
Support for rotation is complex - there are many video cards, driver versions, Operarting system and fixpack combinations in addition to versions of SoftOSM.  The display driver must support rotation and when you are in the process of updating crucial components of your OS, (such as installing a Service Pack), that support may be non-existent or temporarily disabled. Your display driver may even have been replaced by or updated to a Microsoft generic.
 
If auto-rotation is checked but greyed-out, it means the user preference is to auto-rotate, but the system doesn't currently support it. (drivers and SoftOSM may need to be updated).