cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gusevmk
Paper Tape
Posts: 2
Registered: ‎08-13-2019
Location: RU
Views: 181
Message 1 of 3

Lenovo Flex System. Trouble with SNMP authentification "snmpwalk: Unknown user name"

Hello, I have troubles with snmp authentification on blade chassis Lenovo Flex System. I have created account, set SNMP settings in User Settings. After trying connect to host via snmpwalk and getting error:
# snmpwalk -v3 -l authPriv -u snmpuser -a SHA -A "******" -x AES -X "******" <my host IP>

snmpwalk: Unknown user name

 

We have other same chassis, with same settings and same firmware version - it works.. Only difference is that on problem chassis I get error, when try change user settings (Mgt Module Managmet -> User Accounts -> Click on User name -> Click ok :

 

User properties: An error occured and the user account provisioning data could not be retrieved

 

In cli there is no this error.

Can you help me - how can I diagnose trouble?
Restart CMM does not helped.

 

Hardware:

Manufacturer ID: 19046

Product ID: 1032

Hardware rev: 8.0

 

Firmware:

Build ID: 1AON26A

Release date: 01/22/2019

Version: 2.1.0

Lenovo Employee 1337h4x
Lenovo Employee
Posts: 67
Registered: ‎12-05-2016
Location: US
Views: 153
Message 2 of 3

Re: Lenovo Flex System. Trouble with SNMP authentification "snmpwalk: Unknown user name"

If you have centralized management, LDAP or Lenovo XClarity Administrator, the local user authentication is disabled.

For SNMP you will need local users, so ideally you should have the system running in decentralized mode, so that each management device can have its own local accounts.

 

On the downside, each of your (up to) 14 nodes will now have individual user account databases that could have unique passwords and expiration dates.

gusevmk
Paper Tape
Posts: 2
Registered: ‎08-13-2019
Location: RU
Views: 135
Message 3 of 3

Re: Lenovo Flex System. Trouble with SNMP authentification "snmpwalk: Unknown user name"

Yes, we have LDAP authentication and XClarity, but in Global User Settings I did set authentication method is "External first, then local authentication"
+ We have other ~ 15 chassis, with LDAP and XClarity - all works fine... 
When I trying connect to cmm via ssh or web with user snmpuser - it works. Problem only with connect via SNMPv3

 

SNMPv1 - works fine. 

Check out current deals!


Shop current deals

Top Kudoed Authors