English Community

Datacenter SystemsConverged Systems - HX Series
All Forum Topics
Options

160 Posts

04-23-2015

JP

710 Signins

6030 Page Views

  • Posts: 160
  • Registered: ‎04-23-2015
  • Location: JP
  • Views: 6030
  • Message 1 of 3

Firmware restriction for HX Series

2016-05-24, 3:42 AM

Hi,

 

From HX series release notes describe current shipping firmware version below.

https://download.lenovo.com/servers_pdf/lenovo_converged_hx_series_release_notes.pdf

 

Now shipping hardware implement uEFI 1.1(TCE106KUS) and IMM2 1.72(TCOO10H).

 

Can we upgrade these firmware to latest version? or do we have any restriction for HX series? (lik stay firmware level to specific AHV/foundation combination)?

At May 2016, latest uEFI 2.01(TCE122W) and IMM2 2.50 (TCOO16P) are released.

 

From release notes, "You must upgrade the Nutanix NOS to version 4.5.2.3 or later in order to take advantage of some critical fixes." are described. If we ugrade latest uEFI/IMM2 version, do we need update Nutanix NOS first then update firmware?

Because previous release note (at Fib 2016) had similar description but Nutanix NOS version is not 4.5.2.3 but 4.5.2. So would like to know any restriction (or relation) for system firmware and updating uEFI/IMM2.


 

Thank you.

Solved! See the solution
Reply
Options

5 Posts

02-19-2016

Austin

11 Signins

184 Page Views

  • Posts: 5
  • Registered: ‎02-19-2016
  • Location: Austin
  • Views: 184
  • Message 2 of 3

Re: Firmware restriction for HX Series

2016-05-28, 16:11 PM

There is a problem in UEFI 1.2. The workaround is to first install NOS version 4.5.2 or later first and then you can upgrade the UEFI and IMM. This is per the release notes.

 

This problem has been rectified in the latest UEFI 2.01. I would still recommend upgrade the NOS version first and then upgrade the firmware.

 

Mike Perks

Reply
Options

160 Posts

04-23-2015

JP

710 Signins

6030 Page Views

  • Posts: 160
  • Registered: ‎04-23-2015
  • Location: JP
  • Views: 6030
  • Message 3 of 3

Re: Firmware restriction for HX Series

2016-06-01, 1:44 AM

Hi, Mike.

Thank you for youre replay and ok I understand.

We should update NOS to 4.5.2 or later at first, and after that, we are able to update uEFI/IMM2 version from factory shipping version to the latest. It have no dependency to specific NOS version.

 

 

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete