Motorola Community

Older Devices ArchiveDEFY™ with MOTOBLUR™ (Non-U.S.)
All Forum Topics
Options

1 Posts

12-05-2011

0 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎12-05-2011
  • Location:
  • Views: 0
  • Message 1 of 1

Strange screen problem in Defy

2011-12-14, 18:03 PM

Hi!

Few weeks ago I noticed  my screen was dark and it did't light up when I pushed the power button.  I thougt my battery was just empty and I tried to reload it. When I  connected my charger, my phone turned on and the "M" logo started  to blink normally. I dialed my PIN number and phone behaved normally for 10 minutes.

Suddenly the screen stopped responding to touch and got quite dark. Yet I was still able to see things on screen. Then it slowly  got darker and darker until it was completely black. After that I tried  to push the power button but the screen didn't light up, only the 4 buttons were lit.

I noticed I was still able to unlock the screen or answer  phonecalls sliding my finger from left to right on the correct area of  the screen, although it remainded black all the time.

I  tried to remove my battery and reinstall it after few minutes but problems mentioned above remain. It works just few seconds after start, but then it freezes. If I wait several hours before reinstalling battery it works for 10 minutes. It seems like something inside my phone is overheating and then cools down after battery is removed.

I tried to contact Motorola Service in Europe, but I can't log in. I have set up 2 different accounts but either one of them isn't working. I either get no message or: "The username or password that you entered is incorrect or  your account has been disabled.". Is there any other way to contact them? Calling is not an option because of my english talking skills.

All help is appreciated, Thank you!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete