Motorola Community

Older Devices ArchiveMoto Blur PhonesDEVOUR™ with MOTOBLUR™
All Forum Topics
Options

2 Posts

12-06-2010

0 Signins

0 Page Views

  • Posts: 2
  • Registered: ‎12-06-2010
  • Location:
  • Views: 0
  • Message 1 of 3

Battery Issue?

2010-12-06, 0:43 AM

I've had this phone since mid April and so far I've had to replace it once, hard reset it more than 8 and now this.

I go to charge my Devour, before when I bought it, it would charge pretty good. Keep a steady charge going and I would be happy. NOW I plug it in and it says connected then right after disconnected and back and forth for what seems to be ever! It will only charge if the wire it twisted in a special way. Before you yell at me "ITS A WIRE ISSUE NUMB NUTS" I've used other peoples chargers. Same thing.

Do you think its in my phone, my charger or battery?

Reply
Options

379 Posts

07-21-2009

0 Signins

0 Page Views

  • Posts: 379
  • Registered: ‎07-21-2009
  • Location:
  • Views: 0
  • Message 2 of 3

Re: Battery Issue?

2010-12-09, 15:41 PM

It sounds like the Charger has a short in it and it's preventing your Devour from Charging....

Reply
Options

1 Posts

01-12-2011

0 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎01-12-2011
  • Location:
  • Views: 0
  • Message 3 of 3

Re: Battery Issue?

2011-01-15, 2:54 AM

RollinStoned420 wrote:

It sounds like the Charger has a short in it and it's preventing your Devour from Charging....

Could you give more detailed description? I'm still studying it, Where can I find the related documentation?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete