Motorola Community

Older Devices ArchiveDROID 3 by Motorola
All Forum Topics
Options

5 Posts

07-13-2011

0 Signins

0 Page Views

  • Posts: 5
  • Registered: ‎07-13-2011
  • Location:
  • Views: 0
  • Message 21 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-19, 15:05 PM

It's a self-signed CA issue. Moto is aware of the issue, but there is no timetable for an upgrade nor is there a workaround. There is no way to root the phone to really get at the cert store. As su, I could probably pull it off...

Before you go crazy, I've already tried a lot of ideas myself....the following does NOT work (on MY device with MY server):

1. Installing the certificate of the CA in my device

2. Installing the certificate of the server in my device

3. Doing 1-2 from the internal and external SD card

4. Connecting from the local LAN of the server

5. Third party cert. installers (X509 tools)

6. SecureEAS

7. Entering IP address of the server / exchange locator

8. Emailing the cert to myself and attempting to install it

9. Setting up touchdown first, then trying to get native activesync to work

10. Calling VZW

11. Calling Moto (at least they admitted to the problem)

The following does work:

1. Touchdown

Like the Droid X, Moto/VZW should be supplying licenses to Touchdown software until a workaround has been found. I'd have liked to have seen this disclosure before I purchased this device.

Reply
Options

2 Posts

07-19-2011

0 Signins

0 Page Views

  • Posts: 2
  • Registered: ‎07-19-2011
  • Location:
  • Views: 0
  • Message 22 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-19, 19:07 PM

I too am unable to connect to my corporate exchange server having tried most of the suggestions on this thread. Droid2 Global.

I downloaded touchdown and was connected in less than 5 minutes. Come on Moto.



Moto/VZW should be supplying licenses to Touchdown software until a workaround is found. I found this issue going back more than a year on another thread.



Reply
Options

8 Posts

07-19-2011

0 Signins

0 Page Views

  • Posts: 8
  • Registered: ‎07-19-2011
  • Location:
  • Views: 0
  • Message 23 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-19, 21:05 PM

I too have had the same frustration.  Working in a small company I am in charge of both the email server and phones.  I was able to download a free instantSSL certificate from Comodo and activate it for my webmail.  I then set up the account.  I subsequently changed the certificate back to the self-signed certificate and changed the setting to not check certificates in the account settings.  I am still able to receive mail.  Of course new phones will not be able to be set up this way as my instantSSL will expire in 90 days.  I just wanted to let you all know that the "workaround" suggested by Motorola would work if you could get through the account set up somehow. 

Reply
Options

294 Posts

11-26-2010

0 Signins

0 Page Views

  • Posts: 294
  • Registered: ‎11-26-2010
  • Location:
  • Views: 0
  • Message 24 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-19, 23:23 PM

One thing to keep in mind is that a lot of us Droid 3 types have far less tech knowledge and even IT support than many of you.  I don't even know what a "Certificate" is and our IT department doesn't support mobile devices at all.  They do have an exchange server, which I have access to, but setting it up is my own responsibility.

With my iPad this took nothing more than just typing in the info.  Ditto the D3 with Touchdown.  But, without touchdown, I can't connect at all. 

I echo the frustation many of you are feeling about this but also have a degree of confidence that Moto will find a quick fix.

I also think Moto should supply touchdown licenses if they can't fix this rapidly though.  In fact, I'd go so far as to demand it.

Reply
Options

4 Posts

04-06-2011

0 Signins

0 Page Views

  • Posts: 4
  • Registered: ‎04-06-2011
  • Location:
  • Views: 0
  • Message 25 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 17:59 PM

Should be no surprise....

It doesn't work on Droid 2

It doesn't work on Droid 2 Global

It doesn't work on Droid X

It doesn't work on DroidPro

It doesn't work on Droid 3....

I'd say it probably doesn't work on Droid X2 either....

Oh wait! Moto knows about the issue and is working on it....

See where I'm going with this? They probably have the canned response on the clipboard for easy cut and paste. Anyone who believes this BS any longer deserves it. Moto has not provided ANY fixes for any of their devices. There are too many good devices and manufacturers for them to keep pulling this nonsense.

Here is a promise Moto...my next device will NOT be from you! You can take that one to the bank, I promise. 

Reply
Options

19379 Posts

02-03-2016

US

2392 Signins

59453 Page Views

  • Posts: 19379
  • Registered: ‎02-03-2016
  • Location: US
  • Views: 59453
  • Message 26 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 19:14 PM

As fxholl indicated, we're working on this. In the meantime, we do have a fairly simple workaround.

Set-up a corp-sync or Exchange Activesync account

  • Use your google account to create a corporate sync account . The prompt for server name should be “m.google.com” and the prompt for user name is your gmail address (the entire email address, not simply the first half/user part). So, as an example:
  • After the account is created, go into settings -> accounts and select the EAS account created
  • In the first screen, un-check the option "Verify Certificate"
  • Change the credentials to the account needed

Let me know if this works or not for you. Sorry for the issue.

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!

0 person found this solution to be helpful.

This helped me too

Reply
Options

170 Posts

05-10-2009

Canada

40 Signins

237 Page Views

  • Posts: 170
  • Registered: ‎05-10-2009
  • Location: Canada
  • Views: 237
  • Message 27 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 19:34 PM

mattsheehe wrote:

I imported my certificate onto my phone using a similar method - it was one of the first things I tried.  But it made no difference, I still got the same error while trying to connect.

Have you restarted the phone after you imported the certificate? You need to restart it first or the certificate won't be visible.

Matt's workaround is neat!

Reply
Options

18 Posts

07-13-2011

0 Signins

0 Page Views

  • Posts: 18
  • Registered: ‎07-13-2011
  • Location:
  • Views: 0
  • Message 28 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 19:41 PM

I did; no difference. It looks like the email software doesn't accept self-signed certificates. I'm not sure why this is the case, but it does appear to be what is preventing my connection.

Reply
Options

2 Posts

07-19-2011

0 Signins

0 Page Views

  • Posts: 2
  • Registered: ‎07-19-2011
  • Location:
  • Views: 0
  • Message 29 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 20:03 PM

So where do I enter the "m.google.com"? On the droid or in my gmail account?

On Wed, Jul 20, 2011 at 12:14 PM, Matt <

Reply
Options

2 Posts

07-20-2011

0 Signins

0 Page Views

  • Posts: 2
  • Registered: ‎07-20-2011
  • Location:
  • Views: 0
  • Message 30 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 20:47 PM

Enter the m.google.com in the server name.

1.) Add a new corporate sync account.

2.) Put your email address, password, domain (if needed), and username in the appropriate fields.  Press next.

3.) You should get a message that says "Could not auto-detect server.  Please enter the server name manually." Press OK.

4.) There will now be a box labeled Server:.  Here is where you will enter m.google.com. Press next.

Your account should be created.  Then you go Settings->Accounts and modify the settings to your corporate environment and uncheck the "Verify Certificate" option.

Hope that helps.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete