Motorola Community

Older Devices ArchiveDROID 3 by Motorola
All Forum Topics
Options

2 Posts

07-20-2011

0 Signins

0 Page Views

  • Posts: 2
  • Registered: ‎07-20-2011
  • Location:
  • Views: 0
  • Message 31 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 20:48 PM

Thanks Matt.

Reply
Options

19232 Posts

02-03-2016

US

2362 Signins

58302 Page Views

  • Posts: 19232
  • Registered: ‎02-03-2016
  • Location: US
  • Views: 58302
  • Message 32 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 20:59 PM

Paul, go into Menu > Settings > Accounts > Add account. Choose Corporate Sync. You won't see the "server" field until you try to log in -- it will fail if you just use your Gmail ID and password and then offer you the server field.

At least, that's what I see.

If it still fails, try using your full email address in the user name field as well.

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Options

18 Posts

07-13-2011

0 Signins

0 Page Views

  • Posts: 18
  • Registered: ‎07-13-2011
  • Location:
  • Views: 0
  • Message 33 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 21:08 PM

This workaround seems to be working for me.  I can get my email.  I don't seem to see my schedule in the Calendar, though, nor does my Corporate Sync account show up in the list of possible calendars in the Calendar settings.

Reply
Options

294 Posts

11-26-2010

0 Signins

0 Page Views

  • Posts: 294
  • Registered: ‎11-26-2010
  • Location:
  • Views: 0
  • Message 34 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 22:17 PM

Matt - Thank you so much! I can see my e-mail now.  I'm not getting the calendar or contacts, but I think that is probably an issue on our end. I don't really know the particulars, but we have a novell groupwise server - touchdown says "Activesync with certificate."   I'm mostly worried about the mail now, because I get suck my calendar down through Gmail, so it is not an issue.

I really, really, really appreciate your efforts.  You rock.

David (aka Kilgore)

Reply
Options

1 Posts

07-20-2011

0 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎07-20-2011
  • Location:
  • Views: 0
  • Message 35 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 22:41 PM

Thanks for the workaround. It worked for me on Exchange 2003 with self-signed cert.

Reply
Options

19232 Posts

02-03-2016

US

2362 Signins

58302 Page Views

  • Posts: 19232
  • Registered: ‎02-03-2016
  • Location: US
  • Views: 58302
  • Message 36 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-20, 23:08 PM

Wish I could take credit, but it was others here behind the scenes who came up with it. I will pass it on.

We still intend, as far as I know, to correct it.

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Options

18 Posts

07-13-2011

0 Signins

0 Page Views

  • Posts: 18
  • Registered: ‎07-13-2011
  • Location:
  • Views: 0
  • Message 37 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-21, 19:58 PM

Thanks to an email from MOTO_Tarnisha I've got the last part of the problem worked around.  I wasn't able to access my calendar after Matt's workaround, but if I uninstall Touchdown before doing said workaround, my calendar data does show up.  If you've already done the workaround and can't see your calendars, remove the Corporate Sync account, uninstall Touchdown, and perform Matt's workaround steps again.

Thanks for getting this working, guys. I know it's not a proper fix to the connection problem, but, as workarounds go, this is a pretty easy one.

Reply
Options

15 Posts

11-17-2010

United States

0 Signins

0 Page Views

  • Posts: 15
  • Registered: ‎11-17-2010
  • Location: United States
  • Views: 0
  • Message 38 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-21, 20:12 PM

Since the Droid 3 has improved security it requires a different configuration when using SSL certificates within Activesync.  It drops the connection if the certificate is not validated.  One resolve would be

Opt 1: Get an SSL certificate from a commercial Certificate Authority (CA) like Verisign, GoDaddy, Network Solution or DigiCert and etc., and install it on your Exchange server.

Opt 2: Download Touchdown, Improved Email or another 3rd-party application from Marketplace which has been said to provide a functional workaround.

**Opt 3: Found under FAQ 69570 is a workaround that allows you to use the native corp sync app by adding a gmail account in the Corp Sync app to create an email account, then edit the account by changing the gmail credentials to reflect those of your Exchange Corp Account credentials.



.

Reply
Options

22 Posts

04-24-2011

0 Signins

0 Page Views

  • Posts: 22
  • Registered: ‎04-24-2011
  • Location:
  • Views: 0
  • Message 39 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-07-23, 9:02 AM

LOL, wow. On another thread one of the "Forum Managers" was extolling the virtues of Blur and mentioned Exchange support at one of the reasons Motorola keeps it around. And here we are. One of those dreaded "3rd party" apps that cause, without fail, all of the problems with any Motorola device actually does Exchange better than you. And is recommended as a workaround.

Or you can go the easy route and buy an SSL certificate and install in to your Exchange server. I'm sure you have admin rights for everything at your work, right guys? And some money to drop on a cert?

Reply
Options

9 Posts

08-08-2011

0 Signins

0 Page Views

  • Posts: 9
  • Registered: ‎08-08-2011
  • Location:
  • Views: 0
  • Message 40 of 44

Re: Trouble connecting to Exchange with Droid 3

2011-08-08, 3:38 AM

Hehe, that was a boneheaded oversight on Motorola's part - only giving you the option to accept all certificates in the settings for an existing account, which it won't let you create unless the certificate is acceptible and the setting's not needed.  I mean, didn't they notice that the default Android Exchange app has a checkbox for that on the initial account setup??

I was going to offer to create an account on my Exchange server for people to use to initially create an account, so they could then go back and flip the toggle and change the server settting to their own - but the solution Matt posted is an even better way to do that.  Very cool

IMO, you guys should tell your Exchange admins to straighten up - it only costs $22.50/year and takes about 20 minutes to install a real certificate from http://certificatesforexchange.com/.

One thing I love about this Exchange app over the Android one, though, is that once I read all new email on my PC, the new email notification status bar icon goes away on my phone....always bugged me that the Android one left it up there indefinitely. 

On the flip side, I hate that the contact photos don't sync over from Exchange to Contacts on the phone like they do in the Android Exchange app.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete