cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
otim4988
What's DOS?
Posts: 1
Registered: ‎09-18-2013
Views: 44,122
Message 1 of 9

MTP device will not connect using windows xp


I have been trying to download media files from my phone to my laptop using windows XP.  I can download pictures but when I switch to the MTP settings it finds new hardware but will not connect.  I tried installing new drivers, deleting and reinstalling checking and unchecking the debugging feature and it still doesn't.  I was told by Motorola support after 4 hours my laptop and operating system is not compatible?  Any help would be appreciated.



 Thanks otim4988

Moto Sr Moderator
Moto Sr Moderator
Posts: 4,613
Registered: ‎03-15-2011
Location: United States
Views: 44,122
Message 2 of 9

Re: MTP device will not connect using windows xp


In camera mode, you should see the DCIM folder only. If you switch to MTP, if nothing shows up, what happens if you leave it in MTP mode, and disconnect the cable from the computer, then reconnect it?



 



Are you using a USB hub? If so, take that out of the equation. Also, if you are not already, try using the cable provided with the Mini.



 



You also said you tried installing drivers - just want to make sure they are the ones from here:

https://motorola-global-portal.custhelp.com/app/answers/detail/a_id/88481



 



Sorry it took a little while to reply. Hopefully one of these suggestions will help.

Greg17
What's DOS?
Posts: 1
Registered: ‎12-25-2013
Views: 44,122
Message 3 of 9

Re: MTP device will not connect using windows xp


I am having a similar issue getting my new droid mini to connect to my pc (windows XP SP 3) The Motorola device driver installed ok but the MTP device did not install and the found new hardware wizard comes up with an error when I connect the usb cable to the phone. it says an error occurred during installation. also it says the required section was not found in the INF.



Thanks

Sumb
What's DOS?
Posts: 5
Registered: ‎12-28-2013
Location: Czech Republic
Views: 44,122
Message 4 of 9

Re: MTP device will not connect using windows xp


Got exactly the same problem here with a Moto G and Windows XP (SP3)



Motorola Live Chat told me to turn off my cookies and / or try a different browser - different USB cable / USB port.



I get the feeling that they don't have an answer.



Everything works fine when the phone is plugged into my daughters Windows 7 laptop.

Moto Sr Moderator
Moto Sr Moderator
Posts: 12,379
Registered: ‎02-02-2016
Location: US
Views: 44,122
Message 5 of 9

Re: MTP device will not connect using windows xp


There's a chance that the issue lies with XP, and not with the phone or its drivers.  



This problem has been reported to Microsoft in a forum as existing across manufacturer's products.  Depending on whether you're using XP Home or XP Pro, this thread may contain a solution.



Extended support from Microsoft for XP will end next year; consumer support ended in 2009.  No matter how well our systems may be working, there is a limit to how much backward compatibility we can expect from any manufacturer.

fil11
What's DOS?
Posts: 2
Registered: ‎09-07-2014
Location: Brazil
Views: 44,122
Message 6 of 9

Re: MTP device will not connect using windows xp

Had the same problem. Win XP + SP3. My Moto G was detected as Camera but not as Multimedia device. After driver installation and plugging the device a window communicated that "MTP Error occurred" and the drived could not be installed. Tried the solution suggested by Sumb in this thread https://forums.motorola.com/posts/f7c3b8ac5a?commentId=803301#803301 by installing the MTP drivers package (had already Media Player 11 and updated to NET Framework to 4.0). Still the same problem.



At the end I found in a Samung forum, wehre the same problem was discussed, that the problem is a missing update: Microsoft_User-Mode_Driver_Framework_Install-v1.0-WinXP



I downloaded it http://download.microsoft.com/download/2/0/9/20944076-988f-487c-89fa-d37718782948/Microsoft_User-Mode_Driver_Framework_Install-v1.0-WinXP.exe installed it and now the moto g ist detected as multimedial device!!!



In some cases you have to install again the Motorola Device Manager. If you had installed the driver manually (through Control Panel - System - Device Manager) you have to update the MTP driver by right clicking on the "yellow question mark" near MTP and select "Update driver".

G-man3
What's DOS?
Posts: 2
Registered: ‎01-11-2015
Location: Spain
Views: 44,119
Message 7 of 9

Re: MTP device will not connect using windows xp

Hi all,



I have been trying like the dickens to get my Droid Turbo to be seen by both my Chromebook, and my WinXP SP3 machine.  On the Chromebook, it appears as a USB device, but read-only.  I cannot copy anything to it, but and get stuff from it.  Drive is apparently my friend.  I give up on that.



On the WinXP SP3, I tried installing the latest drivers by installing drivers from here: https://motorola-global-portal.custhelp.com/app/answers/detail/a_id/88481, after fresh boot, install, and reboot.  Alas, the damn OS cannot find the driver, as you can see from the attached images where the poor OS cannot seem to find the driver.



https://drive.google.com/file/d/0B9zoMhsJ885HSHBEOVBEdUprTzA/view?usp=sharing



https://drive.google.com/file/d/0B9zoMhsJ885HS01TMk0yQWZuZkk/view?usp=sharing



https://drive.google.com/file/d/0B9zoMhsJ885HWjRIbFNWQ1BRbUk/view?usp=sharing



https://drive.google.com/file/d/0B9zoMhsJ885HY2ZJaVVhMnd1UkE/view?usp=sharing



Any help anyone can give me would be most appreciated!



Best regards,



Rob



 

RTKohl
What's DOS?
Posts: 1
Registered: ‎01-15-2015
Views: 44,119
Message 8 of 9

Re: MTP device will not connect using windows xp

I had the same problem and I found the solution below in another forum and it worked for me on my droid Turbo.



Go into settings



Select storage



Click on the 3 dots in the upper right ( options)



Select USB computer connection



Turn off Software Install



That was it. I had previously gone to Motorola and downloaded and installed the latest device manager software, but I am not sure that was necessary.



Hope this helps!



Rich

SaiSrinivas
What's DOS?
Posts: 2
Registered: ‎09-06-2015
Views: 44,119
Message 9 of 9

Re: MTP device will not connect using windows xp

Trust me, this really works and very simple!!
First make sure your computer has these softwares installed:

1)Microsoft net framework 4.0(download here-https://www.microsoft.com/en-in/download/confirmation.aspx?id=17851)

2)Windows media player 11(download here-https://www.microsoft.com/en-in/download/windows-media-player-details.aspx)

3)MTP Transfer Protocol Porting Kit(download here-http://www.microsoft.com/en-in/download/details.aspx?id=19153)

Note: If your computer windows XP OS is not genuine and if you need to install windows media player 11 without validation, follow the steps in this website-http://www.tech-recipes.com/rx/2577/wmp11_install_windows_media_player_11_without_activating_bypass_wga/
After installing all those softwares, connect your device to computer using usb cable and follow these steps:
Right click on 'my computer'-->click 'properties'-->click 'hardware' tab-->open 'device manager'-->you'll see yellow question mark on MTP device list there, right click on it-->click 'properties'-->click'reinstall drivers'

that's it you can now see that your device is detected as MTP device. Enjoy!!