Showing results for 
Search instead for 
Did you mean: 
Blue Screen Again
Posts: 2
Registered: ‎10-18-2018
Location: PK
Views: 445
Message 1 of 3

Droid Turbo 2 Accidentally deleted some system files. How to get them back?



I have a Droid Turbo 2 and Accidentally I deleted some of the system files.

Which are causing problems in CHARGING.


Caused Problems are:

  1. Battery icon remains constant as charging. I plug or unplug charger, icon remains charging icon.
  2. TurboPower Label always shown in COMMAND CENTER Widget.
  3. Charging very very slow.
  4. When I Plug charger, it does not alert that power connected or not. 
  5. When I Unplug charger, it does not alert that power disconnected or not. 
  6. When I Plug charger, it does not show TurboPower Connected Popup. But sometime it shows. ***It's really strange***
  7. Battery Saver also not working.
  8. On Power-off state, when I plug charger, It shows charging screen. But on unplugging charger, the screen does not go. It reamains constant. i.e. on pressing power button, it shows charging screen.


Steps taken to resolve issues:

  1. Restarted mobile several times.
  2. Cleared Cache.
  3. Cleared Cache partition.
  4. Phone reset.
  5. Phone Hard Reset.



  1. I am using it's original TurboPower charger.
  2. Android OS version is 7.0 Nougat.
  3. I live in Pakistan.
  4. I do not use Verizon wireless sim card.
  5. Mobile purchased as used second hand.
  6. It has no warranty to claim.
  7. I have installed Ampere App to see charging state and current. Before deletion of system files, I checked / noted that current value was 2440mA. And now it's value is 280mA. Too much difference.
  8. System files were deleted by me using ES File Explorer App. Actually my mobile is short of memory. So this app analyzed the files and showed me the categories of Big files, Cache files, Redundant files, Duplicate files, Temporary files, junk files etc. I removed temporary files, junk files and some of the duplicate files completely from mobile.



So, I am unable to resolve the problem. I thought I will downgrade Android OS 7.0 (Nougat) - to - 6.0 (Marshmallow) and then reinstall 7.0 (Nougat) this will solve the problems. I GOOGLED it. Then in many posts I found that I can not perform system downgrade because of bootlocker locked in Verizon-model Droid Turbo 2.


I need help. Kindly tell me what should I do now?


Senior MotoAgent
Senior MotoAgent
Posts: 3,948
Registered: ‎12-01-2016
Location: PH
Views: 401
Message 2 of 3

Re: Droid Turbo 2 Accidentally deleted some system files. How to get them back?

Hi Fahad_Ali_


Thanks for reaching out. I'll do my best to help. By the way, are you using a Verizon phone?


If yes, try this-- Repairing a Verizon Device with SUA
Download and then install the "Verizon Software Update Assistant" on your computer from these links.
Windows link:
Mac link:
Reboot the phone into Fastboot/Recovery
Power off your phone
Hold “Volume Down + Power” for at-least 3 seconds and then release the buttons
Connect your phone to that PC via a USB cable.
Open the "Verizon Software Update Assistant" application on your Windows PC (if you haven't already).
Wait a good 10-30 seconds (at least) for the "Verizon Software Update Assistant" to a) check for updates to itself, and then b) discover your attached smartphone.
When available, click on the red "Restore" button within the "SUA App" 
Choose whether to erase or keep all your data during this process. By default the app will not erase user data
After that, it seems like it took around 30 minutes to download the image, decompress that Android image, and then install it to the phone.  After that process is done though, the problem should be fixed and the phone should boot up.

If SUA tool fails to decompress the files.
Uninstall the Verizon SUA tool from the computer..
Reboot the computer.
Start over at step 1 of the Restoring the device.



Hope it works for  you.


Moto Support





Blue Screen Again
Posts: 2
Registered: ‎10-18-2018
Location: PK
Views: 391
Message 3 of 3

Re: Droid Turbo 2 Accidentally deleted some system files. How to get them back?

Hi Agent_Daisy,


Thanks for the help guidance.

I tried your solution. SUA reinstalled NCK25.118-10.5 to my DT2.


Droid Turbo 2 Repairing from SUA Tool Verizon2.pngImage Droid Turbo 2 Repairing from SUA Tool Verizon


But unfortunately it did not worked.
The problem still remains the same.


Kindly suggest another way to resolve the issue.

Waiting for your kind response.