Motorola Community

Droid PhonesDROID TURBO 2 by Motorola
All Forum Topics
Options

2 Posts

08-10-2019

US

2 Signins

39 Page Views

  • Posts: 2
  • Registered: ‎08-10-2019
  • Location: US
  • Views: 39
  • Message 1 of 2

This is not the Droid I was looking for...

2019-08-10, 6:23 AM

Hi all, I have a Droid Turbo 2 that is not reading a class 10 16 or 32G msd card. I have read through a lot of these forums, and have yet to find something that works. I have tried rebooting my phone in safe mode, cleared cached data from Settings>Storage>>Internal Shared Storage. Nothing. Tried turning debugging off and on, the same. Made sure that the USB option was set to MTP. Tried putting a piece of tape on the back to life it in case it wasn’t making contact. Nothing again. When I look on the screen, it doesn't have a message, it just indicates that there isn't a card inserted. Also, when I try to hook it up to my Mac, Android File Transfer says "Can't access device storage -- Make sure your device is unlocked and "File Transfer" or "MTP" mode is selected. I just brought that up in case they might be related. I’m really lost here, guys. Does anyone have any other ideas? Please help!

Reply
Options

10585 Posts

03-05-2018

US

1115 Signins

150683 Page Views

  • Posts: 10585
  • Registered: ‎03-05-2018
  • Location: US
  • Views: 150683
  • Message 2 of 2

Re: This is not the Droid I was looking for...

2019-11-01, 19:29 PM

Hi spankler,

 

Thank you for posting. I just this post. Do you still need assistance with this? 

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete