Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 1
Registered: ‎08-09-2019
Location: US
Views: 171
Message 1 of 1

This is not the Droid I was looking for...

Hi all, I have a Droid Turbo 2 that is not reading a class 10 16 or 32G msd card. I have read through a lot of these forums, and have yet to find something that works. I have tried rebooting my phone in safe mode, cleared cached data from Settings>Storage>>Internal Shared Storage. Nothing. Tried turning debugging off and on, the same. Made sure that the USB option was set to MTP. Tried putting a piece of tape on the back to life it in case it wasn’t making contact. Nothing again. When I look on the screen, it doesn't have a message, it just indicates that there isn't a card inserted. Also, when I try to hook it up to my Mac, Android File Transfer says "Can't access device storage -- Make sure your device is unlocked and "File Transfer" or "MTP" mode is selected. I just brought that up in case they might be related. I’m really lost here, guys. Does anyone have any other ideas? Please help!

Top Kudoed Authors