Motorola Community

Droid PhonesDROID ULTRA & ULTRA MAXX
All Forum Topics
Options

16 Posts

01-06-2014

United States

2 Signins

24 Page Views

  • Posts: 16
  • Registered: ‎01-06-2014
  • Location: United States
  • Views: 24
  • Message 1 of 22

Camera App not working after 4.4.4 update

2014-07-28, 5:02 AM

Two Droid Maxx, pretty much the same complain. After 4.4.4 update camera was working fine and dandy for few days. After that I started getting error messages, "restart camera app" when ever I would launch the camera app. On launching there would be a BLANK screen with two NON-WORKING  buttons on the bottom (one for swaping front-back camera and other for movie). Initially restarting the phone helped but now even that is not helping. After 3 days of camera not working, suddenly the camera worked for 20 minutes and replaced again with the BLANK screen. 


 


Anybody having similar problems? What should I do? I cleared the camera cache but havenot gone through full wipe. These are TWO droids having similar problems after the 4.4.4 update. No new app have been downloaded for last one month or so on both phones. Looking into running and cache apps. there is just the usual google and motorola  stuff, facebook, some amazon and verizon stuff but nothing related to camera.  These stuff have been running for a long time before the update unless something got added OTA with the last update. 


 


I never rooted either of my phone, it always have been stock. One was in soak test, other was NOT. 


 


Please Help!
Solved! See the solution
Reply
Options

353 Posts

06-16-2012

United States

2 Signins

32 Page Views

  • Posts: 353
  • Registered: ‎06-16-2012
  • Location: United States
  • Views: 32
  • Message 2 of 22

Re: Camera App not working after 4.4.4 update

2014-07-28, 9:04 AM
Do this. Go to the google seatch app, scroll to the bottom and click on the three vertical dots. Then click Settings then voice then OK google detection. Turn off OK, google detection. It worked for me.

0 person found this solution to be helpful.

This helped me too

Reply
Options

353 Posts

06-16-2012

United States

2 Signins

32 Page Views

  • Posts: 353
  • Registered: ‎06-16-2012
  • Location: United States
  • Views: 32
  • Message 3 of 22

Re: Camera App not working after 4.4.4 update

2014-07-28, 9:04 AM
Don't worry, OK google will still work.
Reply
Options

1 Posts

07-28-2014

Colombia

0 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎07-28-2014
  • Location: Colombia
  • Views: 0
  • Message 4 of 22

Re: Camera App not working after 4.4.4 update

2014-07-28, 15:21 PM


I have a similar issue.  After the 4.4.4 update my camera worked, but I couldn't record a video.  I followed the instructions above and restarted the phone and it's working now.  I also had issues using Ok google now.  It would tell me google is not available.  That also is working now.

Reply
Options

16 Posts

01-06-2014

United States

2 Signins

24 Page Views

  • Posts: 16
  • Registered: ‎01-06-2014
  • Location: United States
  • Views: 24
  • Message 5 of 22

Re: Camera App not working after 4.4.4 update

2014-08-22, 20:49 PM


Ok, my camera app is still works sporadically. I have turned the ok google off, but I would say 60% of the times the camera doesnt start. Is there anything else I can do? Please help

Reply
Options

16 Posts

01-06-2014

United States

2 Signins

24 Page Views

  • Posts: 16
  • Registered: ‎01-06-2014
  • Location: United States
  • Views: 24
  • Message 6 of 22

Re: Camera App not working after 4.4.4 update

2014-08-22, 21:50 PM


here is the screenshot, with everything turned off. 

Reply
Options

8 Posts

10-28-2014

United States

0 Signins

0 Page Views

  • Posts: 8
  • Registered: ‎10-28-2014
  • Location: United States
  • Views: 0
  • Message 7 of 22

Re: Camera App not working after 4.4.4 update

2014-11-04, 3:45 AM

I would like to add that I'm having the same issue, getting the "Camera Error" - "Please Restart Camera" - "Can't connect to the camera" errors after the phone had been functioning perfectly for months.  I'm pretty sure it is an app that is causing the camera to crash but have not narrowed it down yet.  Some say it is Skype, I never gave Microsoft a chance to screw up my phone, some say it is the flash light app, I read here it is Ok Google Now detection.  I have no clue, but the camera seems awfully sensitive.  I've also tried the Google Camera app with the same results.  I hope this is not a hardware issue, which would be weird since it's been working for months.  My wife has a Moto X and her's has been rock solid and I've loaded basically the same apps on hers.  The only difference is that I have WeChat running on mine, which may very well be the cause.  I've disabled the video chat feature on WeChat just now and the camera already seems more stable, even though I was able to make it crash with the Google Camera app.  This is pretty frustrating, I've been trying to figure this out for a few days now with no success.  To add insult to injury, I'm also having issues with Active Display.  Wonder if it all ties in to some underlying hardware issue!

Reply
Options

12372 Posts

02-02-2016

US

2935 Signins

20947 Page Views

  • Posts: 12372
  • Registered: ‎02-02-2016
  • Location: US
  • Views: 20947
  • Message 8 of 22

Re: Camera App not working after 4.4.4 update

2014-11-04, 11:13 AM

The easiest way to narrow down the cause of a problem is to ruin the phone in safe mode.  If the problem doesn't occur in safe mode, which prevents third party apps from launching, the problem is caused by a third party app.  If the problem does occur, it's either hardware or OS related.

Reply
Options

8 Posts

10-28-2014

United States

0 Signins

0 Page Views

  • Posts: 8
  • Registered: ‎10-28-2014
  • Location: United States
  • Views: 0
  • Message 9 of 22

Re: Camera App not working after 4.4.4 update

2014-11-04, 16:33 PM
Yes, took your advice and ran the phone in safe mode to try to crash the camera. Only did it for a few minutes and got pretty close to crashing it once. It froze but came back to life after about 10 seconds. So right now, I think I've discovered the culprit, and it is WeChat. More specifically, the features in WeChat that uses the camera. So I've disabled moments and video chat. So far so good, will report back if anything changes.
Reply
Options

16 Posts

01-06-2014

United States

2 Signins

24 Page Views

  • Posts: 16
  • Registered: ‎01-06-2014
  • Location: United States
  • Views: 24
  • Message 10 of 22

Re: Camera App not working after 4.4.4 update

2014-11-04, 18:30 PM

Both my droid Maxx would have camera initiation problems 70% of the time either in safe mode or regular mode. I ended up replacing both under warranty. Could not be happier, both camera works 100% of the time. Dont know why it took me so long to replace, cause they end result was so much better. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete