cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Moto Sr Moderator
Moto Sr Moderator
Posts: 28,232
Registered: ‎02-02-2016
Location: US
Views: 240
Message 31 of 34

Re: USB Device Not Recognized - Maxx and Windows 7/8

I think joelbon is right - that should be a quick and easy test - much easier then doing anything else. 


* Search box is your friend * I don't respond to PM if question belongs in forum
droidforce
Token Ring
Posts: 660
Registered: ‎08-04-2010
Location: United States
Views: 240
Message 32 of 34

Re: USB Device Not Recognized - Maxx and Windows 7/8

I have never had a problem using a non Moto cable but maybe I'm just lucky. Occasionly I have had trouble connecting but it cleared up by disconnecting and reconnecting cable.

Does your phone acknowledge its connected or just the PC end?
DavidSweden
What's DOS?
Posts: 1
Registered: ‎12-30-2015
Location: Pakistan
Views: 240
Message 33 of 34

Re: USB Device Not Recognized - Maxx and Windows 7/8

I'm so happy right now I have to write something somewhere.. Smiley Very Happy



I haven't been able to transfer data via USB since I got my Moto E a year ago. Doesn't matter what I do. Once about ½ year ago it worked one time but after reboot no more. Tried everything twice. Read all forums. Gave up.



Anyway. Now it works. On all PCs (Win 7). All the time. Doesn't matter if I have "Motorola Device Manager" installed or not. Doesn't matter if phone is unlocked or screen is black. Just keeps on working. If I connect it to a PC for the first time, the PC installs a driver (supposedly from Microsoft 2006), takes 3 seconds then it works. And the USB cable is the same I used at most previous attempts. And an ordinary USB2 port.



My conclusion is that it must be due to some update of the phone or Windows. I haven't done any specific updates for this so whatever it is, it must have come with some general update. So if anyone else has had these problems then maybe just try again now.



In my state of total bliss I can't help thinking: I wish Motorola & Microsoft recognized this problem long ago.

Moto Sr Moderator
Moto Sr Moderator
Posts: 28,232
Registered: ‎02-02-2016
Location: US
Views: 240
Message 34 of 34

Re: USB Device Not Recognized - Maxx and Windows 7/8


DavidSweden said:


I'm so happy right now I have to write something somewhere.. Smiley Very Happy



I haven't been able to transfer data via USB since I got my Moto E a year ago. Doesn't matter what I do. Once about ½ year ago it worked one time but after reboot no more. Tried everything twice. Read all forums. Gave up.



Anyway. Now it works. On all PCs (Win 7). All the time. Doesn't matter if I have "Motorola Device Manager" installed or not. Doesn't matter if phone is unlocked or screen is black. Just keeps on working. If I connect it to a PC for the first time, the PC installs a driver (supposedly from Microsoft 2006), takes 3 seconds then it works. And the USB cable is the same I used at most previous attempts. And an ordinary USB2 port.



My conclusion is that it must be due to some update of the phone or Windows. I haven't done any specific updates for this so whatever it is, it must have come with some general update. So if anyone else has had these problems then maybe just try again now.



In my state of total bliss I can't help thinking: I wish Motorola & Microsoft recognized this problem long ago.


View original


I am glad you got it working - but it is not a Motorola problem. MDM isn't used anymore as the Android drivers get pulled by windows update from Microsoft repositories. 



Since it only affects a handful of computer/phones it is something in the Windows configuration, but there is no easy way to solve it. I have a couple phones that Windows would not recognize and I had to download USB drivers from a 3rd party site - but it was an issue limited to just one of my Windows machines - the other worked fine - so something about that one Windows install. 


* Search box is your friend * I don't respond to PM if question belongs in forum