cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sliding_billy
What's DOS?
Posts: 34
Registered: ‎08-07-2010
Location: United States
Views: 538
Message 11 of 22

Re: MTP USB Device Failed (again)

Still no joy.

Chris

Padron26
What's DOS?
Posts: 10
Registered: ‎08-09-2010
Views: 538
Message 12 of 22

Re: MTP USB Device Failed (again)

still no joy for me either, even thouht it works great on my 10 yr old Vaio 32 bit. which only has 1 toe on the ground

i just wish it would work on my new Vaio 64 bit.or hp 64 bit neither will work.  it always says Mpt usb device Failed.

ive uninstalled both of the old moto drivers and installed new ones, tried installing with the phone connected and disconnected.

with debugging on and off, and still nothing. i got the moto drivers from the link at the bottom of the page

any help would greatly be Appreciated

Moto Sr Moderator
Moto Sr Moderator
Posts: 15,449
Registered: ‎02-03-2016
Location: US
Views: 538
Message 13 of 22

Re: MTP USB Device Failed (again)

I didn't have any problems with installing the drivers.  I also didn't download any drivers.  All the drivers I needed were installed when first plugged the X into my computer, (Windows 7 - 64 bit).  When I first plugged the phone in, PC mode, I went to Computer and opened the CD rom that was named something like Motorola something.  I can't remember what it was named for sure.  It installed the drivers that the computer needed and everything has worked fine since then.  Hope this helps.

I am not a Motorola/Lenovo Employee. I am just a volunteer who happens to be a Moderator. All comments are my own and are not necessarily Motorola/Lenovo's position.

Padron26
What's DOS?
Posts: 10
Registered: ‎08-09-2010
Views: 538
Message 14 of 22

Re: MTP USB Device Failed (again)

i also tried that route, where i didnt install anything....i just connect my X and then let it automatically download the drivers.

it goes well untill the Mtp usb, then asks for a restart of the pc, i restart and it still does gives the Fail

sliding_billy
What's DOS?
Posts: 34
Registered: ‎08-07-2010
Location: United States
Views: 538
Message 15 of 22

Re: MTP USB Device Failed (again)

BUMP!  Can we please get a single response from a MOTO rep (Matt, since you are the only one that says anything on here I guess that means you )?  Is this a known issue, or are we idiots?  I am being sarcastic, BTW.  I am 100% confident that I have done everything possible to get this driver to work without having the actual code to try and diagnose some random incompatibility with both of my WIN7/64 machines.  I am sure others who have posted on this thread and others feel the same.  WIN7/64 drivers are a mess for a lot of hardware.  I don't blame the fact that it came out buggy.  I blame the fact that nobody cares to comment on it.  Check my posts.  I don't complain a lot.  I am almost 100% happy with my phone, but the 2 issues I do have (that are not explainable otherwise - and yes BLUR is an explanation - GET RID OF IT) cannot get a response from MOTO.  The other is the buggy HDMI function.  I am not referring to it being locked to the gallery, but that STINKS too!

Chris

Moto Sr Moderator
Moto Sr Moderator
Posts: 27,682
Registered: ‎02-02-2016
Location: US
Views: 538
Message 16 of 22

Re: MTP USB Device Failed (again)

Most people have no issues with the Moto drivers - I have numerous Moto phones and no problems at all. I can offer a few suggestions - based on what I have seen with many Android phones:

1. use a USB on the MB, not one on the front of a desktop

2. use a quality cable - Moto only recommends theirs so confirm you are using it; also some really cheap cables have issues

3. Don't use a USB extension cable - I don't know why, but I have had failed driver installs in these cases

All of the above I have direct experience with many Android phones, not necessarily moto. Swapping cables, USB ports, and eliminating extension cables fixed most of my issues.

Additionally,

Make sure you are not using a USB hub - just to take it out of the equation

Is your PC behaving normally? My win 7 x64 had symptoms of hang at shutdown - additionally it would not mount any USB device (phone or card) - I traced it back to a failed driver install for a Seagate NAS.

These USB drivers have been out for over a year and been rock solid. I will see if anyone else has any suggestions, but if this issue were effecting a majority of users, we would see a lot more posts.


* Search box is your friend * I don't respond to PM if question belongs in forum
Padron26
What's DOS?
Posts: 10
Registered: ‎08-09-2010
Views: 538
Message 17 of 22

Re: MTP USB Device Failed (again)

Ive got several Motorola Phones myself, it is just strange to me that the problem only exists with Windows 64 bit. I get it to work flawlessly on all of the 32 bit systems. I just installed all the drivers etc, on a Old windows 32 bit laptop that was in storage. the pc was very slow but it recognized everything as it should.

I resorted to doing a Factory reset on the X and tried it again on the 64 bit systems (2) and for some reason it works great..

the only way i connect my phones to a pc is by the factory oem cables, no extensions, hubs etc.

marvin02
Bit Torrent
Posts: 2,632
Registered: ‎03-08-2010
Location: United States
Views: 538
Message 18 of 22

Re: MTP USB Device Failed (again)

Padron26 wrote:

Ive got several Motorola Phones myself, it is just strange to me that the problem only exists with Windows 64 bit. I get it to work flawlessly on all of the 32 bit systems. I just installed all the drivers etc, on a Old windows 32 bit laptop that was in storage. the pc was very slow but it recognized everything as it should.

. . . . .

The problem with phone drivers isn't limited to 64 bit versions of windows. I have 4 WinXp computers and three connected to my Moto phones fine and the fourth was a problem. You can read the steps I took to fix the issue. I don't have any windows 64-bit machines so I don't know how much the info will help you.

----
I am a volunteer. The MotoXprt tag means I spend too much time here. The opinions expressed in my posts are my own. I own a Backflip and a Flipside. If my advice doesn't make any sense - ignore it!

Introduced to Android by the Moto Backflip
wyluli
What's DOS?
Posts: 1
Registered: ‎01-12-2011
Views: 538
Message 19 of 22

Re: MTP USB Device Failed (again)

I am having the same problem. I have Win 7 64-bit system. After trying countless ways using my knowledge of computers the driver fails; however, the driver worked once and i was able to access my phone files through my computer but after that the driver keeps trying to install and it fails again and again. I have never seen a driver try to reinstall itself after working once? i am very excited about this phone but with it being this much of a headache i am second guessing my choice. Please help with this problem.

sliding_billy
What's DOS?
Posts: 34
Registered: ‎08-07-2010
Location: United States
Views: 538
Message 20 of 22

Re: MTP USB Device Failed (again)

New driver, same problem.  I downloaded the 4.8.0 driver, uninstalled all exisiting files, rebooted, installed 4.8.0, rebooted, battery pulled the phone and... here it comes... MTP USB Device Failed.  Big shock.  Two computers.  Only real similarity is Win 7 64 bit.  Same reults.  Nice work Moto!  NOT!  I know some of you have had success.  So did I for a little while and nothing changed on the computers before they failed to work with the X again.  The driver is crap, Moto doesnt care.  I will now move on with my life until the next time I optomistically try to install PC Mode.

Chris