Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Datacenter NetworkingDatacenter Networking Hardware
All Forum Topics
Options

7 Posts

08-27-2021

Australia

7 Signins

50 Page Views

  • Posts: 7
  • Registered: ‎08-27-2021
  • Location: Australia
  • Views: 50
  • Message 1 of 10

LACP setup issue NE2572

2021-08-27, 12:16 PM

Hi,

 

So I have attached a rough sketch of my current setup (hopefully its clear enough). I'm having issues with LACP coming up and also spanning tree. We have 2 X Lenovo ThinkSystem NE2572's running version 10.10.8.0 As seen from my "sketch" The Lenovo's are connected together via LACP Port-Channel 10 on ports 49 and 51. 

 

I then have a pair of FS switches (Data centre switches from a companty called fibre store). These is the first time I've used these switches but their CLI is very very similar to Cisco. The FS switches are connected in a Stack configuration.

 

Its also a first with the Lenovo swithces and I'm finding them quite powerful.

 

On Lenovo 1,  port 50 as Channel-group 1 to FS1 which has both port 49 and 51 in channel-group 1.

On Lenovo 2 Port 50 is also in Channel-group 1

 

On Lenovo 2, port 52 is connected to FS 2 which has both ports 49 and 51 in channel-group 2

 

I hope I haven't confused everybody but hopefully the attached sketch is clear enough. Please note, from the Lenovo's, the channel-groups only have 1 port as a member. Can this be an issue? Would it be easier to set this all up using vLAG connected in the same way?

 

I've put some configs below. Hoping that someone will point me in the right direction and happy to walk through it. I suppose I would like to know if this kind of topology will work or I'm I setting myself up for grief. I've put some trunkated configs below.

 

Thanks

 

Lenovo 1:

interface Ethernet1/49
 speed 100000
 switchport mode trunk
 channel-group 10 mode active
!
interface Ethernet1/50
 speed 100000
 switchport mode trunk
 channel-group 1 mode active
!
interface Ethernet1/51
 speed 100000
 switchport mode trunk
 channel-group 10 mode active
!
interface Ethernet1/52
 switchport mode trunk
 channel-group 2 mode active

 

interface port-channel1
 speed 100000
 switchport mode trunk
!
interface port-channel2
 speed 100000
 switchport mode trunk
!
interface port-channel10
 switchport mode trunk

 

#sh interface brief

--------------------------------------------------------------------------------
Port-channel     PVID Type Mode   Status  Reason                 Speed  Protocol
Interface        NVLAN
--------------------------------------------------------------------------------
po1              1    eth  trunk  up      none                   100000 lacp
po2              1    eth  trunk  down    No link up members     100000 lacp
po10             1    eth  trunk  up      none                   100000 lacp

 

Lenovo 2:

 

interface Ethernet1/49
 speed 100000
 switchport mode trunk
 channel-group 10 mode active
!
interface Ethernet1/50
 speed 100000
 switchport mode trunk
 channel-group 1 mode active
!
interface Ethernet1/51
 speed 100000
 switchport mode trunk
 channel-group 10 mode active
!
interface Ethernet1/52
 speed 100000
 switchport mode trunk
 channel-group 2 mode active

!
interface port-channel1
 speed 100000
 switchport mode trunk
!
interface port-channel2
 speed 100000
 switchport mode trunk
!
interface port-channel10
 switchport mode trunk

 

#sh interface brief

--------------------------------------------------------------------------------
Port-channel     PVID Type Mode   Status  Reason                 Speed  Protocol
Interface        NVLAN
--------------------------------------------------------------------------------
po1              1    eth  trunk  down    No operational members 100000 lacp
po2              1    eth  trunk  up      none                   100000 lacp
po10             1    eth  trunk  up      none                   100000 lacp

--------------------------------------------------------------------------------

 

I'm also getting alot of these logs coming up on this switch - literally flooding the switch. But if I shut down channel group 2 interface, they stop.

 %STP-5-BRIDGE_TOPO_CHANGE: Bridge 80:32:80:96:21:c9:26:00 for VLAN0050 topology change
 %STP-5-BRIDGE_TOPO_CHANGE: Bridge 81:2c:80:96:21:c9:26:00 for VLAN0300 topology change
 %STP-5-BRIDGE_TOPO_CHANGE: Bridge 81:2d:80:96:21:c9:26:00 for VLAN0301 topology change
 %STP-5-BRIDGE_TOPO_CHANGE: Bridge 81:31:80:96:21:c9:26:00 for VLAN0305 topology change

 

FS1: (Stack unit1)

interface HundredGigabitEthernet 1/0/49
 port-group 1 mode active
!
interface HundredGigabitEthernet 1/0/50
!
interface HundredGigabitEthernet 1/0/51
 port-group 1 mode active
!

interface AggregatePort 1
 speed 100G
 switchport mode trunk

 

FS2: (Stack unit 2)

 

interface HundredGigabitEthernet 2/0/49
 port-group 2 mode active
!
interface HundredGigabitEthernet 2/0/50
!
interface HundredGigabitEthernet 2/0/51
 port-group 2 mode active

 

interface AggregatePort 2
 speed 100G
 switchport mode trunk

 

 

Reply
Options

192 Posts

06-03-2020

United States of America

164 Signins

1535 Page Views

  • Posts: 192
  • Registered: ‎06-03-2020
  • Location: United States of America
  • Views: 1535
  • Message 2 of 10

Re:LACP setup issue NE2572

2021-08-27, 14:34 PM

Hello,

 

Without VLAG, this design will not work. For example, on FS1 we have a single Po1, but the two interfaces are going to two different Lenovo switches. That requires vLAG to split an aggregation across the 2 different Lenovo switches (if you are familiar with Cisco vPC, it is the same concept, Cisco switches that do not stack require a feature like vPC to connect a single aggregation across two switches). But with this design, even if you added vLAG to fix the issue, having two separate aggregations (po1 and po2) defeats one of the strongest advantages to vLAG, as STP would have to block one of the Po interfaces to prevent a loop (so you loose half of your bandwidth to STP blocking).

 

So the best solution is to instead create a single 4 port Po interface between the FS switches and the Lenovo switches, and use vLAG on the Lenovo switches to turn interfaces 1/50 and 1/52 on both switches into a single 4 port LACP aggregation. To do this you would need to:

 

1) On the FS switch, put 1/49 and 1/51 and 2/49 and 2/51 into a single Po interface (i.e. all in Po1), and remove any reference to interface po2.

 

2) Before going any further, upgrade both Lenovo switches to the latest 10.10 release. There have been many improvements and critical fixes since 10.8 and I would strongly encourage you to go to the latest code. The latest code for the NE2572 can be found here:

https://download.lenovo.com/servers/mig/2021/08/23/54481/lnvgy_fw_torsw_ne2572-cnos-10.10.10.0_anyos_noarch.zip

The change history file for this code can be found here:

https://download.lenovo.com/servers/mig/2021/08/23/54481/lnvgy_fw_torsw_ne2572-cnos-10.10.10.0_anyos_noarch.chg

And I have attached a PDF that provides details on upgrading (see page 3 for your switches)

 

3) On the Lenovo switches, put interfaces 1/50 and 1/52 on both switches into interface po1 (you can delete interface po2)

4) On the Lenovo switches enable vLAG and tell it to use po10 as the vLAG cross connects (ISL), and po1 as a vLAG aggregation, with the following commands on BOTH Lenovo switches:

 

vlag enable
vlag tier-id 10
vlag isl port-channel 10
vlag instance 1 port-channel 1 enable

 

I would also recommend you add a health check configuration, that uses the OOB mgmt ports to carry the health check keep alive's. This is to prevent split brain if the ISL were to go down. The command for this would be something like this:

 

vlag hlthchk peer-ip X.X.X.X vrf management

 

Where X.X.X.X points at the IP address on the partner switch on it's mgmt 0 interface (Out of band)

 

Once everything is configured and cabled up, you can use the following commands on the Lenovo switches to confirm operation:

"show port-chan sum" - to confirm LACP has come up on each of the desired ports on each Lenovo switch

"show vlag info" - to confirm vLAG is healthy (you want to see the healthcheck as "up", the ISL as "up" and the po1 vLAG aggregation reporting a state "Formed". If you do not see this you have something wrong and need to troubleshoot.

 

Once everything is correctly up you will have a single 4 port aggregation between the two Lenovo switches and the FS stack, and no spanning-tree blocking, giving you the highest performing and most robust design for your environment.

 

Let us know if you need any assistance getting this working, or if you have any questions.

 

Thanks, Matt

Reply
Options

7 Posts

08-27-2021

Australia

7 Signins

50 Page Views

  • Posts: 7
  • Registered: ‎08-27-2021
  • Location: Australia
  • Views: 50
  • Message 3 of 10

Re:LACP setup issue NE2572

2021-08-28, 2:23 AM

Thanks Matt,

 

Much appreciated.

 

I initially had it as a vLAG configuration but I was getting STP kicking-in just as you have mentioned in your response. I have attached an updated sketch based on your suggestion. Please let me know if this is what you meant. This will make it so much simplier.

 

I have added port 1/1 on the FS stack which is the connection to our other DC via BGP and into our ISP.

 

I have configured OOB management port's on both switches. Will I be able to upgarde the fimware remotely via this? 

 

As can be seen from the sketch, the Lenovo's are not doing any routing and all L3 is being done on the FS level. Do we need to turn off routing on the Lenovo's? I beleive in the Cisco world its "no ip routing"? Or will I have connectivity once the trunk to FS stack is up or will I need to add gateway addreses on both switches?

 

Thanks again,

Steve

 

Reply
Options

192 Posts

06-03-2020

United States of America

164 Signins

1535 Page Views

  • Posts: 192
  • Registered: ‎06-03-2020
  • Location: United States of America
  • Views: 1535
  • Message 4 of 10

Re:LACP setup issue NE2572

2021-08-28, 2:51 AM

Hi Steve,

 

Yes, that diagram is correct.

 

Yes, the upgrade can be performed via the OOB ports. Can also use a USB key if that is easier (instructions included in that previously posted upgrade PDF). Note if you upgrade via remote (i.e. TFTP) over the OOB interface, if the remote server is on a different network, you will need to also add a default gateway to the management VRF, for example:

vrf context management

  ip route 0.0.0.0 0.0.0.0 Y.Y.Y.Y

Where Y.Y.Y.Y is the Default Gateway for the subnet assigned to the OOB interfaces. This DG will ONLY be used by the OOB port, and can not be used by any of the data ports (it is a true VRF instance and isolated from the main switching fabric).

 

No, no need to add any routing (static, DG or otherwise) to the Lenovo switches (other than that management VRF DG mentioned above). Just carry L2 VLANs from the servers to the FS stack (via the Lenovo switches), and the servers should point at the IP on the same VLAN on the FS stack as their default gateway. Also no need to disable routing on the Lenovo switches, it just will not be used in this architecture.

 

Let me know if you run into any issues.

 

Thanks, Matt

 

Reply
Options

7 Posts

08-27-2021

Australia

7 Signins

50 Page Views

  • Posts: 7
  • Registered: ‎08-27-2021
  • Location: Australia
  • Views: 50
  • Message 5 of 10

Re:LACP setup issue NE2572

2021-08-28, 3:54 AM

Thanks Matt,

 

Will do the firmware upgrade but will need to go into the DC and do the physical topology change though.

 

Will let you know how it all goes.

 

Thanks.

 

Steve

Reply
Options

7 Posts

08-27-2021

Australia

7 Signins

50 Page Views

  • Posts: 7
  • Registered: ‎08-27-2021
  • Location: Australia
  • Views: 50
  • Message 6 of 10

Re:LACP setup issue NE2572

2021-09-15, 3:35 AM

Hi Matt,

 

Finally got myself to the DC. We made the changes and so we now have only Po1 as the vLAG instance and Po10 between the 2 lenovo's. The LAG's seemed to have formed correctly but I'm not getting traffic being passed through to the FS switches from my test server. I have placed it it VLAN 12 but cant seem to hit the gateway on the FS. On the arp table on the FS, its coming up as incomplete. Could there still be an issue with my trunks? Have put some configs below. The server is plugged into ethernet 1/1 (10.50.12.1) which I have put switchport access vlan 12. The vlan gateway exists on the FS stack. Not sure what's going on here but any input will be good.

 

Cheers!

Steve

 

dc101(config)#sh port-channel summary
Flags:
D - Down        P - Up in port-channel (members)
S - Switched    R - Routed
I - Individual  s - Suspended
U - Up (port-channel)
B - standBy (members)
------+----------------+--------+-----------------------------------------------
Group  Port-Channel     Protocol Member Ports
------+----------------+--------+-----------------------------------------------
1      po1         (SU)  LACP     Ethernet1/50(P) Ethernet1/52(P)
10     po10        (SU)  LACP     Ethernet1/49(P) Ethernet1/51(P)
sandc101(config)#

 

 

 

dc102(config-if)#
dc102(config-if)#exit
dc102(config)#sh port-channel summary
Flags:
D - Down        P - Up in port-channel (members)
S - Switched    R - Routed
I - Individual  s - Suspended
U - Up (port-channel)
B - standBy (members)
------+----------------+--------+-----------------------------------------------
Group  Port-Channel     Protocol Member Ports
------+----------------+--------+-----------------------------------------------
1      po1         (SU)  LACP     Ethernet1/50(P) Ethernet1/52(P)
10     po10        (SU)  LACP     Ethernet1/49(P) Ethernet1/51(P)
sandc102(config)#

 

 

dc101(config)#sh vlag information
  Global State            : enabled
  VRRP active/active mode : enabled
  vLAG system MAC         : 08:17:f4:c3:dd:09
  ISL Information:
    PCH     Ifindex     State       Previous State
    -------+-----------+-----------+---------------------------------
    10      100010      Active      Inactive

  Mis-Match Information:
                   Local                      Peer
    -------------+---------------------------+-----------------------
    Match Result : Match                      Match
    Tier ID      : 10                         10
    System Type  : NE2572                     NE2572
    OS Version   : 10.10.x.x                  10.10.x.x

  Role Information:
                   Local                      Peer
    -------------+---------------------------+-----------------------
    Admin Role   : Primary                    Secondary
    Oper Role    : Primary                    Secondary
    Priority     : 0                          0
    System MAC   : 80:96:21:c4:f8:01          80:96:21:c4:ff:01

  Consistency Checking Information:
    State             : enabled
    Strict Mode       : disabled
    Final Result      : pass

  FDB refresh Information:
  FDB is doing refresh with below setting:
    FDB refresh is configured
    Bridge FDB aging timer is 1800 second(s)

  FDB synchronization Information:
  FDB is being synchronized.

 Auto Recovery Interval 300s (Finished)

 Startup Delay Interval 120s (Finished)

 Health Check Information:
  Health check retry interval: 30 seconds
  Health check number of keepalive attempts: 3
  Health check keepalive interval: 5 seconds
  Health check status: DOWN

  Peer Gateway State    : disabled

  Total enabled VLAG instances: 1
                    Down      : 0
                    Local UP  : 0
                    Remote UP : 0
                    Formed    : 1

  VLAG instance 1 : enabled
  Instance Information
    PCH        ifindex     State          Previous State    Cons Res
    ----------+-----------+--------------+-----------------+--------
    1          100001      Formed         Remote UP         pass

  vlag dual-active exclude interface vlans: None

dc101(config)#

 

 

 

dc102(config)#sh vlag information
  Global State            : enabled
  VRRP active/active mode : enabled
  vLAG system MAC         : 08:17:f4:c3:dd:09
  ISL Information:
    PCH     Ifindex     State       Previous State
    -------+-----------+-----------+---------------------------------
    10      100010      Active      Inactive

  Mis-Match Information:
                   Local                      Peer
    -------------+---------------------------+-----------------------
    Match Result : Match                      Match
    Tier ID      : 10                         10
    System Type  : NE2572                     NE2572
    OS Version   : 10.10.x.x                  10.10.x.x

  Role Information:
                   Local                      Peer
    -------------+---------------------------+-----------------------
    Admin Role   : Secondary                  Primary
    Oper Role    : Secondary                  Primary
    Priority     : 0                          0
    System MAC   : 80:96:21:c4:ff:01          80:96:21:c4:f8:01

  Consistency Checking Information:
    State             : enabled
    Strict Mode       : disabled
    Final Result      : pass

  FDB refresh Information:
  FDB is doing refresh with below setting:
    FDB refresh is configured
    Bridge FDB aging timer is 1800 second(s)

  FDB synchronization Information:
  FDB is being synchronized.

 Auto Recovery Interval 300s (Finished)

 Startup Delay Interval 120s (Finished)

 Health Check Information:
  Health check retry interval: 30 seconds
  Health check number of keepalive attempts: 3
  Health check keepalive interval: 5 seconds
  Health check status: DOWN

  Peer Gateway State    : disabled

  Total enabled VLAG instances: 1
                    Down      : 0
                    Local UP  : 0
                    Remote UP : 0
                    Formed    : 1

  VLAG instance 1 : enabled
  Instance Information
    PCH        ifindex     State          Previous State    Cons Res
    ----------+-----------+--------------+-----------------+--------
    1          100001      Formed         Local UP          pass

  vlag dual-active exclude interface vlans: None

dc102(config)#

 

 

!
vlag tier-id 10
vlag isl port-channel 10
vlag enable
vlag instance 1 port-channel 1
vlag instance 1 enable
!
vlan 1
!
vlan 10
!
vlan 12
 name ESXi_MANAGEMNT
!
vlan 20
 name vSAN
!
vlan 22
 name vMOTION
!
vlan 25
 name NFS_iSCSI_STORAGE
!
vlan 26
 name TSM_BACKUP
!
vlan 50
 name MORWELL_SERVER
!
vlan 300
 name M1_CORE_SERVICES
!
vlan 301
 name M2_CORE_SERVICES
!
vlan 305
 name M1_CORE_SERVER_LINK
!
vlan 306
 name LINK
!
vlan 310
 name CITRIX_WORKER_CLUSTER
!
interface Ethernet1/1
 switchport access vlan 12
!

 

FS stack sh arp:

 

Internet  10.50.10.100     1577      3868.dd20.bd50  arpa   VLAN 10
Internet  10.50.10.254     --        649d.99d0.54fe  arpa   VLAN 10
Internet  10.50.12.1       <--->     <Incomplete>    arpa   VLAN 12 (server IP)
Internet  10.50.12.254     --        649d.99d0.54fe  arpa   VLAN 12
Internet  10.50.20.254     --        649d.99d0.54fe  arpa   VLAN 20

Reply
Options

192 Posts

06-03-2020

United States of America

164 Signins

1535 Page Views

  • Posts: 192
  • Registered: ‎06-03-2020
  • Location: United States of America
  • Views: 1535
  • Message 7 of 10

Re:LACP setup issue NE2572

2021-09-15, 3:50 AM

Can you share the output from "show int trunk" and "show int status" from the Lenovo switches, and the running config from po1, and the physical ports associated with Po1 from the FS stack? My gut says we are not agreeing on if VLAN 12 is tagged between the FS stack and the Lenovo switches, and the above will show if this is the case.

 

Thanks, Matt

Reply
Options

7 Posts

08-27-2021

Australia

7 Signins

50 Page Views

  • Posts: 7
  • Registered: ‎08-27-2021
  • Location: Australia
  • Views: 50
  • Message 8 of 10

Re:LACP setup issue NE2572

2021-09-15, 4:14 AM

dc101(config)#sh interface trunk
----------------------------------------------------------------------------
Port           Native        Status    Port      Tagged/
               Vlan                    Ch        Untagged
----------------------------------------------------------------------------
Ethernet1/49   1             trunk       10         u
Ethernet1/50   1             trunk       1          u
Ethernet1/51   1             trunk       10         u
Ethernet1/52   1             trunk       1          u
po1            1             trunk       --         u
po10           1             trunk       --         u

----------------------------------------------------------------------------
Port           Allowed VLANs
----------------------------------------------------------------------------
Ethernet1/49   All
Ethernet1/50   All
Ethernet1/51   All
Ethernet1/52   All
po1            All
po10           All

 

---------------------------------------------------------------
Port           STP Forwarding
---------------------------------------------------------------
Ethernet1/50   none
Ethernet1/52   none
po1            1,10,12,20,22,25-26,50,300-301,305-306,310
po10           1,10,12,20,22,25-26,50,300-301,305-306,310
dc101(config)#

 

 

dc101(config)#sh interface status

--------------------------------------------------------------------------------
Port            Name               Status    Vlan      Duplex  Speed   Type
--------------------------------------------------------------------------------
Ethernet1/1     --                 connected 12        full    25000   eth
Ethernet1/2     --                 notconnec 1         full    25000   eth
Ethernet1/3     --                 notconnec 1         full    25000   eth
Ethernet1/4     --                 notconnec 1         full    25000   eth
Ethernet1/5     --                 notconnec 1         full    25000   eth
Ethernet1/6     --                 notconnec 1         full    25000   eth
Ethernet1/7     --                 notconnec 1         full    25000   eth
Ethernet1/8     --                 notconnec 1         full    25000   eth
Ethernet1/9     --                 notconnec 1         full    25000   eth
Ethernet1/10    --                 notconnec 1         full    25000   eth
Ethernet1/11    --                 notconnec 1         full    25000   eth
Ethernet1/12    --                 notconnec 1         full    25000   eth
Ethernet1/13    --                 notconnec 1         full    25000   eth
Ethernet1/14    --                 notconnec 1         full    25000   eth
Ethernet1/15    --                 notconnec 1         full    25000   eth
Ethernet1/16    --                 notconnec 1         full    25000   eth
Ethernet1/17    --                 notconnec 1         full    25000   eth
Ethernet1/18    --                 notconnec 1         full    25000   eth
Ethernet1/19    --                 notconnec 1         full    25000   eth
Ethernet1/20    --                 notconnec 1         full    25000   eth
Ethernet1/21    --                 notconnec 1         full    25000   eth
Ethernet1/22    --                 notconnec 1         full    25000   eth
Ethernet1/23    --                 notconnec 1         full    25000   eth
Ethernet1/24    --                 notconnec 1         full    25000   eth
Ethernet1/25    --                 notconnec 1         full    25000   eth
Ethernet1/26    --                 notconnec 1         full    25000   eth
Ethernet1/27    --                 notconnec 1         full    25000   eth
Ethernet1/28    --                 notconnec 1         full    25000   eth
Ethernet1/29    --                 notconnec 1         full    25000   eth
Ethernet1/30    --                 notconnec 1         full    25000   eth
Ethernet1/31    --                 notconnec 1         full    25000   eth
Ethernet1/32    --                 notconnec 1         full    25000   eth
Ethernet1/33    --                 notconnec 1         full    25000   eth
Ethernet1/34    --                 notconnec 1         full    25000   eth
Ethernet1/35    --                 notconnec 1         full    25000   eth
Ethernet1/36    --                 notconnec 1         full    25000   eth
Ethernet1/37    --                 notconnec 1         full    25000   eth
Ethernet1/38    --                 notconnec 1         full    25000   eth
Ethernet1/39    --                 notconnec 1         full    25000   eth
Ethernet1/40    --                 notconnec 1         full    25000   eth
Ethernet1/41    --                 notconnec 1         full    25000   eth
Ethernet1/42    --                 notconnec 1         full    25000   eth
Ethernet1/43    --                 notconnec 1         full    25000   eth
Ethernet1/44    --                 notconnec 1         full    25000   eth
Ethernet1/45    --                 notconnec 1         full    25000   eth
Ethernet1/46    --                 notconnec 1         full    25000   eth
Ethernet1/47    --                 notconnec 1         full    25000   eth
Ethernet1/48    --                 notconnec 1         full    25000   eth
Ethernet1/49    --                 connected trunk     full    100000  eth
Ethernet1/50    --                 connected trunk     full    100000  eth
Ethernet1/51    --                 connected trunk     full    100000  eth
Ethernet1/52    --                 connected trunk     full    100000  eth
Ethernet1/53    --                 notconnec 1         full    100000  eth
Ethernet1/54    --                 notconnec 1         full    100000  eth
po1             --                 connected trunk     full    100000  eth
po10            --                 connected trunk     full    100000  eth
mgmt0           --                 connected routed    full    1000    eth
loopback0       --                 connected routed    half    NA      eth
Vlan1           --                 connected routed    auto    auto    --
Vlan10          --                 connected routed    auto    auto    --
dc101(config)#

 

 

 

dc102#sh interface trun
----------------------------------------------------------------------------
Port           Native        Status    Port      Tagged/
               Vlan                    Ch        Untagged
----------------------------------------------------------------------------
Ethernet1/49   1             trunk       10         u
Ethernet1/50   1             trunk       1          u
Ethernet1/51   1             trunk       10         u
Ethernet1/52   1             trunk       1          u
po1            1             trunk       --         u
po10           1             trunk       --         u

----------------------------------------------------------------------------
Port           Allowed VLANs
----------------------------------------------------------------------------
Ethernet1/49   All
Ethernet1/50   All
Ethernet1/51   All
Ethernet1/52   All
po1            All
po10           All

 

---------------------------------------------------------------
Port           STP Forwarding
---------------------------------------------------------------
Ethernet1/50   none
Ethernet1/52   none
po1            1,10,12,20,22,25-26,50,300-301,305-306,310
po10           1,10,12,20,22,25-26,50,300-301,305-306,310
dc102#
dc102#
dc102#sh interface status

--------------------------------------------------------------------------------
Port            Name               Status    Vlan      Duplex  Speed   Type
--------------------------------------------------------------------------------
Ethernet1/1     --                 notconnec 12        full    25000   eth
Ethernet1/2     --                 notconnec 1         full    25000   eth
Ethernet1/3     --                 notconnec 1         full    25000   eth
Ethernet1/4     --                 notconnec 1         full    25000   eth
Ethernet1/5     --                 notconnec 1         full    25000   eth
Ethernet1/6     --                 notconnec 1         full    25000   eth
Ethernet1/7     --                 notconnec 1         full    25000   eth
Ethernet1/8     --                 notconnec 1         full    25000   eth
Ethernet1/9     --                 notconnec 1         full    25000   eth
Ethernet1/10    --                 notconnec 1         full    25000   eth
Ethernet1/11    --                 notconnec 1         full    25000   eth
Ethernet1/12    --                 notconnec 1         full    25000   eth
Ethernet1/13    --                 notconnec 1         full    25000   eth
Ethernet1/14    --                 notconnec 1         full    25000   eth
Ethernet1/15    --                 notconnec 1         full    25000   eth
Ethernet1/16    --                 notconnec 1         full    25000   eth
Ethernet1/17    --                 notconnec 1         full    25000   eth
Ethernet1/18    --                 notconnec 1         full    25000   eth
Ethernet1/19    --                 notconnec 1         full    25000   eth
Ethernet1/20    --                 notconnec 1         full    25000   eth
Ethernet1/21    --                 notconnec 1         full    25000   eth
Ethernet1/22    --                 notconnec 1         full    25000   eth
Ethernet1/23    --                 notconnec 1         full    25000   eth
Ethernet1/24    --                 notconnec 1         full    25000   eth
Ethernet1/25    --                 notconnec 1         full    25000   eth
Ethernet1/26    --                 notconnec 1         full    25000   eth
Ethernet1/27    --                 notconnec 1         full    25000   eth
Ethernet1/28    --                 notconnec 1         full    25000   eth
Ethernet1/29    --                 notconnec 1         full    25000   eth
Ethernet1/30    --                 notconnec 1         full    25000   eth
Ethernet1/31    --                 notconnec 1         full    25000   eth
Ethernet1/32    --                 notconnec 1         full    25000   eth
Ethernet1/33    --                 notconnec 1         full    25000   eth
Ethernet1/34    --                 notconnec 1         full    25000   eth
Ethernet1/35    --                 notconnec 1         full    25000   eth
Ethernet1/36    --                 notconnec 1         full    25000   eth
Ethernet1/37    --                 notconnec 1         full    25000   eth
Ethernet1/38    --                 notconnec 1         full    25000   eth
Ethernet1/39    --                 notconnec 1         full    25000   eth
Ethernet1/40    --                 notconnec 1         full    25000   eth
Ethernet1/41    --                 notconnec 1         full    25000   eth
Ethernet1/42    --                 notconnec 1         full    25000   eth
Ethernet1/43    --                 notconnec 1         full    25000   eth
Ethernet1/44    --                 notconnec 1         full    25000   eth
Ethernet1/45    --                 notconnec 1         full    25000   eth
Ethernet1/46    --                 notconnec 1         full    25000   eth
Ethernet1/47    --                 notconnec 1         full    25000   eth
Ethernet1/48    --                 notconnec 1         full    25000   eth
Ethernet1/49    --                 connected trunk     full    100000  eth
Ethernet1/50    --                 connected trunk     full    100000  eth
Ethernet1/51    --                 connected trunk     full    100000  eth
Ethernet1/52    --                 connected trunk     full    100000  eth
Ethernet1/53    --                 notconnec 1         full    100000  eth
Ethernet1/54    --                 notconnec 1         full    100000  eth
po1             --                 connected trunk     full    100000  eth
po10            --                 connected trunk     full    100000  eth
mgmt0           --                 connected routed    full    1000    eth
loopback0       --                 connected routed    half    NA      eth
Vlan1           --                 connected routed    auto    auto    --
Vlan10          --                 connected routed    auto    auto    --
dc102#

Reply
Options

7 Posts

08-27-2021

Australia

7 Signins

50 Page Views

  • Posts: 7
  • Registered: ‎08-27-2021
  • Location: Australia
  • Views: 50
  • Message 9 of 10

Re:LACP setup issue NE2572

2021-09-15, 4:38 AM

FS switch output from agg 1:

 

netdc101(config)#sh interface aggregatePort 1
Index(dec):119 (hex):77
AggregatePort 1 is UP  , line protocol is UP
  Hardware is AggregateLink AggregatePort, address is 649d.99d0.54fd (bia 649d.99d0.54fd)
  Description: 
  Interface address is: no ip address
  Interface IPv6 address is:
    No IPv6 address
  MTU 1500 bytes, BW 400000000 Kbit
  Encapsulation protocol is Ethernet-II, loopback not set
  Keepalive interval is 10 sec , set
  Carrier delay is 2 sec
  Ethernet attributes:
    Last link state change time: 2021-09-15 13:11:11
    Time duration since last link state change: 0 days,  1 hours, 24 minutes, 59 seconds
    Priority is 0
    Medium-type is Fiber
    Admin duplex mode is AUTO, oper duplex is Full
    Admin speed is 100G, oper speed is 100G
    Flow control admin status is OFF, flow control oper status is OFF
    Admin negotiation mode is OFF, oper negotiation state is OFF
    Storm Control: Broadcast is OFF, Multicast is OFF, Unicast is OFF
    Admin FEC mode is auto, oper FEC mode is auto
  Bridge attributes:
    Port-type: trunk
    Native vlan: 1
    Allowed vlan lists: 1-79,83-4094
    Active vlan lists: 1,10,12,20,22,25-27,50,300-301,303-307,310
                       999
  Aggregate Port Informations:
        Aggregate Number: 1
        Name: "AggregatePort 1"
        Members: (count=4)
        Lower Limit: 1
        HundredGigabitEthernet 1/0/49            Link Status: Up       Lacp Status: bndl
        HundredGigabitEthernet 1/0/51            Link Status: Up       Lacp Status: bndl
        HundredGigabitEthernet 2/0/49            Link Status: Up       Lacp Status: bndl
        HundredGigabitEthernet 2/0/51            Link Status: Up       Lacp Status: bndl
    Load Balance by: Source MAC and Destination MAC
  Rxload is 1/255, Txload is 1/255
  Input peak rate: 28122 bits/sec, at 2021-09-13 09:52:05
  Output peak rate: 70524 bits/sec, at 2021-09-13 09:52:05
   10 seconds input rate 2482 bits/sec, 3 packets/sec
   10 seconds output rate 26714 bits/sec, 19 packets/sec
    790459 packets input, 59941425 bytes, 0 no buffer, 0 dropped
    Received 384 broadcasts, 0 runts, 0 giants
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 abort
    3344250 packets output, 501712472 bytes, 0 underruns , 0 no buffer, 381573 dropped
    0 output errors, 0 collisions, 0 interface resets

 

 

Reply
Options

7 Posts

08-27-2021

Australia

7 Signins

50 Page Views

  • Posts: 7
  • Registered: ‎08-27-2021
  • Location: Australia
  • Views: 50
  • Message 10 of 10

Re:LACP setup issue NE2572

2021-09-21, 0:38 AM

Hi all,

 

So this is now resolved. It turns out that all I had to to was configure the ports to the server(s) as trunk ports. The Esxi server ports are setup as trunk ports. vLAG/LACP was all good as per my attached topology. I can now ping from a server all the way to the FS stack. During my earlier troubleshooting, I had configured this however I did not wait long enough for STP to sort itself out and reconverge. It took between 15-20 seconds for the network to reconverge. 

 

I'd like to thank @mslavin-new for tips along the way in troubleshooting this. Really appreciated.

 

Cheers!

Steve

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All