cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
amos_batto
Paper Tape
Posts: 5
Registered: ‎08-15-2016
Location: US
Views: 7,194
Message 1 of 2

Installing Debian Linux on the Thinkpad T450s

I just finished installing Debian Linux (Jessie version 8.5) on my Thinkpad T450s and wanted to share my experience so it will benefit others. 

 

Here are the specs for my machine:

Thinkpad T450s (20BX001PUS)

Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz

Samsung K4B8G1646B-MYK0 4GB DDR3 1.35V 1600MHz RAM

(I added an additional Crucial 8GB RAM stick)

Seagate ST500LM021-1KJ152 500GB 6GB/s 7mm SATA harddrive

SanDisk U110 16GB M.2 SATA 22x42mm caching SSD

Innolux N140FGE-EA2 TN 1600x900 matte screen

(I upgraded this to a InnoLux N140HCE-EAA IPS 1920x1080 matte screen)

Intel 7265 Wireless (WiFi and Bluetooth)

Realtek RTS5227 PCI Express Card Reader

Chicony webcam

Validity Sensors VFS5011 fingerprint reader (ID: 138a:0017)

 

The installation went smoothly except that the Intel 7265 Wireless card requires the proprietary firmware-iwlwifi driver, which can be installed from the Debian non-free repository. If you are like me and are using WiFi for your internet connection, then download the firmware-iwlwifi package for Jessie and place it on a USB memory stick. When the Installation Wizard  fails to activate the wireless device for internet access, an error message will appears and ask you if you have the driver. Stick the USB pendrive in the computer and install it. 

If you don't install it that way, then after finishing the install, you can install it from the Debian repos if you have an internet connection through an ethernet cable:

su
apt-get install firmware-iwlwifi

If you don't have an ethernet cable, then you can install it manually from the downloaded .deb package file:

su

dpkg -i firmware-iwlwifi_0.43_all.deb

 

After installing, I found that the 3.16 kernel used by Debian Jessie doesn't support hibernation in the T450s, so I installed the 4.6 kernel from the Backports repository which does support hibernation:

1. Edit /etc/apt/sources.list and add the line:

deb http://http.debian.net/debian/ jessie-backports main contrib non-free
2. Then, update the package list:
apt-get update

3. Then install the latest kernel in the Backports repo:

apt-get install -t jessie-backports linux-image-amd64 linux-headers-amd64

4. Finally set the pinning by creating the /etc/apt/preferences.d/backports file with the following content:

 

Package: linux-image-*
Pin: release a=jessie-backports
Pin-Priority: 1001

Package: linux-headers-*
Pin: release a=jessie-backports
Pin-Priority: 1001

Package: *
Pin: release a=jessie-backports
Pin-Priority: 499

 

Updating the kernel will fix hibernation, but it also break the wireless, because a more recent driver is needed for kernel 4.6. If you install the firmware-iwlwifi package from the testing repo, the WiFi will only work sporadically. If you run dmesg, you will see error messages that the driver is looking for the iwlwifi-7265D-20-ucode firmware, so it is loading the first it can find, which is iwlwifi-7265D-16-ucode.

The solution I found is to go to https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release
and download the iwlwifi-7265D-20-ucode firmware, which is available here:

https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/linux-firmware.git/plain/iwlwifi-7265D-20.ucode

Then copy it into the /lib/firmware directory:

cp iwlwifi-7265D-20.ucode /lib/firmware/

Upgrading the kernel will also break the installation of Virtualbox. To solve this problem, first uninstall virtualbox, then install it from backports:

apt-get purge virtualbox

apt-get install -t jessie-backports virtualbox

The touchpad is pretty good in GNOME 3, but jumps all over the place when I'm typing in the Cinnamon desktop, so I reconfigured it. I created two new “Startup Programs”, to execute the following two commands:

syndaemon -i 0.5 -d -K

synclient PalmDetect=1 PalmMinZ=100

 

The palm detection does not seem to work correctly so these setting probably need more fiddling, but at least the mouse doesn't jump around on the screen when I'm typing. The mouse has frozen on the screen several times when I have been running syndaemon. The only workaround I have found is to enter the following commands in a terminal to reload the psmouse kernel module:

su

modprobe -r psmouse; modprobe psmouse

 

 

The audio at 100% volume in Linux is not as loud as in Windows. This posts suggests using pacmd to increase the volume:
http://askubuntu.com/questions/51156/how-can-i-reach-over-100-volume-with-a-keyboard-shortcut

However when I execute the command:

pacmd set-sink-volume 0 102400

The following error message is displayed:

Daemon not responding.

However, the volume control applet can increase the volume to 125%, which works well enough and VLC can be used to increase the volume 150%.

 

The fingerprint reader does not work with fprintd, but according to this post it may be possible to use it by compiling an experimental driver:
https://gist.github.com/foosel/3abd45bc1b6ae121965b

 

The webcam and microphone works perfectly using Cheese. The media card reader can read SD cards. Most of the Fn+F* keys work, except for: Fn+F9 (Open Control Panel), Fn+F10 (Open search dialog), Fn+F11 (view list of opened programs). In Cinnamon Fn+F12 opens the user's home directory in the file manager, whereas in Windows it opens the Computer in the File Explorer. The Fn+F1 (Mute/Unmute audio) and Fn+F4 (Mute/Unmute microphone) key combinations work, but they do not activate the LEDs in the F1 and F4 keys. However, the LED in the Fn works when the Fn+ESC combination is pressed to turns on and off the function key lock.

 



amos_batto
Paper Tape
Posts: 5
Registered: ‎08-15-2016
Location: US
Views: 7,147
Message 2 of 2

Re: Installing Debian Linux on the Thinkpad T450s

I compiled and installed fingerprint-gui and fprint_vfs5011 to test out the fingerprint reader. It seems to function, but I could never get fingerprint-gui to verify my fingerprint after I had registered it. No matter how many times I swiped it, I never could get my fingerprint to match. It seems that you have to have a perfect match. Even in Windows, I usually have to swipe my finger at least 3 times before it will verify my fingerprint. In my opinion, fingerprint readers which require a swipe are a waste of time, because you have to swipe your finger at the same speed every time.

 

I could not figure out how to configure lightdm to use the fingerprint reader. It is probably a PAM configuration problem. I'm not going to bother fiddling with this.

Check out current deals!


Shop current deals