English Community

Linux Operating SystemsDebian
All Forum Topics
Options

55 Posts

12-25-2009

EU

181 Signins

896 Page Views

  • Posts: 55
  • Registered: ‎12-25-2009
  • Location: EU
  • Views: 896
  • Message 1 of 42

W520, Debian 64-bit (Testing) + VT enabled

2012-02-06, 9:41 AM

Hello all,

 

 

on booting the abovmentioned configuration, at boot time, everything stops with multiple "udev..." messages.

 

If I disable VT, boot process completes.

 

I have tried a different Linux flavour (Gentoo 64-bit) and the same thing happens with VT enabled.

 

Anyone any ideas??

 

 

Regards,

 

 

 

Aubrey

 

 

 

PS Debian Kernel is 3.2.

Reply
Options

8263 Posts

01-13-2008

US

77234 Signins

2188854 Page Views

  • Posts: 8263
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2188854
  • Message 2 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

2012-02-06, 15:18 PM

Hi Mainframe_Snob,

 

Is there anything useful in the thread below?  I haven't chased down all the links, but it looks similar.

 

64-bit Linux, W520 & nVidia

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

55 Posts

12-25-2009

EU

181 Signins

896 Page Views

  • Posts: 55
  • Registered: ‎12-25-2009
  • Location: EU
  • Views: 896
  • Message 3 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

2012-02-06, 15:28 PM

Appreciate the prompt reply.

 

Afraid none of the solutions are applicable in my case.

 

*MUST* be able to run 64-bit.

 

 

 

Regards,

 

 

 

Aubrey

Reply
Options

342 Posts

03-02-2010

Dublin

1628 Signins

9783 Page Views

  • Posts: 342
  • Registered: ‎03-02-2010
  • Location: Dublin
  • Views: 9783
  • Message 4 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

2012-02-09, 7:02 AM

I'm running Fedora 16 64-bit on my W520 with VT-d enabled. The difference is that I disabled the NVidia card in the bios and use the Intel graphics. Better battery life, too. 

 

This bug with the NVidia driver/chip has been out for a while now. It would be nice if somebody at NVidia would fix it, or give us the source so we can fix it ourselves...

 

Edit: seems like its fixed in NVidia driver 295.09 beta (beta is a state of mind!)

Reply
Options

55 Posts

12-25-2009

EU

181 Signins

896 Page Views

  • Posts: 55
  • Registered: ‎12-25-2009
  • Location: EU
  • Views: 896
  • Message 5 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

2012-02-09, 7:27 AM

I am afraid with the Nvidia Beta driver 295.09 this problem has not gone away..

Reply
Options

55 Posts

12-25-2009

EU

181 Signins

896 Page Views

  • Posts: 55
  • Registered: ‎12-25-2009
  • Location: EU
  • Views: 896
  • Message 6 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

2012-02-24, 16:19 PM

Hello all,

 

I see that BIOS 1.36 has been released for the abovementioned Thinkpad.

 

I have duly installed same but STILL CANNOT boot my Debian 64-bit Linux with VT-D enabled.

 

Thousands of "DRAM..error" and / or UDEV messages are issued at the start of the boot sequence.

 

I do not want to run this machine with ACPI=off and only run with one CPU or try any hacks to try and circumvent this nor am I interested in running on the integrated Intel GPU (which also does not work, see above error message description).

 

I am currently running with the Nvidia 295.09 driver.

 

 

A DEFINITIVE STATEMENT from Lenovo on whether this is a BIOS problem or not would be helpful.

 

 

Reply
Options

55 Posts

12-25-2009

EU

181 Signins

896 Page Views

  • Posts: 55
  • Registered: ‎12-25-2009
  • Location: EU
  • Views: 896
  • Message 7 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

2012-02-26, 15:03 PM

** No interest or competence here ?? **

 

 

Still waiting for a reply.

 

 

 

Aubrey

 

 

 

PS Not impressed at all.

Reply
Options

8095 Posts

11-19-2007

US

10101 Signins

400183 Page Views

  • Posts: 8095
  • Registered: ‎11-19-2007
  • Location: US
  • Views: 400183
  • Message 8 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

2012-02-26, 17:18 PM

Mainframe_Snob,

 

Please understand that the Linux boards in this forum are going to have to run as peer to peer support.  Lenovo supports the Windows preloads, so while it is possible we have some quirk that needs to be addressed in BIOS it is difficult to open this as a formal problem for engineering to chase to a definitive solution.

 

If this ALSO occurs under windows, then it may be easier to obtain greater focus on the issue.

 

That said, if you will post some additional details on this including the error list.  (Is there a way you can capture the list?) 

We can try check into this a bit further.

 

I appreciate your understanding.  

 

Thanks

 

Mark

Reply
Options

55 Posts

12-25-2009

EU

181 Signins

896 Page Views

  • Posts: 55
  • Registered: ‎12-25-2009
  • Location: EU
  • Views: 896
  • Message 9 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

2012-02-26, 18:33 PM

Hello Mark,

 

as these messages  (see previous posts) happen at the very start of the boot sequence, it is impossible for the kernel to start writing its logs, hence the difficulty in providing "hard" evidence.

 

Supposedly there was a Linux kernel (IOMMU) bug in the early 3.x kernels that should have been addressed in the latest (3.3) kernel, alas, this is not the case - still the same problem. See this post - http://www.phoronix.com/scan.php?page=news_item&px=MTAzNzk

 

The problem also occurs when I use the Intel integrated graphics card only (i.e. disable the Nvidia card).

 

I have tried this (enable VT-d) with Liquorix kernels 3.0-3.2 and a vanilla 3.3 kernel, all with the same result.

 

Here is one of many google hits returned if one enters the following keywords "w520  bios vt-d dmar boot"

 

http://web.archiveorange.com/archive/v/u1yF7FblX57xwavu9sBj

Reply
Options

55 Posts

12-25-2009

EU

181 Signins

896 Page Views

  • Posts: 55
  • Registered: ‎12-25-2009
  • Location: EU
  • Views: 896
  • Message 10 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

2012-02-27, 15:30 PM

@Mark,

 

 

below URL for W520 DMESG boot with VT-d disabled.

 

[URL=http://www.zshare.net/download/99166017a138c52e/]W520-Boot-VT-d_disabled.txt - 0.04MB[/URL]

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete