Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

External Displays, Options and AccessoriesDisplays, Options and Accessories
All Forum Topics
Options

2 Posts

07-06-2021

United States of America

2 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎07-06-2021
  • Location: United States of America
  • Views: 10
  • Message 1 of 3

Docking Station 40AJ's USB and Audio port not working after Windows 10 Servicing Stack Update

2021-07-06, 20:30 PM

Hello,

 

A few days ago Windows 10 Update installed Servicing Stack 10.0.19041.1022 on my T480s laptop. After the reboot all USB ports and the audio port on mt 40AJ Docking Station stopped working. Display ports still work. I checked for updates with Lenovo Vantage and it can't find any new docking station updates. I downloaded the latest available firmware from the following link:

 

https://pcsupport.lenovo.com/us/en/downloads/DS505699

 

When I run the updater I get:

 

USB Audio can't be detected.

Return Code:-10

 

I also tried my laptop with another docking station and I ran into the same problem with USB and audio not working. So I know that most likely the Servicing Stack update is what caused the problem but I can't roll that update back because Windows won't let you uninstall Servicing Stack updates. So I am hoping someone has experienced the same issue and has a workaround or Lenovo will take notice of this issue and provide a fix. I have been using my laptop with this docking station for about 3 years and never had any issues like this until this latest Servicing Stack update.

Reply
Options

5580 Posts

08-02-2018

Philippines

922 Signins

28419 Page Views

  • Posts: 5580
  • Registered: ‎08-02-2018
  • Location: Philippines
  • Views: 28419
  • Message 2 of 3

Re:Docking Station 40AJ's USB and Audio port not working after Windows 10 Servicing Stack Update

2021-07-07, 10:27 AM

 

Hi bande18!


Welcome to community forums

 

 

Have you tried a system restore to an earlier date when the computer was working fine?

 

Try installing the dock audio driver first while the dock is connected. Restart the computer then install the dock station firmware utility.

 

You can get it here: https://pcsupport.lenovo.com/us/en/products/accessory/docks/thinkpad-ultra-docking-station/40aj/downloads/driver-list/

 

Let us know how it goes.

 

 

 

Jwes_Lenovo



Did someone help you today? Press the thumbs-up icon below to thank them.!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.


Using Browser Search to find your answers in Lenovo and Moto Community

Reply
Options

2 Posts

07-06-2021

United States of America

2 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎07-06-2021
  • Location: United States of America
  • Views: 10
  • Message 3 of 3

Re:Docking Station 40AJ's USB and Audio port not working after Windows 10 Servicing Stack Update

2021-07-07, 14:07 PM

Thanks for the quick reply. Unfortunately, I do not have a backup I can roll back to since it's been more than 10 days since the update (I was on vacation when it installed). I did try to uninstall the update but since it's a servicing stack update Windows won't let me do that either. So I am stuck and desperately trying to fix this issue for the many USB devices I have connected to the dock and need to use on a daily basis.

 

I have tried what you suggested, the audio driver installed without errors and after the reboot I attempted to install "Firmware for ThinkPad Ultra/Pro/Basic Docking Station" version 3.3.1 but I received the same error messages I described in my previous post.

 

Another thing I wanted to mention is that I noticed that the Thunderbolt Software doesn't see the controller or any devices when I start it, it just shows a completely blank panel. Not sure if this has something to do with the dock not working or not, I've never payed much attention to the Thunderbolt software but I've read on forums that people re-installed the Thunderbolt software and that fixed their issue with the docking station. I've tried that as well but it didn't help.

 

Any other ideas what I can try besides restoring my PC to factory defaults and re-installing all my apps? (I reeeeaaally don't want to do that)

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms