cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
csco
Fanfold Paper
Posts: 5
Registered: ‎10-05-2016
Location: CY
Views: 3,261
Message 1 of 4

OneLink+ cannot update firmware

Hi,

 

I have a problem with OneLink+, where DP is not working. I believe a firmware update should fix this. The update.log which is returned from tp_onelinkplus_dock_fw.exe is:

 

Version: 0.00.000
Update result: 255
Error description: Can't connect to Synaptics VMMxxxx DP hub IC

 

The paradox is that I am trying to update the firmware to fix the DP and firmware won't update unless you have a DP already connected. 

 

In my quest to fix this, I have downloaded many files some of those where for an incorrect model, pressumably the other OneLink. I am now wondering if I have overwritten the firmware of OneLink+ with that of OneLink. Is that possbile?

 

 

Is there any other way to fix this?

Guru
Posts: 1,916
Registered: ‎02-27-2012
Location: US
Views: 3,181
Message 2 of 4

Re: OneLink+ cannot update firmware

Hi csco

 

I had got the same error "Can't connect to Synaptics VMMxxxx DP hub IC" when I run that firmware update without any dock installed.

 

If you have the "Thinkpad Onelink+" (40A40090US) this is the support site and the latest firmware version is the "V2.30.000" from 22 Mar 2016.

https://support.lenovo.com/ec/es/documents/acc100252

 

Please double check your dock model just in case.

 

I also recommend to check your Thinkpad model support for any BIOS update. Lenovo has relased some updates for the onelink+ in some Thinkpad models.

 

Regards












Martín Itúrbide
OS2World.com NewsMaster
Self-proclaimed Trackpoint Fan Club President
"Don't Panic" 
Wil Wheaton
Remember: Your Friend Wil Declares....
Please click "Kudos" for Ego Boost !!


 

pabear
What's DOS?
Posts: 1
Registered: ‎12-27-2016
Location: US
Views: 2,999
Message 3 of 4

Re: OneLink+ cannot update firmware

The problem with your solution is that it requires one monitor working on the docking station! How do you update the bios if you dont have at least one monitor working on the docking station?  I know that if i can get this bios loaded it will probably fix my problem.  Little catch22. Any help would be appreicated.

motorro
Ctrl-Alt-Del
Posts: 11
Registered: ‎03-17-2014
Location: Russia
Views: 2,974
Message 4 of 4

Re: OneLink+ cannot update firmware

Now the support page displays 2.33 as a current version since December 8th

The README states some DP issues has been solved. 

However either the file is built wrong or the site is not actually updated because when trying to upgrade log-file tells me the same 2.30 is being installed and update is not needed:

Version: 2.30.000
Update result: 16
Error description: Your device has already got the same Firmware version 2.30.000 installed

I've mailed a tech support and they say "they have no 2.33 version at all" and the whole update announcement is a mistype Smiley Happy

Here is a quote if you can read Russian.

Здравствуйте, Николай!
Спасибо за обращение в компанию Lenovo.

Сожалею, но версии 2.33 нет. На сайте опечатка.

Для нас очень важно сотрудничество с вами.
С уважением, Артур
Служба поддержки клиентов Lenovo

It will be great however if Lenovo officials could post an official statement here...

Check out current deals!


Shop current deals

Top Kudoed Authors