English Community

External Displays, Options and AccessoriesDisplays, Options and Accessories
All Forum Topics
Options

29 Posts

07-24-2014

CA

63 Signins

412 Page Views

  • Posts: 29
  • Registered: ‎07-24-2014
  • Location: CA
  • Views: 412
  • Message 1 of 5

Thunderbolt 3 Dock Audio Pop Issue

2018-08-27, 14:20 PM

Hey all. There's unfortunately no forum dedicated to things like docks but I am using a T480 so I'm posting it here.

 

I was recently given a brand new T480 for work and my employer also purchased the Thunderbolt 3 Dock to go with it. It's working quite reliably but I'm having one annoying issue with it which is audio pop.

 

I use a headset that's plugged into the 3.5mm jack on the front of the dock. Audio playback is fine but when not playing anything back, a random pop occurs when I'm doing things such as surfing around the web or switching between applications. It will regularly just play a small but really annoying pop sound in the headset. I know the headset is fine as I've used it on other machines without issue. This can often be the result of the audio chip changing power states but there's no way to change that with the dock as far as I can tell. I'm also on the latest firmware and drivers for the dock.

 

Has anyone else seen this and do you have any suggestions on how to prevent it? The constant popping is really frustrating and definitely shouldn't be an issue in an accessory this expensive. Thanks!

Reply
Options

19 Posts

08-11-2018

US

22 Signins

200 Page Views

  • Posts: 19
  • Registered: ‎08-11-2018
  • Location: US
  • Views: 200
  • Message 2 of 5

Re: Thunderbolt 3 Dock Audio Pop Issue

2018-09-24, 15:25 PM
Hey, I've been experiencing this for a few months. I've got a Lenovo P52s and my speaker system does the same thing. Any time the audio driver seems to be involved (if a video is on the page, or even in Google Calendar in a browser!) it pops. People have mentioned that it's something to do with the power management driver, but I haven't ever been able to find a permanent fix for it. It's very frustrating, so now I'm forced to use the onboard Realtek HD Audio driver and plug my speakers into the PC directly and bypass the Thunderbolt dock for audio until they figure it out.
Reply
Options

19 Posts

08-11-2018

US

22 Signins

200 Page Views

  • Posts: 19
  • Registered: ‎08-11-2018
  • Location: US
  • Views: 200
  • Message 3 of 5

Re: Thunderbolt 3 Dock Audio Pop Issue

2018-09-24, 15:28 PM
This was the other thread I was involved with that temporarily fixed the issue (rolling back the driver) but the issue started up again several days ago.

https://forums.lenovo.com/t5/ThinkPad-P-and-W-Series-Mobile/P52s-After-Newest-Power-Mgmt-Driver-Speakers-Make-Popping-Noise/td-p/4189321
Reply
Options

1 Posts

08-27-2019

FI

1 Signins

27 Page Views

  • Posts: 1
  • Registered: ‎08-27-2019
  • Location: FI
  • Views: 27
  • Message 4 of 5

Re: Thunderbolt 3 Dock Audio Pop Issue

2019-08-27, 12:05 PM

Hey,

 

I found a permanent fix for this in my case :

 

Im using the Lenovo Thinkpad P52S and Gen2  Thunderbolt 3 dock with it.

Connections from the dock :

2x DELL P2417H / 1080p 

1x HP ZR22W / 1080p

Plantronics 8200 Wireless Conference headset

Wireless KB

Wireless M

 

+ Couple of work related accessories connected via usb 

 

I also have UE's small Bluetooth-speaker connected via the Docks front 3,5mm jack and initially i had its power taken from the docks back USB-ports, and it was keeping constant static noise wich was driving me nuts.

 

After disconnecting the speakers power supply from the dock USB and switching to an external power-source ( some old Samsungs phone charger + MicroUSB-cable ) the static noise vanished completely.

Reply
Options

3 Posts

11-12-2014

SE

7 Signins

41 Page Views

  • Posts: 3
  • Registered: ‎11-12-2014
  • Location: SE
  • Views: 41
  • Message 5 of 5

Re: Thunderbolt 3 Dock Audio Pop Issue

2020-02-11, 17:27 PM

I have a similar problem even though my Thunderbolt Dock 3 (Gen2, ArtNr: 40AN0230EU) have been updated to latest fw of today (2020-02-11)..

I have a Lenovo X1 Extreme Gen2 connected to it, and when I connect an Altec Lancing THX 5.1 system to the Dock, via analogue 3,5mm connector on the front of the dock, I get ramdomly popping sounds.

(Not to mention all problems with black/fickering screens, etc.. But that's another story for another thread, perhaps

But, if I connect the same speakers to the X1 Extreme Gen2's earphone outlet instead, it works as expected...

I've never had any problems with these speakers when using a Thinkpad T560 with its related UltraDock ("genuine" dock). It just worked.

As they should.

 

It seems as if these newer Lenovo docks are a pain... From my earlier personal experience at a small Swedish insurance company (+30 docks of another USSB-C based model, but still Lenovo, and with Lenovo X250 etc) they also had a hard time even getting these docks to work in a decent way... struggling with them for months, with fw updates etc.

I really thought Lenovo would have put some effort in these really expensive Thunderbolt docks but it seems to be the same, still..

If Lenovo instead would focus on fewer dock models that worked for a larger amount of models they would probably earn more money and have more satisfied customers......

As it is now, the customers will finally leave Lenovo - First when it comes to finding a working dock from 3rd party (?), then maybe even leave as portable supplier.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete