cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
karolinanna
Fanfold Paper
Posts: 5
Registered: ‎07-05-2019
Location: CA
Views: 530
Message 1 of 4

Thunderbolt 3 Dock firmware update failing (40AC0135US)

When I search my dock's serial number, it  gives me machine type model:40AC0135US.

 

Lenovo Vantage and Lenovo Update (this issue is across multiple computers (models T480 and a T470s) and multiple docks of the same model, some have Vantage installed, some have Lenovo Update) are showing that there is a firmware update for my Thunderbolt 3 dock. This update fails. It is ThingPad TBT3 Dock Firmware Update Package -10 [64] - V.V1.00.12-1.20.00

IMG_1413.JPG

An error window pops up with the following message:

"Failed to update the Device Firmware. Restart this program and try again."

IMG_1416.JPG

Things I have tried:

  1. I have obviously tried again, I have restarted and tried again. It continiously fails whether it is via Vantage or Lenovo Update.
  2. Going on Lenovo Support, entering in the serial number and trying Automatic Drive Update. (This installs Lenovo Bridge)
    • Finds NO updates:
    • IMG_1418.JPG
  3. Downloaded the driver and firmware from the downloads page:
    1. 3546i5434.PNG
    2. I updated, the driver, that was successful. I had to enable Winfows Features, Net 3.5 Framework for it.
    3. The Fock Firmware Update Tool downloads and opens up.
      • It tells me that the Audio FW is missing
      • I press "Start"
      • I get "Audio update timeout!", "FW update Fail!"
      • IMG_1419.JPG

Setup:

Laptop plugged via thunderbolt usb c

Two Dell monitors connected to the dock via display port cables (the monitors do have hdmi ports btw)

One monitor has a sound bar that plugs via usb to the back of the monitor.

 

I am considering trying to unplug the monitor that has the sound bar and plugging the first monitor in via HDMI cable and seeing if that works.

If anyone has any insight or can provide any other troubleshooting I can try, please advise.
Please let me know if any additional info is needed.

Social Support Agent
Social Support Agent
Posts: 1,122
Registered: ‎08-02-2018
Location: US
Views: 283
Message 2 of 4

Re: Thunderbolt 3 Dock firmware update failing (40AC0135US)

Hi Karolinanna! Welcome to our forums community. When updating manually from the website, it is not recommended to perform the automatic updates. The Lenovo Vantage is intended for Ideapads while the Think Vantage is intended for Thinkpad lines. This is both recommended for Windows 10 OS. Run the update and install all detected updates. Update us how it goes.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

karolinanna
Fanfold Paper
Posts: 5
Registered: ‎07-05-2019
Location: CA
Views: 244
Message 3 of 4

Re: Thunderbolt 3 Dock firmware update failing (40AC0135US)

Automatic updates were tried as there was another thread that suggested it.

Is it recommended we uninstall Lenovo Vantage from our Thinkpad machines (T470 and T480 and also the Carbons)?
When I look at the support page of one of the T480 laptops (https://pcsupport.lenovo.com/ca/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-...) I do not see a link to install any ThinkVantage software. Can you direct me to the appropriate software for driver updates on these machines?

As I said above, whether I tried to install the update vie Lenovo Vantage, Lenovo Update, or manually, it still was failing. The text document does say that if your dock is working correctly, you may not need the firmware update but Vantage was popping off saying it was "critical."

I tried Lenovo Vantage, the update fails, I tried manually, the update fails, I tried System Update and it fails. It seems like it fails regardless what method chosen so I don't really understand what update process you are wanting me to try.

iapom
Paper Tape
Posts: 2
Registered: ‎08-08-2019
Location: US
Views: 198
Message 4 of 4

Re: Thunderbolt 3 Dock firmware update failing (40AC0135US)

Has this been resolved? I'm having a pretty similar issue with my brand new 40AN0135US and am considering returning it if no solutions are found. I can't believe Lenovo is selling a device as unusable as this.

Check out current deals!


Shop current deals

Top Kudoed Authors