cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jnk_lenovo
Paper Tape
Posts: 4
Registered: ‎08-27-2009
Location: US
Views: 1,770
Message 1 of 6

USB-C (GEN 2) Dock - PXE not working

I received a USB-C Gen 2 docking station for testing in our environment as the the Gen 1 is no longer available. The dock itself works for normal use with all of our hardware models (X1 Carbon (5th and 6th), Yoga 370/380), however, PXE does not.

 

PXE works fine with the Gen 1 dock as does the Ethernet Dongle using the same hardware.

 

From a cold-boot, I press F12 to access the Boot Menu and then select LAN / PXE. It "thinks" for a few seconds and then loops back to the Boot Menu.

 

SecureBoot / UEFI is enabled; IP-Helpers are configured correctly; DHCP Options are not configured. There is nothing in the SMSPXE log as it does not appear to be getting that far. The dock Firmware has been updated to the latest version. The laptop BIOS has been updated to the latest version. The BIOS settings for Thunderbolt are set correctly (No Security // USB devices enabled, etc.).

 

Help! What am I missing?

 

 

AmoSohi
Paper Tape
Posts: 2
Registered: ‎07-24-2019
Location: GB
Views: 1,682
Message 2 of 6

Re: USB-C (GEN 2) Dock - PXE not working

Hi,

 

Have you managed to resolve PXE boot using the Gen 2 dock as I am also having the same issue.

 

Thanks

jnk_lenovo
Paper Tape
Posts: 4
Registered: ‎08-27-2009
Location: US
Views: 1,666
Message 3 of 6

Re: USB-C (GEN 2) Dock - PXE not working

I reached out to our rep and one of the hardware engineers and they suggested I upgrade the dock and Thunderbolt Firmware. While I had the hood open, I also updated the system BIOS. This fixed the issue for one of the models but I have 3 more that it still is not working on. I am distracted with some other project work right now but will get back to this as soon as I can and provide another update.

Administrator
Administrator
Posts: 7,291
Registered: ‎09-03-2014
Location: SK
Views: 1,629
Message 4 of 6

Re: USB-C (GEN 2) Dock - PXE not working

Hello,

 

I just took a look in the Option Compatibility Matrix and, I hate to say it, it would appear that the X1 Carbon 5th, Yoga 370 and Yoga 380 are not devices which the USB-C Dock Gen 2 supports; I checked against 40AS0090US docking.

 

The Matrix can be downloaded from here:
https://support.lenovo.com/us/en/solutions/accs-guide

 

Andy

 

English Community Leader
Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points 
Did you find a post helpfull? You can thank the member by clicking on the star below their post awarding them Kudos
 

Please don't ask me questions by Personal Message; questions belong in the forums.
 

  Communities:   English    Deutsche    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Język Polski    Moto English

jnk_lenovo
Paper Tape
Posts: 4
Registered: ‎08-27-2009
Location: US
Views: 1,621
Message 5 of 6

Re: USB-C (GEN 2) Dock - PXE not working

After fully updating Firmwares and BIOS and confirming proper BIOS settings, my results agree with the Compatibility Matrix. The only device I was able to PXE boot was the 6th Gen Carbon.

Highlighted
WasifR
Paper Tape
Posts: 6
Registered: ‎05-10-2019
Location: CA
Views: 439
Message 6 of 6

Re: USB-C (GEN 2) Dock - PXE not working

i am having similar issues. how do I update the driver and firmware on these Gen 2 docking stations?

Check out current deals!


Shop current deals

Top Kudoed Authors