English Community

External Displays, Options and AccessoriesDisplays, Options and Accessories
All Forum Topics
Options

11 Posts

11-24-2015

US

20 Signins

217 Page Views

  • Posts: 11
  • Registered: ‎11-24-2015
  • Location: US
  • Views: 217
  • Message 1 of 3

USB-C to monitor stopped working after windows update

2018-03-16, 2:40 AM

The USB-C port on my Yoga 900 suddenly stopped working while I was working on a second monitor (monitor A) in my office after windows 10 forced update KB4088776. When I reverted that update, monitor A did not work anymore, I ensured that all drivers & BIOS were updated.

When I got home and connected anoter previously known monitor (monitor B) that screen worked fine for an hour - but then the same thing happened again: windows forced the same update and the USB-C stopped working with Monitor B as well. The problem is not related to the cable (using several different ones, vga, hdmi, displayport)

 

Device manager is showing a "unknown usb device (device descriptor request failed)" but this was also showing when Monitor B was working.

 

All my drivers and bios are up to date (using lenovo system update)

 

Is there are workaround to this problem, I have now lost several hours trying to figure out what is going on. Please help.

 

I have spent several hours troubleshooting, reinstalling the USB to no avail.

 

Reply
Options

2 Posts

03-19-2018

DK

2 Signins

31 Page Views

  • Posts: 2
  • Registered: ‎03-19-2018
  • Location: DK
  • Views: 31
  • Message 2 of 3

Re: USB-C to monitor stopped working after windows update

2018-03-19, 8:16 AM
I have the same problem, T470p HDMI port stopped working after update.
Reply
Options

2 Posts

03-19-2018

DK

2 Signins

31 Page Views

  • Posts: 2
  • Registered: ‎03-19-2018
  • Location: DK
  • Views: 31
  • Message 3 of 3

Re: USB-C to monitor stopped working after windows update

2018-03-19, 10:20 AM

I had a similar problem after the update with my HDMI port no longer working, even after updating the drivers etc.

In the BIOS display settings I changed the boot screen from being the inbuilt LCD to the HDMI setting and after rebooting the port works again.

 

Although not the exact same problem as with the USB-C connection but maybe you can try something similar in your BIOS.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete