Showing results for 
Search instead for 
Do you mean 
Blue Screen Again
Posts: 1
Registered: ‎05-21-2011
Location: USA
Message 1 of 3 (1,442 Views)

USB travel keyboard vs non-IBM PC

For some time I've been using a USB keyboard with ultranav - the kind with the keypad, which has been discontinued - on my non-IBM PC running XP.  That keyboard worked fine, and I could modify all the attributes of the trackpoint and pad.  For me, it's especially important to be able to reduce the force necessary to use the trackpoint or I'll hurt my hands.  Over time, though, it reached the end of its lifespan.


I bought a USB travel keyboard with ultranav.  Essentially the same thing, but without the keypad.  I've tried a variety of driver installs, including generic Synaptics drivers, and I can't modify the trackpoint's beavior.  Both the pad and the trackpoint work, controlling the mouse, but there is no way to reduce the force necessary.  At one point, I got the message that the trackpoint was disabled and I needed to re-enable it in the BIOS... but this isn't an IBM machine.  It has an ASUS motherboard, and the bios has nothing relevant as far as I can tell.


A potential clue:

Watching the device manager, I've plugged in my old keyboard and the new travel keyboard.  The old keyboard is recognized as a "HID Keyboard Device", "Synaptics Composite USB TouchPad", and "Synaptics Composite USB TouchStyk".  The _new_ keyboard is recognized as a "HID Keyboard Device" and "HID-compliant mouse."  I would have expected two mice, actually, one for the trackpoint and one for the touchpad.


I have tried various installs and drivers, including drivers from Lenovo and generic ones from Synaptics, without luck.  It's still an HID-compliant mouse which won't let me change the amount of force necessary.


Any ideas?


Paper Tape
Posts: 4
Registered: ‎05-08-2013
Location: United States
Message 2 of 3 (954 Views)

Re: USB travel keyboard vs non-IBM PC

I feel your pain ringrose.


My beloved IBM T42, circa 2005, has been retired from work duties and soldiers on in limited duty at home. I have recently attempted to re-create the well-designed keyboard, particularly the Synaptics touchpad and the TrackPoint, for my office PC, which is a clone (but with 'name-brand' internals, an Intel motherboard and processor, Kingston RAM, OCZ SSD) running 64-bit Windows 7 Professional, SP1.


So, for the princely sum of $35 I purchased a new keyboard, an IBM Part No. 89P8500 and IBM Model No. SK-8840. It's labeled IBM, not Lenovo. The keyboard's cord ends in two PS/2 plugs, one for the keyboard and one for the mouse, the latter I believe refers to the integrated Synaptics touchpad, and the integrated Trackpoint. My office PC has no PS/2 inputs, so I purchased a Ziotek PS/2 Keyboard and Mouse to USB Adapter (ZT1040444) to make the connection between the keyboard and the PC.


The keyboard does achieve basic functionality by simply plugging it into the PC through the Ziotek adapter. But the Synaptics touchpad and the TrackPoint are capable of considerably more functionality. I know this because on my T42 the touchpad and TrackPoint were controlled by UltraNav software, which created a tab in the Mouse Properties in Control Panel. There, many adjustments and customizations were possible.


But having spent more hours than I will admit to (yes, it's in double digits), I am still unable to achieve UltraNav levels of functionality. Worse, and even though the keyboard functions, if I open Control Panel, Mouse Properties an error message appears saying:


"Unable to connect to the Synaptics Pointing Device Driver.


If you have installed another PS/2 Pointing Device Driver please uninstall the Synaptics driver by clicking on the Yes button. You then need to reinstall your pointing device driver for your external device again.


Do you want to uninstall the Synaptics driver now?"


I select "No" and the Mouse Properties dialogue box opens, sans any indication of UltraNav or any functionality beyond the basic functions provided in Windows.


It finally dawned on me that the UltraNav software is IBM's proprietary version of Synaptics' generic touchpad / trackpoint driver. And it just doesn't want to and/or isn't going to work on my clone PC. I have literally tried dozens of USB and PS/2 drivers from Lenovo's website. The generic Synaptics driver from Synaptics' website imparts none of the UltraNav functionality, as best as I can tell.


My guess is that IBM probably didn't plan on selling enough of the now-priced-at-$35 keyboard (89P8500 / SK-8840) to merit going to the trouble and expense of preparing an UltraNav driver for non-IBM computers to run the thing. But, is there a version of UltraNav that will run on non-IBM/Lenovo PCs? I haven't found it.


The keyboard uses PS/2 and the Ziotek adapter, at least in theory, maps the PS/2 interface over to work with the USB interface. But is Windows 7 Professional 64-bit treating the Ziotek adapter-connected keyboard as a PS/2 device (which it is), or does the Ziotek adapter cause windows to treat the keyboard as a USB device? Thus, is the adapter's mapping over process so complete that the PS/2 device is now treated as a USB device? I have inquired with Ziotek and I am awaiting a response, which may never come.


I posted here in desperation. Please help, if you are able.


Thank you,



Punch Card
Posts: 30
Registered: ‎02-03-2008
Location: RTP, NC
Message 3 of 3 (924 Views)

Re: USB travel keyboard vs non-IBM PC

[ Edited ]

I feel your pain for the past 5+ years.


The Synaptics drivers and software does not play nice w/ the IBM or Lenovo keyboards. I've gone down that route a couple of times over the last 8+ years with various models - NEVER with success.   The Synaptics does not even come close to showing all the IBM/Lenovo options - just like you said.  Of course, the one that chaps for me is scrolling directions via 3rd mouse button (center) and that invariably breaks or is not there if I touch / update the drivers / software.  Even on the IBM USB  UltraNav Travel Keyboard (older models, which is no longer sold) with the current drivers it breaks or refuses to set the "extra" functions on the USB keyboard while working fine on the laptop keyboard.


Recently, I made the mistake of updating my TrackPoint drivers with The Thinkvantage Utilities (I usually do not)  and it screwed up my working perfectly USB + onboard TrackPoints.  So now I'm trying to find the older versions I had on the machine to reinstall.  What I've found is the current drivers and utilities which also get installed, always hoze up any of the "extra features" such as trackpoint scrolling or the touch/tap functions.


However, I have usually been able to set the trackpoint sensitivity to very light and have that work properly.    I suggest perhaps full backup, uninstalling, reinstalling.  I've had various levels of success with the Windows restore points, so do not rely too heavily on them...


My guess is that the software is on supporting certain vIDs and does not play nice with anything except what's supported.   We see this with other Lenovo "parts...", especially in the Thinkpads..


You may consider going back to some earlier driver / utility versions, way back, to see if any of those work for your setup.  I doubt they will ever work on anything other than IBM/Lenovo.. YMMV.



Top kudoed Authors