cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
HomerS124
What's DOS?
Posts: 1
Registered: ‎06-22-2019
Location: DE
Views: 558
Message 1 of 3

Ultradock 40AJ only allows 100Mbps

Hi all,

 

I have a T480 connected via Ultradock.

However, the ethernet port will only give me 100Mbps, claiming that the other side does not support a faster speed.

 

I have

- updated all drivers and have updated the ultradock firmware to 3.1

- have tested various cables (all of which are CAT5e and give perfect Gigabit connectivity directly to the T480 ethernet port)

- have tested with another Gbit switch

   Neither the TP-Link nor Netgear Gbit switch work on Gbit through the Ultradock both give me only 100Mbps

- Any test, any cable, any switch give me perfect Gbit connection when connected through the T480 ethernet port

 

Is there anything I may have missed? I am quite convinced that my Ultradock ethernet is the only outstanding part that I have not been able to change.

Any ideas?

 

Thanks

 

Peter

 

Support Specialist
Posts: 1,851
Registered: ‎08-02-2018
Location: US
Views: 467
Message 2 of 3

Re: Ultradock 40AJ only allows 100Mbps

Hi HomerS124! Welcome to our forums community. Try checking the advanced settings on the network. Make sure it is under Speed and Duplex and check the value on the right side. Please refer to the photo below. We also suggest you to try cat 6 cable.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

mplichta
Paper Tape
Posts: 2
Registered: ‎09-19-2018
Location: US
Views: 39
Message 3 of 3

Re: Ultradock 40AJ only allows 100Mbps

I have a 40AC dock but same problem. The issue is that the Dock driver is not installed.  The default driver by microsoft doesn't auto negotiate right.  

 

(not working) Thinkpad TBT 3 Dock Ethernet    Microsoft            10.5.920.2015

(working) Thinkpad TBT 3 Dock Ethernet   Realtek 10.33.419.2019   <- this fixed it

 

I downloaded the ThinkPad Thunderbolt 3 Driver for Windows 10 from https://pcsupport.lenovo.com/us/en/downloads/ds501904

 

 Note that this issue only started after updating the firmware on the docking station.  

 

1Gbps working (but dock doesn’t work before logon with a Carbon Gen 7)

Dock Name = ThinkPad TBT3 AR Dock

Tbt3_Pd FW version = C15_13104S2

MCU FW version = E123

DpHub FW version = 3.12.000

Audio FW version = 2800

 

100Mbps (but dock works before logon with a Carbon Gen 7) - now working with dock driver.

Tbt3_Pd FW version = C33_13801S5 

MCU FW version = E123

DpHub FW version = 3.13.002   

Audio FW version = 0087

 

When troubleshooting Thunderbolt dock issues, check versions of all of these and update in order.  

1.  BIOS (some TB controller drivers need specific BIOS updates)

2.  Onboard TB controller card driver version

3.  Firmware of TB Controller card

4.  Dock driver (single package include ethernet and audio drivers)

5.  Dock firmware

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors