Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Software and Operating SystemEnterprise Client Management
All Forum Topics
Options

21 Posts

04-04-2016

United States of America

25 Signins

179 Page Views

  • Posts: 21
  • Registered: ‎04-04-2016
  • Location: United States of America
  • Views: 179
  • Message 1 of 11

Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 18:40 PM

I am having an issue where I can PXEBOOT my M900 but once I get to the WinPE screen (Microsoft Solutions), the keyboard and mouse just stops working.  We have MDT with WDS which is how we build our machines.  Windows 7 x64.   All the USB ports on this machine are USB 3.0.  I've tried using every port possible and no luck.   I also created a selection profile in MDT with the Net,chipset and USB drivers and I than selected that profile in my WinPE but no luck.   I've looked all over the internet and nothing.   

 

If anyone has had this issue and knows how to fix it please reach out to me.  My job depends on it.  

Reply
Answer
Options

205 Posts

06-02-2015

United States of America

364 Signins

2566 Page Views

  • Posts: 205
  • Registered: ‎06-02-2015
  • Location: United States of America
  • Views: 2566

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 21:32 PM

If you are already running MDT 2012 U1, you only need to install a later Windows ADK. MDT 2012 U1 supports Windows ADK 8 (not ADK 8.1). You would have to uninstall your current Windows WAIK and then install the ADK 8. This gets you to WinPE 4 - which we did test as well.

There are guides available from 3rd party sites that can assist you with the upgrade.

Once you have completed the upgrade you will need to update your deployment share and choose the "completely regenerate boot images" option.

Reply

Replies(10)
Options

205 Posts

06-02-2015

United States of America

364 Signins

2566 Page Views

  • Posts: 205
  • Registered: ‎06-02-2015
  • Location: United States of America
  • Views: 2566
  • Message 2 of 11

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 18:58 PM
One other important thing to do is to flash the BIOS to the latest. There was an update released 3/10/2016 and can be found here;

http://support.lenovo.com/us/en/products/Desktops-and-all-in-ones/ThinkCentre-M-Series-desktops/ThinkCentre-M900/downloads/DS105487

You will need either the CD ISO or the DOS version. There are readme files that will provide you with instructions.

Lastly, what version of MDT; What WinPE version?
Reply
Options

21 Posts

04-04-2016

United States of America

25 Signins

179 Page Views

  • Posts: 21
  • Registered: ‎04-04-2016
  • Location: United States of America
  • Views: 179
  • Message 3 of 11

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 19:23 PM
WinPE 3.1 x64 That is the equivalent to Win7SP1x64 I believe. Also these machines don't have a CD-ROM drive, so I am trying to figure out how to update the darn thing lol
Reply
Options

205 Posts

06-02-2015

United States of America

364 Signins

2566 Page Views

  • Posts: 205
  • Registered: ‎06-02-2015
  • Location: United States of America
  • Views: 2566
  • Message 4 of 11

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 19:30 PM
You can take a look at the readme file and use a tool like "Rufus" for creating a bootable USB drive with the CD ISO.
Reply
Options

21 Posts

04-04-2016

United States of America

25 Signins

179 Page Views

  • Posts: 21
  • Registered: ‎04-04-2016
  • Location: United States of America
  • Views: 179
  • Message 5 of 11

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 20:00 PM
I updated the Bios to the latest version on the link, tried to PXEboot again (when I F12 it works great) but than when I get to the Microsoft Solution WinPE page and it presents me with my task sequence, Mouse and Keyboard are unresponsive.
Reply
Options

205 Posts

06-02-2015

United States of America

364 Signins

2566 Page Views

  • Posts: 205
  • Registered: ‎06-02-2015
  • Location: United States of America
  • Views: 2566
  • Message 6 of 11

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 20:15 PM
Are you using MDT 2012 or later? If so, can you try creating a Boot wim that uses a higher version of WinPE?

4.0 Windows 8 6.2.9200.x Windows ADK (Windows Kits 8.0).
5.0 Windows 8.1 6.3.9300.x Windows ADK (Windows Kits 8.1).
5.1 Windows 8.1 Update 1 6.3.9600.x Windows ADK (Windows Kits 8.1 Update).

If the above is not an option, then try the steps below;

Do you have more than 1 unit? If so, it is time for process of elimination. Try deploying to a different unit to determine if it is hardware related.

If you do not have another unit and you are
Reply
Options

21 Posts

04-04-2016

United States of America

25 Signins

179 Page Views

  • Posts: 21
  • Registered: ‎04-04-2016
  • Location: United States of America
  • Views: 179
  • Message 7 of 11

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 20:26 PM
We have MDT 2012 Update 1 version 6.1.2373.0, we have several units from Lenovo such as M92, M93, HP Elite desk G1 which build out fine and the T460's as well.

Just to add I also had the same issue with an HP Elite desk G2 SFF machine. The Band-Aid solution for that was to use the onboard PS2 connections (luckily we still have those keyboards)
Reply
Options

205 Posts

06-02-2015

United States of America

364 Signins

2566 Page Views

  • Posts: 205
  • Registered: ‎06-02-2015
  • Location: United States of America
  • Views: 2566
  • Message 8 of 11

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 20:56 PM
Hi jsnyc, We have verified that keyboard and mouse support does work in WinPE 5. WinPE 3.1 x86 and x64 do not work with the m900.

Is there any reason that you are not able to deploy with a later version of WinPE from either Windows ADK 8 or Windows ADK 8.1?
Reply
Options

21 Posts

04-04-2016

United States of America

25 Signins

179 Page Views

  • Posts: 21
  • Registered: ‎04-04-2016
  • Location: United States of America
  • Views: 179
  • Message 9 of 11

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 21:14 PM
AHHHHHHH, well that answers a lot of questions lol. I am a bit of a intermediate when it comes to this so please bare with me. That would require me upgrading my MDT correct?
Reply
Answer
Options

205 Posts

06-02-2015

United States of America

364 Signins

2566 Page Views

  • Posts: 205
  • Registered: ‎06-02-2015
  • Location: United States of America
  • Views: 2566
  • Message 10 of 11

Re: Lenovo M900 Keyboard and Mouse not working in WinPE

2016-04-04, 21:32 PM

If you are already running MDT 2012 U1, you only need to install a later Windows ADK. MDT 2012 U1 supports Windows ADK 8 (not ADK 8.1). You would have to uninstall your current Windows WAIK and then install the ADK 8. This gets you to WinPE 4 - which we did test as well.

There are guides available from 3rd party sites that can assist you with the upgrade.

Once you have completed the upgrade you will need to update your deployment share and choose the "completely regenerate boot images" option.

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms