cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
skyn3t_uk
Paper Tape
Posts: 2
Registered: ‎05-17-2017
Location: GB
Views: 9,408
Message 1 of 8

MDT 2012 Drivers t460s / T470s - NVMe0 SSD

Hello,

 

We bought some Lenovo T470s (type 20JS, 20JT) , and once we imported the SCCM Drivers to our MDT 2012 System (WinPE 3.0) is not detecting the new SSD that came on the T470s.

The SSD look the same we have on the the T460s (the new generation) and with this model we just imported the storage drivers and everything worked fine.

 

With the t470s the hdd is not detected. Are we missing any more driver?

 

Thanks Claudio

moseni
Punch Card
Posts: 8
Registered: ‎05-31-2017
Location: GB
Views: 9,232
Message 2 of 8

Re: MDT 2012 Drivers t460s / T470s - NVMe0 SSD

Hi ,

I am having the same issue. Where can we get the Nvme driver for Lenovo 20JT
skyn3t_uk
Paper Tape
Posts: 2
Registered: ‎05-17-2017
Location: GB
Views: 9,230
Message 3 of 8

Re: MDT 2012 Drivers t460s / T470s - NVMe0 SSD

Hello,

 

I got the solution for that.

 

You need to upgrate your MDT to 2013, and then on the packages use the hotfixed:

 

Windows6.1-KB2990941-v3-x64.msu

Windows6.1-KB3087873-v2-x64.msu

 

to avoid BSOD after installing the Operating System.

 

This was the last solution I found, since WINPE 3.0 can't load the drivers for this new SSD.

moseni
Punch Card
Posts: 8
Registered: ‎05-31-2017
Location: GB
Views: 9,225
Message 4 of 8

Re: MDT 2012 Drivers t460s / T470s - NVMe0 SSD

Hi ,

Does the microsoft update apply to all WinPe i.e newer version winpe10 ??
Lenovo Employee tlawson
Lenovo Employee
Posts: 853
Registered: ‎03-03-2016
Location: US
Views: 9,212
Message 5 of 8

Re: MDT 2012 Drivers t460s / T470s - NVMe0 SSD

Moseni,

 

No, you do not need to do anything for WinPE 10. Windows 7 OS needed the patch. I don't think you can patch WinPE 3.1 to do this. Best option is to upgrade to latest MDT 8443 and WinPE 10. That should resolve your issues nicely. There is a good blog post at http://thinkdeploy.blogspot.com/2016/06/deploying-windows-7-to-new-nvme-drives.html?m=1 regarding what to do. 

 

HTH,

 

Tlawson

moseni
Punch Card
Posts: 8
Registered: ‎05-31-2017
Location: GB
Views: 9,147
Message 6 of 8

Re: MDT 2012 Drivers t460s / T470s - NVMe0 SSD

Hotfix fix the issue.

 

Thanks

Mo

moseni
Punch Card
Posts: 8
Registered: ‎05-31-2017
Location: GB
Views: 8,495
Message 7 of 8

Re: MDT 2012 Drivers t460s / T470s - NVMe0 SSD

Hi,

 

We upgraded our Win 7 Wim file and  to SCCM 1702 and all of  sudden both x86 and x64 deployment T470s starting failing  during OS deployment.

 

After spending few days, we notice x86 win7 image  started deploying when we disable both microsoft recommended  hotfixes.  The x64 bit is still failing though.

 

Do you have an recommendation. Please note, I have updated the BIOS to 1.13 with date stamp 26-06-2017.

 

Regards

Mo

 

 

 

copycat10
Blue Screen Again
Posts: 4
Registered: ‎12-15-2016
Location: CH
Views: 1,774
Message 8 of 8

Re: MDT 2012 Drivers t460s / T470s - NVMe0 SSD

I had to integrate KB2990941 and KB3087873 to the x64 boot image (and the intel rapid storage driver for the T470s) and now its formating the drive!

 

Thank you very much for the help.

Check out current deals!


Shop current deals

Top Kudoed Authors