cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
stekkert
Fanfold Paper
Posts: 14
Registered: ‎06-16-2016
Location: US
Views: 1,060
Message 1 of 7

P52 without Sleep Option in Windows 10

We have around 12 P52 installed on our company using windows 10 version 1607. We notice that ll machines didn't have the Sleep option when clicking the power button. The sleep mode is enabled in our organization via Group Policy and we alreadu checked the setting is configured for the P52s. We also have Yoga 260, X1 Yoga, Yoga 370, M900 and M910q machines, all with sleep mode working fine. 

 

gpo.JPG

 

This policy is located at Computer\Administrative Template\System\Power management\Sleep Settings.

 

did anyone have any similar issues with the P52 ?

 

Highlighted
Lenovo Staff
Lenovo Staff
Posts: 5,755
Registered: ‎10-29-2009
Location: NC
Views: 1,017
Message 2 of 7

Re: P52 without Sleep Option in Windows 10

The problem is that  Win10 1607 doesn't support the newer processor in P52.  You need to upgrade to a newer version of Win10.

 

See here:  https://docs.microsoft.com/en-us/windows-hardware/design/minimum/windows-processor-requirements

 

stekkert
Fanfold Paper
Posts: 14
Registered: ‎06-16-2016
Location: US
Views: 1,001
Message 3 of 7

Re: P52 without Sleep Option in Windows 10

Thanks for the quick reply. Our P52s have the Xeon E-2176M, launched in Q2 2018. it is Coffee lake (8th-9th generation). Looking at the windows pre-requisite I see versions 1607 and 1703 up to the 7th generation. We are in the process to roll out 1803. I will give it a try and let you know.

 

Besides the sleep mode, we were having issues with some keyboard keys, the docking station and freezes that we could not explain. 

 

Lenovo Staff
Lenovo Staff
Posts: 5,755
Registered: ‎10-29-2009
Location: NC
Views: 985
Message 4 of 7

Re: P52 without Sleep Option in Windows 10

I would strongly suggest getting 1803 or later on the P52's before you do any more troubleshooting for any problem.  If you're using the Thunderbolt dock, make sure the BIOS setting in Config -> Thunderbolt -> Thunderbolt BIOS Assist Mode is set to Disabled (after you install 1803 or later).

stekkert
Fanfold Paper
Posts: 14
Registered: ‎06-16-2016
Location: US
Views: 961
Message 5 of 7

Re: P52 without Sleep Option in Windows 10

Did the upgrade of one of the impacted machines to 1803 and the sleep option and brightness buton issues are gone. I made sure the BIOS was configured as you suggested. We will upgrade one or two more computers in productiona and will monitor. 

 

Thanks a lot for your help.

Lenovo Employee rbkirk
Lenovo Employee
Posts: 797
Registered: ‎02-20-2009
Location: US
Views: 917
Message 6 of 7

Re: P52 without Sleep Option in Windows 10

I would strongly advise AGAINST upgrading "in place" from an unsupported operating system to a supported version. Start with the supported version and a clean install. This does mean a clean install of at least 1803, but you will be better served installing 1809...for the Enterprise versions of 1809 and future Fall releases of Windows 10, Microsoft has said it will offer 30 months of support vs the usual 18 months.

 

Do a test with a clean install of a current, supported OS so as not to carry forward the problems of the unsupported OS.

stekkert
Fanfold Paper
Posts: 14
Registered: ‎06-16-2016
Location: US
Views: 888
Message 7 of 7

Re: P52 without Sleep Option in Windows 10

Thanks for the heads up. I was really planning to do "in-place" upgrades from 1607 to 1803 to reduce the downtime for the users (critical finance users).

 

However, I also don't want to carry forward any issues from the unsuported version. 1809 is not an option right now as we are rolling out 1803 and then we will target 1909 as next version (because of the 30 months extended support). We are still struggling to have the upgrades done fast and with less impact. We didn't have app compat problems, but the new security features were problematic to us. 

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors