cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dooty22
Punch Card
Posts: 21
Registered: ‎07-06-2014
Location: AU
Views: 3,576
Message 31 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32


@willisj318 wrote:

Any chance we can get the link working again or have them posted someplace to download?


Yes, how do we obtain these 32bit WinPE drivers ??

 

I cant use x64 boot image because Im deploying a 32bit OS, its not supported and it fails. 

 

 

 

 

Highlighted
Lenovo Staff
Lenovo Staff
Posts: 818
Registered: ‎01-16-2010
Location: US
Views: 3,571
Message 32 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32

As noted in another thread:

 

http://download.lenovo.com/luc_test/Intel-I218_WinPE5_32.zip

 

Sorry about that, the name was changed to something a little more recognizable.

tmeyn
Paper Tape
Posts: 5
Registered: ‎06-05-2013
Views: 3,547
Message 33 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32

This link doesn't work anymore. Is there another way to get this?
Lenovo Staff
Lenovo Staff
Posts: 818
Registered: ‎01-16-2010
Location: US
Views: 3,542
Message 34 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32

http://download.lenovo.com/luc_test/Intel-I218_WinPE5_32.zip

 

This link is working for me.  Is it not working for you?

tmeyn
Paper Tape
Posts: 5
Registered: ‎06-05-2013
Views: 3,534
Message 35 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32

Sorry, I had been looking at the orginal link.

 

I still have had no luck getting network connectivity in the pe. I've tried 32 bit & 64 bit pe with many different drivers, nothing seems to work

Lenovo Staff
Lenovo Staff
Posts: 818
Registered: ‎01-16-2010
Location: US
Views: 3,504
Message 36 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32

Have you tried a clean WinPE image with no other drivers in it, then add the T450s drivers?  If it doesn't PXE boot with that then there is something else wrong in your environment.  Do you have more than one machine to test?  Does your test machine have the latest BIOS installed and are the BIOS settings configured properly for deploying Win7?

JimJ
What's DOS?
Posts: 1
Registered: ‎04-24-2015
Location: United States
Views: 3,438
Message 37 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32

This worked for me... Thanks!
twintomwrx
Fanfold Paper
Posts: 9
Registered: ‎04-28-2015
Location: Minnesota
Views: 3,418
Message 38 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32

 

I added the x32 5.1 PE Driver to my X32 Boot image but I am still getting this in my error log before I am able to even select a task sequence.  I highlighted the Errors that I found in Red.

 

 

 

Boot Image x86 Version 6.3.9600.16384

 

System Center 2012 R2

Version 5.0.7958.1000

 

 

LOGGING: Finalize process ID set to 724 TSBootShell 4/24/2015 1:47:31 PM 728 (0x02D8)
==============================[ TSBootShell.exe ]============================== TSBootShell 4/24/2015 1:47:31 PM 728 (0x02D8)
Succeeded loading resource DLL 'X:\sms\bin\i386\1033\TSRES.DLL' TSBootShell 4/24/2015 1:47:31 PM 728 (0x02D8)
Debug shell is enabled TSBootShell 4/24/2015 1:47:31 PM 728 (0x02D8)
Waiting for PNP initialization... TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
RAM Disk Boot Path: NET(0)\SMSIMAGES\DRC00002\BOOT.DRC00002.WIM TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
Booted from network (PXE) TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
Network(PXE) path: X:\sms\data\ TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
Found config path X:\sms\data\ TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
This is not a fixed non usb disk TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
Booting from removable media, not restoring bootloaders on hard drive TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
X:\sms\data\WinPE does not exist. TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
X:\_SmsTsWinPE\WinPE does not exist. TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
Executing command line: wpeinit.exe -winpe TSBootShell 4/24/2015 1:47:31 PM 732 (0x02DC)
The command completed successfully. TSBootShell 4/24/2015 1:47:35 PM 732 (0x02DC)
Starting DNS client service. TSBootShell 4/24/2015 1:47:35 PM 732 (0x02DC)
Executing command line: X:\sms\bin\i386\TsmBootstrap.exe /env:WinPE /configpath:X:\sms\data\ TSBootShell 4/24/2015 1:47:35 PM 732 (0x02DC)
The command completed successfully. TSBootShell 4/24/2015 1:47:35 PM 732 (0x02DC)
==============================[ TSMBootStrap.exe ]============================== TSMBootstrap 4/24/2015 1:47:35 PM 1048 (0x0418)
Command line: X:\sms\bin\i386\TsmBootstrap.exe /env:WinPE /configpath:X:\sms\data\ TSMBootstrap 4/24/2015 1:47:35 PM 1048 (0x0418)
Succeeded loading resource DLL 'X:\sms\bin\i386\1033\TSRES.DLL' TSMBootstrap 4/24/2015 1:47:35 PM 1048 (0x0418)
Succeeded loading resource DLL 'X:\sms\bin\i386\TSRESNLC.DLL' TSMBootstrap 4/24/2015 1:47:35 PM 1048 (0x0418)
Current OS version is 6.2.9200.0 TSMBootstrap 4/24/2015 1:47:35 PM 1048 (0x0418)
Adding SMS bin folder "X:\sms\bin\i386" to the system environment PATH TSMBootstrap 4/24/2015 1:47:35 PM 1048 (0x0418)
PXE Boot with Root = X:\ TSMBootstrap 4/24/2015 1:47:35 PM 1048 (0x0418)
Executing from PXE in WinPE TSMBootstrap 4/24/2015 1:47:35 PM 1048 (0x0418)
Loading TsPxe.dll from X:\sms\bin\i386\TsPxe.dll TSMBootstrap 4/24/2015 1:47:35 PM 1048 (0x0418)
TsPxe.dll loaded TSPxe 4/24/2015 1:47:35 PM 1048 (0x0418)
Device has PXE booted TSPxe 4/24/2015 1:47:35 PM 1048 (0x0418)
Variable Path: \SMSTemp\2015.04.24.11.48.52.0085.{617EEFDA-3DAB-43B2-8B70-E617A629A6DE}.boot.var TSPxe 4/24/2015 1:47:35 PM 1048 (0x0418)
Succesfully added firewall rule for Tftp TSPxe 4/24/2015 1:47:35 PM 1048 (0x0418)
Executing: X:\sms\bin\i386\smstftp.exe -i 10.5.3.132 get \SMSTemp\2015.04.24.11.48.52.0085.{617EEFDA-3DAB-43B2-8B70-E617A629A6DE}.boot.var X:\sms\data\variables.dat TSPxe 4/24/2015 1:47:35 PM 1048 (0x0418)
Command line for extension .exe is "%1" %* TSPxe 4/24/2015 1:47:36 PM 1048 (0x0418)
Set command line: "X:\sms\bin\i386\smstftp.exe" -i 10.5.3.132 get \SMSTemp\2015.04.24.11.48.52.0085.{617EEFDA-3DAB-43B2-8B70-E617A629A6DE}.boot.var X:\sms\data\variables.dat TSPxe 4/24/2015 1:47:36 PM 1048 (0x0418)
Executing command line: "X:\sms\bin\i386\smstftp.exe" -i 10.5.3.132 get \SMSTemp\2015.04.24.11.48.52.0085.{617EEFDA-3DAB-43B2-8B70-E617A629A6DE}.boot.var X:\sms\data\variables.dat TSPxe 4/24/2015 1:47:36 PM 1048 (0x0418)
Executing command line: X:\WINDOWS\system32\cmd.exe /k TSBootShell 4/24/2015 1:47:36 PM 728 (0x02D8)
The command completed successfully. TSBootShell 4/24/2015 1:47:36 PM 728 (0x02D8)
Successfully launched command shell. TSBootShell 4/24/2015 1:47:36 PM 728 (0x02D8)
Process completed with exit code 1 TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
Succesfully removed firewall rule for Tftp TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
uExitCode == 0, HRESULT=80004005 (e:\nts_sccm_release\sms\server\pxe\tspxe\tspxe.cpp,185) TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
Failed to download pxe variable file. Code(0x00000001) TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
PxeGetPxeData failed with 0x80004005 TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
HRESULT_FROM_WIN32(dwError), HRESULT=80004005 (e:\qfe\nts\sms\client\tasksequence\tsmbootstrap\tsmbootstraputil.cpp,1459) TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
TSMBootstrapUtil:Smiley TonguexeGetPxeData(&bPxeBooted, sVariablesFile, sPxePasswd), HRESULT=80004005 (e:\qfe\nts\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,2665) TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
oTSMediaWizardControl.Run( sMediaRoot, true, sTSLaunchMode ), HRESULT=80004005 (e:\qfe\nts\sms\client\tasksequence\tsmbootstrap\tsmbootstrap.cpp,1078) TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
Execute( eExecutionEnv, sConfigPath, sTSXMLFile, uBootCount, &uExitCode ), HRESULT=80004005 (e:\qfe\nts\sms\client\tasksequence\tsmbootstrap\tsmbootstrap.cpp,1226) TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
Exiting with return code 0x80004005 TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
hMap != 0, HRESULT=80070002 (e:\qfe\nts\sms\framework\tscore\environmentscope.cpp,493) TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
m_pGlobalScope->open(), HRESULT=80070002 (e:\qfe\nts\sms\framework\tscore\environmentlib.cpp,335) TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
this->open(), HRESULT=80070002 (e:\qfe\nts\sms\framework\tscore\environmentlib.cpp,553) TSPxe 4/24/2015 1:48:23 PM 1048 (0x0418)
Execution complete. TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
hMap != 0, HRESULT=80070002 (e:\qfe\nts\sms\framework\tscore\environmentscope.cpp,493) TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
m_pGlobalScope->open(), HRESULT=80070002 (e:\qfe\nts\sms\framework\tscore\environmentlib.cpp,335) TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
this->open(), HRESULT=80070002 (e:\qfe\nts\sms\framework\tscore\environmentlib.cpp,553) TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
::RegOpenKeyExW (HKEY_LOCAL_MACHINE, sKey.c_str(), 0, KEY_READ, &hSubKey), HRESULT=80070002 (e:\qfe\nts\sms\framework\tscore\utils.cpp,809) TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
RegOpenKeyExW is unsuccessful for Software\Microsoft\SMS\Task Sequence TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
GetTsRegValue() is unsuccessful. 0x80070002. TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
End program:  TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
Finalizing logging from process 724 TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
Finalizing logs to root of first available drive TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)
LOGGING: Setting log directory to "D:\SMSTSLog". TSBootShell 4/24/2015 1:48:23 PM 732 (0x02DC)

Lenovo Staff
Lenovo Staff
Posts: 818
Registered: ‎01-16-2010
Location: US
Views: 3,395
Message 39 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32

As soon as you get booted into PE hit F8 to get a command prompt (hopefully you have that enabled in your boot image).  Do an IPCONFIG and verify you have network connection.

 

Also, find the SMSPXE.log file on your server (Program Files\SMS_CCM\Logs\SMSPXE.log) and see if it has more details.

twintomwrx
Fanfold Paper
Posts: 9
Registered: ‎04-28-2015
Location: Minnesota
Views: 3,392
Message 40 of 88

Re: T450S WinPE x32 Network Drivers for Win7x32

HI Parkerjnc

Thanks for commenting back on this. 

 

I am not getting an IP address when running the ipconfig command

and the Smspxe log below isnt really helpful either from what I can tell.

 

I mean it seems to be a driver issue for sure, I am trying to image a T450 20bv-0005us

I have never had this much trouble in the past with lenovos like this. 

 

I have also tried in x64 with injecting the propter x64 drivers into that boot image and the same result.

 

 

Client lookup reply: <ClientIDReply><Identification Unknown="0" ItemKey="0" ServerName=""><Machine><ClientID/><NetbiosName/></Machine></Identification></ClientIDReply>
SMSPXE 4/28/2015 2:50:03 PM 4192 (0x1060)
68:F7:28:79:43:68, 50E12001-53DD-11CB-A34F-A201BD420102: device is not in the database. SMSPXE 4/28/2015 2:50:03 PM 4192 (0x1060)
Getting boot action for unknown machine: item key: 2046820353 SMSPXE 4/28/2015 2:50:03 PM 4192 (0x1060)
Client boot action reply: <ClientIDReply><Identification Unknown="0" ItemKey="2046820353" ServerName=""><Machine><ClientID>268bd42b-d274-4e41-8d9a-5a08136d03e3</ClientID><NetbiosName/></Machine></Identification><PXEBootAction LastPXEAdvertisementID="" LastPXEAdvertisementTime="" OfferID="DRC2023E" OfferIDTime="4/28/2015 8:51:00 AM" PkgID="DRC0015E" PackageVersion="" PackagePath="http://servername/SMS_DP_SMSPKG$/DRC00002" BootImageID="DRC00002" Mandatory="0"/></ClientIDReply>
SMSPXE 4/28/2015 2:50:03 PM 4192 (0x1060)
68:F7:28:79:43:68, 50E12001-53DD-11CB-A34F-A201BD420102: found optional advertisement DRC2023E SMSPXE 4/28/2015 2:50:03 PM 4192 (0x1060)
Looking for bootImage DRC00002 SMSPXE 4/28/2015 2:50:03 PM 4192 (0x1060)

Check out current deals!


Shop current deals

Top Kudoed Authors