Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Software and Operating SystemEnterprise Client Management
All Forum Topics
Options

7 Posts

05-07-2018

United States of America

8 Signins

73 Page Views

  • Posts: 7
  • Registered: ‎05-07-2018
  • Location: United States of America
  • Views: 73
  • Message 1 of 6

ThinInstaller Not Installing Chipset Driver on X1 Yoga 4th Gen (Type 20QG)

2021-05-27, 16:21 PM

Currently in our environment, I use Update Retriever to download Lenovo drivers to a repository saved on a network share and then in an SCCM Task Sequence, install ThinInstaller and use a command prompt command to have ThinInstaller search for drivers from the repo. I am currently testing models for the move from Windows 1909 to 20H2 and I am running into an issue where ThinInstaller is not picking up the Intel Chipset driver for the repository. 

 

What is happening is a base system device is missing with the following hardware IDs

Missing DriverMissing Driver Hardware IDs

 

In looking up the hardware ids I find out it's the Intel Chip Driver Software is the missing driver (Id # n2hic04w). If I download and install the driver manually from Lenovo support, it installs the driver fine and there are no missing updates, but with 80 of these I am supporting, that is not an option.

 

I checked UpdateRetriever and I find that the update is already in my driver database, but is listed as two versions. One for 8th gen processors and one for 10th gen processors. This laptop needs the 8th gen processor

Update Retriever

 

I rebuilt that laptop with my SCCM Task Sequence again and ThinInstaller would still not pick up the update. I went into driver settings and added the hardware ids of the missing driver to the detection but ThinInstaller still will not pick up the driver. The logs seem to indicate that it knows about the chipset driver, it just doesn't install it. I am not sure why it is doing this or what the problem may be. Attached are the ThinInstaller Logs. Any help on this issue would be greatly appreciated. Let me know if you have any other questions. Thank You.

Reply
Options

6926 Posts

10-29-2009

United States of America

17808 Signins

166030 Page Views

  • Posts: 6926
  • Registered: ‎10-29-2009
  • Location: United States of America
  • Views: 166030
  • Message 2 of 6

Re:ThinInstaller Not Installing Chipset Driver on X1 Yoga 4th Gen (Type 20QG)

2021-05-28, 13:15 PM

I also see this problem on my X1 Yoga 4th.  We will investigate it.  Sorry for this trouble.

Reply
Options

7 Posts

05-07-2018

United States of America

8 Signins

73 Page Views

  • Posts: 7
  • Registered: ‎05-07-2018
  • Location: United States of America
  • Views: 73
  • Message 3 of 6

Re:ThinInstaller Not Installing Chipset Driver on X1 Yoga 4th Gen (Type 20QG)

2021-05-28, 15:31 PM

Thank You. It was driving me crazy that I could not get this driver to install.

Reply
Options

6926 Posts

10-29-2009

United States of America

17808 Signins

166030 Page Views

  • Posts: 6926
  • Registered: ‎10-29-2009
  • Location: United States of America
  • Views: 166030
  • Message 4 of 6

Re:ThinInstaller Not Installing Chipset Driver on X1 Yoga 4th Gen (Type 20QG)

2021-06-09, 12:26 PM

This issue should be fixed as of today.  Sorry it took so long.  The XML file was updated so you'll need to remove the old package from your repository and then download the new one.  Package ID is the same, just the XML file was updated to fix this problem.

Reply
Options

7 Posts

05-07-2018

United States of America

8 Signins

73 Page Views

  • Posts: 7
  • Registered: ‎05-07-2018
  • Location: United States of America
  • Views: 73
  • Message 5 of 6

Re:ThinInstaller Not Installing Chipset Driver on X1 Yoga 4th Gen (Type 20QG)

2021-06-10, 21:24 PM

The issue is still not fixed. I have deleted all the X1 Yoga 4th Gen drivers and redownloaded them. from Update Retriever I just did another rebuild and I still cannot get that driver installed. I noticed there is no 8th gen or 10th gen driver anymore, just one Intel Chipset Driver with the ID of n2hic04w. I still have the same base driver missing with the same hardware id. Attached are the ThinInstaller logs. Let me know if you need anymore information. Thank You.

 

Reply
Options

6926 Posts

10-29-2009

United States of America

17808 Signins

166030 Page Views

  • Posts: 6926
  • Registered: ‎10-29-2009
  • Location: United States of America
  • Views: 166030
  • Message 6 of 6

Re:ThinInstaller Not Installing Chipset Driver on X1 Yoga 4th Gen (Type 20QG)

2021-06-10, 22:31 PM

I just redeployed 20QG with Win10 20H2, pointed Thin Installer to a fresh 20QG repository, and had no trouble installing the chipset driver n2hic04w.  Your issue is probably caused by using out-of-date Thin Installer... latest version is 1.3.0027.

 

https://support.lenovo.com/us/en/solutions/ht037099#ti

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms