cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
md36
Token Ring
Posts: 71
Registered: ‎02-19-2018
Location: CH
Views: 73
Message 11 of 14

Re: Thininstaller Update r0yvu10e Hotkey Features Integration 9.0.2.12 hangs

1.  How was n1wvu60e originally deployed?  Was it by ThinInstaller, or some other way?

It was deployed using standard sccm driver package

 

2.  When you run ThinInstaller, what user account is running it?  Is it run through SCCM, or some other way?

 

We have an sccm package.Thininstaller is lauched through an appdeploy powershell script.

 

3.  What user(s) are logged into the system at the time that you run ThinInstaller?  Are they admin users, or standard users?

normal user

Highlighted
md36
Token Ring
Posts: 71
Registered: ‎02-19-2018
Location: CH
Views: 73
Message 12 of 14

Re: Thininstaller Update r0yvu10e Hotkey Features Integration 9.0.2.12 hangs

and now we had another t470s where thininstaller reported installation completed return code 0 for hotkey but when i checked before and after a reboot the driver version was still the old one.Only the second attempt did install it

Lenovo Staff
Lenovo Staff
Posts: 4,873
Registered: ‎10-29-2009
Location: NC
Views: 37
Message 13 of 14

Re: Thininstaller Update r0yvu10e Hotkey Features Integration 9.0.2.12 hangs

I am still not able to reproduce a hang problem upgrading from n1wvu60e to r0yvu10e using ThinInstaller.  I think I am testing same as you, by logging in a standard user and then running ThinInstaller.exe as the SYSTEM user (same as what SCCM does).

 

For me to help further, I'll need the detailed repro steps how to make this hang problem happen here.

 

Also, please try r0yvu16e which has recently been released to Update Retriever.

Lenovo Staff
Lenovo Staff
Posts: 4,873
Registered: ‎10-29-2009
Location: NC
Views: 32
Message 14 of 14

Re: Thininstaller Update r0yvu10e Hotkey Features Integration 9.0.2.12 hangs


@md36 wrote:

and now we had another t470s where thininstaller reported installation completed return code 0 for hotkey but when i checked before and after a reboot the driver version was still the old one.Only the second attempt did install it


I can explain this issue where you have to run the r0yvu10e installer twice, and I can reproduce it here.  n1wvu60e had the bug where installation by SCCM was not actually finished.  Although setup.exe would return, some parts of the installation were left pending, until an admin user logged into the system.  In your case, normally an admin user never logs into the system.  So the installation of n1wvu60e never finished.  r0yvu10e fixes this issue, but the first time you run it, it just causes the previous installation of n1wvu60e to finish.  You have to run r0yvu10e again to do the actual update.

Holiday Deals
HAPPENING NOW!

Get the best deals on PCs and tech now during the Holiday Sale
Shop the sale