Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Datacenter StorageEnterprise Storage
All Forum Topics
Options

3 Posts

07-19-2019

Russian Federation

1 Signins

70 Page Views

  • Posts: 3
  • Registered: ‎07-19-2019
  • Location: Russian Federation
  • Views: 70
  • Message 1 of 6

DE4000H and SAS HBA connection

2019-07-19, 13:19 PM

Hello to everyone!

 

I have DE4000H data storage and ThinkSystem 430-8e SAS/SATA 12Gb HBA adapter installed into SR650 server. I faced problem connecting storage by 8644 cable. As soon i did it the storage raise the miswire error:

 

Date/Time: Jul 20, 2019 12:07:25 AM
Sequence number: 536
Event type: 1702
Event category: Error
Priority: Critical
Event needs attention: true
Event send alert: true
Event visibility: true
Description: SAS host adapter miswire detected
Event specific codes: 0/0/0
Component type: IOM (ESM)
Component location: Shelf 99, Bay
Logged by: A

Raw data:
4D 45 4C 48 03 00 00 00 18 02 00 00 00 00 00 00
02 17 17 01 0D 31 32 5D 14 00 00 00 A4 00 00 00
00 00 00 00 01 00 00 00 22 00 00 00 22 00 00 00
07 00 00 00 63 00 00 00 01 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
01 00 00 00 00 00 00 02 10 00 00 00 04 00 00 08
63 00 00 00 04 00 26 88 01 00 00 00

 

I checked the HBA and Storage compatibility and it seems ok. I flashed the latest Firmware and BIOS to HBA, installed the latest OS to storage, but with no luck. I also tried to configure the HBA settings with LSI Storage Authority, but did not find any settings.

 

I read manual and it says that I should "find the SAS addresses using the HBA utility, then use the HBA BIOS to make the appropriate configuration settings"

 

Could anyone point me out what i'm doing wrong? Any comments will be helpful

 

Reply
Answer
Options

242 Posts

04-20-2015

Canada

331 Signins

1939 Page Views

  • Posts: 242
  • Registered: ‎04-20-2015
  • Location: Canada
  • Views: 1939

Re: DE4000H and SAS HBA connection

2019-07-19, 13:50 PM

Just curious where are you plugging the cables in the back for the DE unit? See below.

Possible it's not the case here, but may be worthwhile to check.

 

You need to have the HIC with SAS ports, and that's where the cables go; are you plugging the cables in the "expansion port" SAS ports? Those are for daisy chaning drive shelves, host connectivity need to be done via the HIC SAS ports.

 

Cheers

 

Reply

Replies(5)
Options

25 Posts

09-26-2018

Taiwan,China

140 Signins

1136 Page Views

  • Posts: 25
  • Registered: ‎09-26-2018
  • Location: Taiwan,China
  • Views: 1136
  • Message 2 of 6

Re: DE4000H and SAS HBA connection

2019-07-19, 13:27 PM

 Hi, dmitrielgin,

 

What's your topology and configuration? it's directly attached?

Have you swapped the cable?

 

Thank you.

 

 

Reply
Options

3 Posts

07-19-2019

Russian Federation

1 Signins

70 Page Views

  • Posts: 3
  • Registered: ‎07-19-2019
  • Location: Russian Federation
  • Views: 70
  • Message 3 of 6

Re: DE4000H and SAS HBA connection

2019-07-19, 13:35 PM
Hi, BTman,

Yes, it is directly attached without any SAS devices in the middle. It seems that the storage expect more complex signal from SAS cable and says that direct connection is not supported.

I tried different cables, i have 4, but with no luck.

Here 's more details from storage:

Details
Component reporting problem:
SAS Port
Miswire type:
HBA connected to drive channel
Port located on:
Controller
Location:
Shelf 99, Bay A
Connection:
Internal connection

SAS Host - Improper Connection (Miswire)
A host is improperly connected to a drive channel port on one of the storage array's controllers or IOM (ESM).

Important Notes
Refer to the cabling documentation for the storage array's controller and drive shelves for more information on valid cabling configurations.
To prevent the host from directly accessing the storage array's drives, the port on the controller or IOM that the host is connected to has been disabled.
Recovery Steps
Disconnect the cable attached to the port listed in the Details area and reconnect it to one of the controller's host ports.
Re-enable the disabled drive channel port.

Go to Support > Support Center. Then, select the Diagnostics tab.
Select the Re-enable Drive Ports link located in the View and/or take action on my current storage array status section.
Select Recheck to ensure the problem has been resolved. If this problem still appears in the Problems area, go to step 4.
Power-cycle ALL of the components involved in the miswire.
Select Recheck to ensure the problem has been resolved.
Reply
Answer
Options

242 Posts

04-20-2015

Canada

331 Signins

1939 Page Views

  • Posts: 242
  • Registered: ‎04-20-2015
  • Location: Canada
  • Views: 1939
  • Message 4 of 6

Re: DE4000H and SAS HBA connection

2019-07-19, 13:50 PM

Just curious where are you plugging the cables in the back for the DE unit? See below.

Possible it's not the case here, but may be worthwhile to check.

 

You need to have the HIC with SAS ports, and that's where the cables go; are you plugging the cables in the "expansion port" SAS ports? Those are for daisy chaning drive shelves, host connectivity need to be done via the HIC SAS ports.

 

Cheers

 

0 person found this solution to be helpful.

This helped me too

Reply
Options

25 Posts

09-26-2018

Taiwan,China

140 Signins

1136 Page Views

  • Posts: 25
  • Registered: ‎09-26-2018
  • Location: Taiwan,China
  • Views: 1136
  • Message 5 of 6

Re: DE4000H and SAS HBA connection

2019-07-19, 13:53 PM

Hi, dmitrielgin,

 

How did you connect the SR650 between your DE4000? Are you follow the Thinksystem_storage_de_himg_en guide.?

Make sure your SAS port connection with the right port.

 

Thank you.

Reply
Options

600 Posts

08-14-2018

United States of America

578 Signins

10434 Page Views

  • Posts: 600
  • Registered: ‎08-14-2018
  • Location: United States of America
  • Views: 10434
  • Message 6 of 6

Re: DE4000H and SAS HBA connection

2019-07-19, 15:17 PM

For assistance with cabling please take a look at the  Installation and Setup Guide

 

https://download.lenovo.com/storage/lenovo_de_2u_enclosurers_installation_and_setup_instruction_en.pdf

 

There is a specific section on how to setup the cabling on page 3

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms