cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sjeye
Paper Tape
Posts: 10
Registered: ‎08-15-2009
Location: nj
Views: 1,308
Message 1 of 3

Droid sync problem with Exchange 2010

I'm an old Droid (original) user who was happily sync'd to my Exchange 2003 server until a recent upgrade to Exchange 2010.

Since the upgrade, I can't sync.  I get the message "cannot connect to server" when I try to use the native Android client.  As far as I know, the settings on Exch2010 are unchanged from Exch2003  (Activesync enabled; SSL disabled).  Other smartphones (non Droid) are able to connect and sync.

I tried to install Touchdown, but it errors out during config after the line "Refreshing AS folders” with the “Error refreshing folders“ message, and install closes.

My Droid is running Android 2.2.2;  FRG83G

I'd appreciate any advice about how I can get sync'd. 

Thanks in advance - Jim (SJEYE)

anguish
What's DOS?
Posts: 259
Registered: ‎12-22-2010
Views: 1,308
Message 2 of 3

Re: Droid sync problem with Exchange 2010

SSL enabled is a requirement now for ActiveSync to work, IIRC.

I'm running Exchange 2010 on one of my two Exchange servers I connect to, and I do recall having to do something to get it to work, but I don't remember what exactly.  If it's the same problem I had, the Event Viewer logs will point you in the right direction.

Not applicable
Posts: 0
Views: 1,308
Message 3 of 3

Re: Droid sync problem with Exchange 2010

Sjeye,

If you are an Exchange Admin, here is some steps to get some background info we could trouble shoot. Or if you could forward this steps to your Exchange Admin and we'd be happy to assist further.

Most likely your exchange 2010 has some ActiveSync policies that are not supported on the Droid or other Android devices. To trouble shoot more, you could do the following in the exchange management shell:

1. Find out your mailbox's activesync policy name:
          Get-CASMailbox |ft Displayname, ActiveSyncMailboxPolicy

2. List your policies settings into a text file and paste it back here: (You need to replace the “Default” with your policy name which you get from step 1.

          Get-ActiveSyncMailboxPolicy "Default" > c:logpolicy.txt

The Droid only support limited Exchange policies. By changing some of the policies to default or simply enable “Allow non-provisionable device” might resolve your issue.

You could also use Google SDK, the debug monitor to check the log file when setup your Exchange account.

Please be aware that any policy changes may cause other mailboxes users stopped sync. Please create a separate policy for testing purpose. You might need to remove CorpSync account and re-add it back to test any policy changes.

Bin

Enterprise Support