Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsFedora
All Forum Topics
Options

9 Posts

04-02-2020

Netherlands

31 Signins

165 Page Views

  • Posts: 9
  • Registered: ‎04-02-2020
  • Location: Netherlands
  • Views: 165
  • Message 1 of 6

Nvidia-settings not working properly

2021-01-08, 16:15 PM

I installed Fedora 33 recently and used this tutorial to install nvidia drivers. Now my nvidia-settings behaves very weird. I really want to use the nvidia PRIME feature since I have a ThinkPad P1 Gen 2 with integrated and discrete graphics. Some information:

 

➜  ~ modinfo nvidia
filename:       /lib/modules/5.9.16-200.fc33.x86_64/extra/nvidia/nvidia.ko
alias:          char-major-195-*
version:        455.45.01
supported:      external
license:        NVIDIA
srcversion:     9596FDF4ECB68196404E921
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        
retpoline:      Y
name:           nvidia
vermagic:       5.9.16-200.fc33.x86_64 SMP mod_unload 
parm:           NvSwitchRegDwords:NvSwitch regkey (charp)
parm:           NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)
parm:           nv_cap_enable_devfs:Enable (1) or disable (0) nv-caps devfs support. Default: 1 (int)
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_EnableStreamMemOPs:int
parm:           NVreg_EnableBacklightHandler:int
parm:           NVreg_RestrictProfilingToAdminUsers:int
parm:           NVreg_PreserveVideoMemoryAllocations:int
parm:           NVreg_DynamicPowerManagement:int
parm:           NVreg_DynamicPowerManagementVideoMemoryThreshold:int
parm:           NVreg_EnableUserNUMAManagement:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_KMallocHeapMaxSize:int
parm:           NVreg_VMallocHeapMaxSize:int
parm:           NVreg_IgnoreMMIOCheck:int
parm:           NVreg_NvLinkDisable:int
parm:           NVreg_EnablePCIERelaxedOrderingMode:int
parm:           NVreg_RegisterPCIDriver:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RegistryDwordsPerDevice:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_GpuBlacklist:charp
parm:           NVreg_TemporaryFilePath:charp
parm:           NVreg_AssignGpus:charp
➜  ~ lspci -vnnn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b] (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU117GLM [Quadro T1000 Mobile] [10de:1fb9] (rev a1) (prog-if 00 [VGA controller])
➜  ~ dnf list installed | grep nvidia
akmod-nvidia.x86_64                                3:455.45.01-3.fc33                     @rpmfusion-nonfree-nvidia-driver               
kmod-nvidia-5.9.14-200.fc33.x86_64.x86_64          3:455.45.01-3.fc33                     @@commandline                                  
kmod-nvidia-5.9.15-200.fc33.x86_64.x86_64          3:455.45.01-3.fc33                     @@commandline                                  
kmod-nvidia-5.9.16-200.fc33.x86_64.x86_64          3:455.45.01-3.fc33                     @@commandline                                  
nvidia-settings.x86_64                             3:455.45.01-1.fc33                     @rpmfusion-nonfree-nvidia-driver               
xorg-x11-drv-nvidia.x86_64                         3:455.45.01-1.fc33                     @rpmfusion-nonfree-nvidia-driver               
xorg-x11-drv-nvidia-kmodsrc.x86_64                 3:455.45.01-1.fc33                     @rpmfusion-nonfree-nvidia-driver               
xorg-x11-drv-nvidia-libs.i686                      3:455.45.01-1.fc33                     @rpmfusion-nonfree-nvidia-driver               
xorg-x11-drv-nvidia-libs.x86_64                    3:455.45.01-1.fc33                     @rpmfusion-nonfree-nvidia-driver              
➜  ~ nvidia-settings -q all

➜  ~ 

 

This is how the GUI looks, as you can see a lot of options are missing.

Reply
Options

1366 Posts

05-14-2020

United States of America

583 Signins

7080 Page Views

  • Posts: 1366
  • Registered: ‎05-14-2020
  • Location: United States of America
  • Views: 7080
  • Message 2 of 6

Re:Nvidia-settings not working properly

2021-01-14, 2:44 AM

Hello,

 

It looks mostly correct.

My suggestions:

A)  Carefully plot out the name of your installed Nvidia card.   Then go to Nvidia.com and find what Linux driver version is the latest.  Sometimes the driver version is slightly different between Linux distributions.  Then find that version in the repository, only download the one from Nvidia as a last resort.

B)  Plot out what kind of machine architecture you have.  If it is i686, uninstall the x86_64 drivers, or vice-versa.  Having both kinds active might be the problem. A lot of AMD chips use the x86_64 drivers.

C)  On your desktop environment login page, select your user name, then in Gnome there will be a tiny gear icon somewhere on the screen, on mine it is on the very bottom right corner.  Select that and activate the menu dropdown to start up  Gnome in the XOrg mode.  There is lots of troubleshooting help for XOrg compatibility with Nvidia cards.  The newer Wayland mode probably can be set up to work just fine, but finding the Wiki's and so forth to find the command recipe sequences is more difficult because it is newer.

D) In the worst case for your desktop environment find one that still ONLY has X-Windows mode.  FXDE is rumored to have never tried to invoke Wayland.

 

After you get it running in X-Org, then you can shift into Wayland, there are at least two compositors under Wayland, exact setup could be a little different depending on which compositor is active. 

(Oh for the good old days when screens were either green or amber and only displayed ascii in 80 columns wide, no graphics available except using grap command would print out pretty things on the line printer.  Progress?? )

 

Good Luck!

Usedtoberich

Reply
Options

9 Posts

04-02-2020

Netherlands

31 Signins

165 Page Views

  • Posts: 9
  • Registered: ‎04-02-2020
  • Location: Netherlands
  • Views: 165
  • Message 3 of 6

Re:Nvidia-settings not working properly

2021-01-27, 14:01 PM

Thanks a lot for helping me! To answer your suggestions:

 

B) I have a x86_64 architecture, how would I go about uninstalling the i686 (and other?) versions? Removing them with dnf?

dnf list

These are the packages that are installed on my system.

 

C) On my Fedora 33 version, I have the option between "GNOME" and "GNOME classic". Is "GNOME" wayland?

EDIT: I don't know if this is replying properly, but this should be a reply to Usedtoberich

Reply
Options

1366 Posts

05-14-2020

United States of America

583 Signins

7080 Page Views

  • Posts: 1366
  • Registered: ‎05-14-2020
  • Location: United States of America
  • Views: 7080
  • Message 4 of 6

Re:Nvidia-settings not working properly

2021-01-27, 14:49 PM

Hello,

 

For removing packages the best way is to use the dnf command.

Read the man pages (or info pages) for the dnf command.  Accomplish these tasks with appropriate command line keystrokes:

1)  List the installed packages, store the list into a text file.  dnf {{listinstalledpackages}}  redirect into (>)  myinstalledpackagesfile.txt

2) then use grep command to find text lines containing i686 and redirect into a text file, so grep i686 myinstalled packagesfile.txt > myi686installedpackages.txt

3) Then find the dnf command that will read the text file to obtain the list of packages to uninstall.  With the bash shell commands there are probably several ways to do this.

 

Packages with noarch in the title are configured such that machine architecture does not matter.  They can remain if you use them for something.  If you remove them all your system might not work very well.

 

For finding if you use Wayland or not check into the Fedora 33 System Administration Manual :  https://docs.fedoraproject.org/en-US/fedora/f33/   There is a chapter with details about the Wayland graphics system.

 

As I mentioned, getting nvidia graphics to function under Wayland is not impossible, it's just hard to find the instructions if it does not automatically function after installation with dnf commands.

 

Usedtoberich

Reply
Options

9 Posts

04-02-2020

Netherlands

31 Signins

165 Page Views

  • Posts: 9
  • Registered: ‎04-02-2020
  • Location: Netherlands
  • Views: 165
  • Message 5 of 6

Re:Nvidia-settings not working properly

2021-02-12, 16:37 PM
Well I found out that I am using X11... I also saw that some applications like steam depend on the i686 packages so it would remove them together with the i686 packages, so I don't really want to remove them...
Reply
Options

1366 Posts

05-14-2020

United States of America

583 Signins

7080 Page Views

  • Posts: 1366
  • Registered: ‎05-14-2020
  • Location: United States of America
  • Views: 7080
  • Message 6 of 6

Re:Nvidia-settings not working properly

2021-02-13, 2:47 AM

Hello,

 

That is the beauty of using dnf to manage packages, it keeps one from breaking software dependencies.....  Have you installed some software groups?

 

Unfortunately I am not the best reference, my equipment does not have nvidia graphics adapter and it is not a Thinkpad P2....

 

If your nvidia board is within the "Optimus" family this link might provide some help:  https://docs.fedoraproject.org/en-US/quick-docs/how-to-set-nvidia-as-primary-gpu-on-optimus-based-laptops/

 

At the bottom of this document are links to other possibly useful troubleshooting guides....

 

Good Luck,

Usedtoberich

 

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms