English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

4 Posts

05-24-2020

US

6 Signins

30 Page Views

  • Posts: 4
  • Registered: ‎05-24-2020
  • Location: US
  • Views: 30
  • Message 1 of 2

BIOS not accessible (really not accessible)

2020-09-23, 22:57 PM

I have a Legion Y720 and I cannot access BIOS.

 

These are my tries:

 

> Advanced Initialization on Windows - the option for changing UEFI configs shows up. After clicking this option the computer restarts and Windows is booted.

> All the keyboard keys already pressed on booting , none takes me to the BIOS

> The Lenovo NOVO button - the option shows up. After clicking the BIOS Setup option Windows is booted.

> Disconnected the RTC Battery and Laptop Battery for 1 minute, and still the problem persists

 

I believe the problem is not the HDD or SSD, since I formated then and removed them to test, and still not possible to access BIOS.

 

 

Important note: I am using a USB Keyboard. When the BIOS access problem started, my laptop keyboard stopped working and on every boot the window "Boot Manager" appears to me, regardless the option I choose on this "Boot Manager"I am taken to the Windows.

 

The laptop has 1.5 years only, and warranty is over.

 

Any idea?

 

I really need the laptop to work properly, I need to use VMs and , at the moment, i am not able to change virtualisation settings through BIOS.

 

Attached is the image from the Boot Manager that appears everytime I turn on the laptop.

Reply
Options

9 Posts

12-19-2017

MX

11 Signins

66 Page Views

  • Posts: 9
  • Registered: ‎12-19-2017
  • Location: MX
  • Views: 66
  • Message 2 of 2

Re:BIOS not accessible (really not accessible)

2020-10-15, 16:50 PM

Hello! I am having the same problem I've had the problem for over a year. Same thing and I know what you're talking about.  I was able to access the BIOS a couple of times disconnecting all power including CMOS and all but there's really no one way to  successfully access the BIOS and I've tried Everything you can imagine: Booting w/o integrated keyboard, booting w/o HDD or SSD booting without ethernet or wifi. I was even able to make the integrated keyboard work once or twice until I got tired and I just bought myself a really nice mechanical keyboard not to feel as ripped off as I would otherwise. I had flashed the BIOS to no avail. If you are able to eventually access the BIOS, disable the option for fast boot, otherwise you will not be able to access the BIOS again until stars align and if you flash the BIOS the settings will reset and factory settings are Fast Boot and the option to flash with previous BIOS versions disabled which will lock you out of the BIOS again and render you unable to Flash the BIOS again. I have not tried to rollback the BIOS. If I were to guess it's a bug with the BIOS these guys are just to lazy to fix it. For a guy that has always stick to Lenovo IBM Motorola products I will never buy another Lenovo product ever again.

 BTW let me know if anything works out for you. I will really really appreciate it. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete