cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TNTitan89
Fanfold Paper
Posts: 6
Registered: ‎02-19-2015
Location: US
Views: 824
Message 71 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

I used F2 at startup to enter the InsydeH20 Setup Utility, and I chose Load Default Settings from the Exit menu, confirming with Yes for "Load Optimal Defaults?". (I also later tried F9 which seems to do the same thing.) I pressed F10 and then Enter to Save and Exit. The computer restarted and failed again with the CRITICAL PROCESS DIED stop code, so it didn't solve the problem. The only difference I can see in the UEFI settings from before and after the default settings load is that Secure Boot had been previously disabled and is now enabled.

AzeemJoeharry
What's DOS?
Posts: 3
Registered: ‎08-23-2018
Location: MY
Views: 776
Message 72 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

Hi there. I've updated to bios 4KCN43WW from the previous version and now i'm having trouble booting up my laptop. Is there any solution that can help in my situation?

AzeemJoeharry
What's DOS?
Posts: 3
Registered: ‎08-23-2018
Location: MY
Views: 749
Message 73 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

How am i able to do that? After the legion logo, all i see is a black screen. Pressed F2 and nothing happened
pranav_stefan
SCSI Port
Posts: 117
Registered: ‎09-03-2017
Location: IN
Views: 681
Message 74 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

Did something mess up or they reverted 44WW BIOS... The download page again shows 43WW and 11 May 2018 as update date. OMG?

AzeemJoeharry
What's DOS?
Posts: 3
Registered: ‎08-23-2018
Location: MY
Views: 679
Message 75 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

Nah nevermind. Solved the problem last night. Thanks dude
012512
Punch Card
Posts: 16
Registered: ‎06-26-2018
Location: PH
Views: 592
Message 76 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

by setting the bios to defaults?

MoAzeem
Paper Tape
Posts: 3
Registered: ‎08-27-2018
Location: MY
Views: 580
Message 77 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

After the legion logo came out, quikly press F2. It will then bring you to the InsydeH20 Setup Utility. Go to configuration and enable the BIOS Back Flash. Save and exit by pressing F10. Give it some time to boot, and there you have it. Problem solved.

Simen_K
Fanfold Paper
Posts: 6
Registered: ‎08-31-2018
Location: NO
Views: 505
Message 78 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

I am in the exact same situation as you were with your Lenovo Y520, and I need to know how you fixed it! Please reply as soon as possible.

gryzor
Fanfold Paper
Posts: 28
Registered: ‎12-06-2017
Location: GR
Views: 500
Message 79 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

You mean the post DIRECTLY above yours?

Simen_K
Fanfold Paper
Posts: 6
Registered: ‎08-31-2018
Location: NO
Views: 627
Message 80 of 95

Re: DO NOT UPDATE BIOS 4KCN43WW ON LEGION Y520

When i press F2 on startup all I get is that I have to enter the "System password" which I have not set! U have a fix for this?

Check out current deals!


Shop current deals

Top Kudoed Authors