English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

26 Posts

10-05-2019

FR

22 Signins

225 Page Views

  • Posts: 26
  • Registered: ‎10-05-2019
  • Location: FR
  • Views: 225
  • Message 1 of 13

Help with TDP on Y540 since Vantage updates

2019-11-18, 22:45 PM

Hi All,

 

I'm running out of solutions so I come here to get some extra help, either from community or lenovo support members.

 

I used Enterprise version of Vantage, which worked perfectly well regarding Thermal modes. When I set Quiet, Balanced or Performance, it changed my PL1 and 2 on the fly. I could monitor that with HWinfo64.

But after I updated from Windows Store, the PL1 et PL2 are capped respectively at 45W and 90W, no matter the Thermal Mode. Before, Quiet Mode meant 25/40 and Perf Mode switched to 75/110. Only the fans seem to be affected by the modes.

So I uninstalled the Windows store version and reverted to the Enterprise version but that hasn't reverted the former TDP. Thermal modes no longer affects CPU Power usage. So Quiet mode means hot temp since it's max CPU power use but with less speed fan, which is a flaw in TDP for me.

 

What's even weirder is on some reboot, sometimes it's even changed to 20W/40W for no reason.

 

Am I the only one to experiencing this ? I'm on 32WW BIOS version and 10.1910.16.0 Vantage version

Since I wanted to update my Legion, I manually installed drivers from the product page, such as "Intel Dynamic Platform and Thermal Framework (DPTF) Driver for Windows 10 (64-bit) - Legion Y540-15IRH, Legion Y545, Legion Y540-17IRH, Legion Y7000-2019" 

Does it have something to do with my problem? If it does, how to remove this in order to test?

 

Thanks again for your help guys

Reply
Options

461 Posts

09-27-2019

CN

379 Signins

6997 Page Views

  • Posts: 461
  • Registered: ‎09-27-2019
  • Location: CN
  • Views: 6997
  • Message 2 of 13

Re: Help with TDP on Y540 since Vantage updates

2019-11-19, 7:24 AM

hi,Fourch

Would you mind to give a screenshot of Vantage you are using now? 

And do you remember the last BIOS version you installed on that version everything worked well?

Reply
Options

26 Posts

10-05-2019

FR

22 Signins

225 Page Views

  • Posts: 26
  • Registered: ‎10-05-2019
  • Location: FR
  • Views: 225
  • Message 3 of 13

Re: Help with TDP on Y540 since Vantage updates

2019-11-19, 10:04 AM

Hi, here are the new Vantage version my problems started with and the old one it used to work as intended (at lease as I described in my original post) :

 

I tried to revert to Entreprise version, no change in TDP.

 

The BIOS version on which everything  worked well was WW32. And it's still the one I'm using, even after having tried older version, in vain.

 

Reply
Options

601 Posts

08-01-2018

US

399 Signins

10425 Page Views

  • Posts: 601
  • Registered: ‎08-01-2018
  • Location: US
  • Views: 10425
  • Message 4 of 13

Re: Help with TDP on Y540 since Vantage updates

2019-11-19, 13:43 PM

Hi Fourch!

 

Try dowgrading the BIOS of your computer to version 26. Make sure that the BIOS Backflash is enabled on the BIOS settings of your computer. 

 

Download File : https://download.lenovo.com/consumer/mobiles/bhcn26ww.exe

Read Me : https://download.lenovo.com/consumer/mobiles/bhcn26ww.txt

 

 

Regards,

Jerry_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

26 Posts

10-05-2019

FR

22 Signins

225 Page Views

  • Posts: 26
  • Registered: ‎10-05-2019
  • Location: FR
  • Views: 225
  • Message 5 of 13

Re: Help with TDP on Y540 since Vantage updates

2019-11-19, 17:07 PM

Hi Jerry, I've done that already, with that WW26 version and nothing changed. I even tried to come back to WW32 but same thing. The Power limits remains the same no matter the mode BUT for the GPU. On Perf Mode, the GPU gets 90W instead of 80W on Balanced and Quiet, as it was before all that mess.

 

So it's a CPU TDP related problem. Is there something that can force 45W/90W PL for the CPU, no matter Vantage?

Reply
Options

162 Posts

09-02-2018

RO

825 Signins

7845 Page Views

  • Posts: 162
  • Registered: ‎09-02-2018
  • Location: RO
  • Views: 7845
  • Message 6 of 13

Re: Help with TDP on Y540 since Vantage updates

2019-11-19, 23:36 PM

 wrote:

Hi Jerry, I've done that already, with that WW26 version and nothing changed. I even tried to come back to WW32 but same thing. The Power limits remains the same no matter the mode BUT for the GPU. On Perf Mode, the GPU gets 90W instead of 80W on Balanced and Quiet, as it was before all that mess.

 

So it's a CPU TDP related problem. Is there something that can force 45W/90W PL for the CPU, no matter Vantage?


Try to reinstall or uninstall System Interface Foundation V2 Device driver which can be found in Device Manager under System devices tab.

This might help you.

Reply
Options

4 Posts

11-21-2019

BR

5 Signins

45 Page Views

  • Posts: 4
  • Registered: ‎11-21-2019
  • Location: BR
  • Views: 45
  • Message 7 of 13

Re: Help with TDP on Y540 since Vantage updates

2019-11-21, 12:10 PM

I'm having this exact problem. I formatted my Windows 10, latest 32WW bios, latest drivers and Windows Store Lenovo Vantage is also installed. 

 

What I realize is that even in performance mode in Vantage I'm capped at 45W, which makes my CPU top at 3.3ghz in stress tests such as Cinebench. Its running really cool, tops at 78º C, but i'm missing a bit of performance because of this limit. I also am using it undervolted -0.145. 

 

It still turbo sometimes to 4ghz+, but my sintetic benchmarks are always really lower compared to other i7-9750H because of this limit.

 

I really am not sure how to increase the TDP to match others Y540, should I do it through Throttlestop? Is it Lenovo Vantage not working properly?

Reply
Options

461 Posts

09-27-2019

CN

379 Signins

6997 Page Views

  • Posts: 461
  • Registered: ‎09-27-2019
  • Location: CN
  • Views: 6997
  • Message 8 of 13

Re: Help with TDP on Y540 since Vantage updates

2019-12-10, 6:58 AM

Hi, Fourch

Could you try to run BIOS Load default, and then check whether the it works normally?

Reply
Options

7 Posts

12-20-2019

EG

14 Signins

218 Page Views

  • Posts: 7
  • Registered: ‎12-20-2019
  • Location: EG
  • Views: 218
  • Message 9 of 13

Re: Help with TDP on Y540 since Vantage updates

2019-12-20, 23:11 PM

Maybe you can try using uninstaller app to uninstall vantage like IObit Uninstaller PRO 7 or ashampoo uninstaller to erase all the files connected to vantage and make a refresh install

Blue ocean
Reply
Options

7 Posts

07-04-2020

US

11 Signins

100 Page Views

  • Posts: 7
  • Registered: ‎07-04-2020
  • Location: US
  • Views: 100
  • Message 10 of 13

Re:Help with TDP on Y540 since Vantage updates

2020-07-05, 2:52 AM

Did you solve your problem? Same issue here

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete