English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

6 Posts

11-06-2019

CA

14 Signins

129 Page Views

  • Posts: 6
  • Registered: ‎11-06-2019
  • Location: CA
  • Views: 129
  • Message 1 of 15

Hybrid Mode Not Working (Again)

2019-11-06, 22:46 PM

Greetings

 

I have a Legion Y740-15IRHg ( i7 9750H + 2060 + 1TB m.2 SSD). 

 

My Problem:

 

My laptop does not last as long as it did a few days ago on battery. It is showing roughly 1 hour 10 minutes on a full charge with hybrid mode disabled. With hybrid mode enabled, I will get a basically negligible difference of something like 1 hour 20 minutes. 

 

I was getting well over 4 or 5 hours with a full charge at one point. I can visually see that the graphics settings are not actually changing anymore. Before, when I went into hybrid mode, I would see a difference in video quality being reduced when hybrid mode was turned on. It looks the same as if hybrid mode is disabled now even though i am making the switch in vantage (and I also tried to switch it in BIOS mode. 


Keep In Mind: 

The tests I run are all with the same parameters:

  • I have a special power setting profile in windows 10 (maximum battery life on all settings)
  • Hybrid mode on
  • Screen brightness set to 30% (my 300nits display could go to 50%) 
  • RGB off
  • I have tried with UV of -135mV and with no undervolt

 

What I've Done:

  • Traded in 2 different laptops for new ones
  • Fresh Install of Lenovo Vantage (and Vantage Beta)
  • Checked for Lenovo Updates. 
  • Checked manually for intel updates. 
  • Re-installed integraded intel graphics  driver. 

 

I'm having difficulty figuring out why hybrid mode is not working on my laptop. I am almost 99% sure this is based on the Lenovo Vantage software at this point. I have had 3 different laptops and everything was working fine until it wasn't (out of nowhere) and I have no clue what to do next.

 

In all honesty I am regretting my choice for this laptop a bit. I have spend so many hours in the last few months just dealing with this same issue over and over again and I'm starting to lean towards the reality that this is something Lenovo has to fix and they have been wasting my time trying to fix it.

 

Do you guys have any suggestions what I should do next besides get a new laptop lol? 

 

 

Reply
Options

6 Posts

11-06-2019

CA

14 Signins

129 Page Views

  • Posts: 6
  • Registered: ‎11-06-2019
  • Location: CA
  • Views: 129
  • Message 2 of 15

Re: Hybrid Mode Not Working (Again)

2019-11-10, 22:52 PM

Hello all, 

 

I managed to restore the power settings back to normal levels. I had to use the Windows 'Reset this PC' feature to basically restore it to factory settings. This is done by windows search > 'reset' > 'Reset This PC'. I used the 'Keep My Files' option. It will take about 30 minutes. Keep in mind you will have to re-install all applications, steam games, etc. If you have a backup drive I recomend doing a fresh install (deleting all files). 

Reply
Options

4 Posts

12-27-2019

US

8 Signins

118 Page Views

  • Posts: 4
  • Registered: ‎12-27-2019
  • Location: US
  • Views: 118
  • Message 3 of 15

Re: Hybrid Mode Not Working (Again)

2019-12-27, 5:52 AM

Thanks for this - I just picked up a Y740 during the holiday, and I am seeing this too. I plan to keep working at it, to see if the battery life can be improved.

 

edit: after fiddling with Vantage, it is now showing 5 hours and 31 minutes on 94% using Thermal Balanced mode, Hybrid mode on, and Rapid Charge for the battery.

Reply
Options

6 Posts

11-06-2019

CA

14 Signins

129 Page Views

  • Posts: 6
  • Registered: ‎11-06-2019
  • Location: CA
  • Views: 129
  • Message 4 of 15

Re: Hybrid Mode Not Working (Again)

2019-12-27, 16:27 PM

A battery estimate of over 5 hours is definitely impressive. Overall, if you keep the brightness down and don't play any games on battery, hybrid mode should be enough to keep most people satisfied with this laptop but when it didn't switch to hybrid mode it drove me insane.

 

What hardware is in your laptop? 2060, 2070 or 1660? My observation between owning the

i7 8750 w/300 nits vs i7 9750 w/500nits display (both with RTX 2060) :

The i7 8th gen w/300 nits display would give me estimates of over 5+ hours when fully charged. The 500nits display never shows over about 4+ hours so the 9th gen i7/500 nits display definitely seems to use more battery life to power the new screen.

 

Keep in mind you also have the option to put the 17" Y740's battery in the 15" model. You will give up the HDD drive slot but this can give you approximately an extra 25% battery life for less than $100.  

Reply
Options

4 Posts

12-27-2019

US

8 Signins

118 Page Views

  • Posts: 4
  • Registered: ‎12-27-2019
  • Location: US
  • Views: 118
  • Message 5 of 15

Re: Hybrid Mode Not Working (Again)

2019-12-27, 22:53 PM
This config came with 2060 and 144 screen. I'm seeing varying numbers as I install apps, sometimes under 3 hours, then closer to 4. You are right about the Vantage software needing some more tweaking.

Thanks, I like that idea about the battery upgrade. I might try that once I see how games perform, and whether the hybrid mode continues working.
Reply
Options

0 Posts

02-05-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎02-05-2020
  • Location: US
  • Views: 0
  • Message 6 of 15

Re: Hybrid Mode Not Working (Again)

2020-02-05, 7:44 AM

I have found a way that fixed the battery life issue Lenovo vantage hybrid mode for me.


I have a 2060 60hz screen i7 9th 16gb ram 475gb SSD 682 HDD (installed my self)

Anyways I use quite for fan settings intel turbo turned off, maximum battery life in intel graphics, and custom power plan. 

So I was using hybrid mode worked fine I was getting 5-6 hours battery life then I enabled a few settings like rapid charging in Lenovo Vantage. After this I received a low 1hr battery life (at the time I didn't realize what was wrong) then I started playing around with the settings again and as soon as I turned off rapid charge my battery life went straight back to the normal 5-6hr battery life.

 

What I did: Turned off Rapid Charge.

 

Respond to this if it worked or if it was just me

Reply
Options

6 Posts

11-06-2019

CA

14 Signins

129 Page Views

  • Posts: 6
  • Registered: ‎11-06-2019
  • Location: CA
  • Views: 129
  • Message 7 of 15

Re: Hybrid Mode Not Working (Again)

2020-02-05, 21:00 PM

I will test again when I go home. Definitely had this setting on at one point and it was right around the time I was having this issue. I didnt think twice about disabling rapid charge but you may be right because my estimate was exactly around 1 hour... it grinded my gears big time since both hybrid and graphics mode were giving same time... 1 hour. Thanks for sharing I will test this at home.

Reply
Options

0 Posts

02-05-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎02-05-2020
  • Location: US
  • Views: 0
  • Message 8 of 15

Re: Hybrid Mode Not Working (Again)

2020-02-06, 5:51 AM

I have been trying to replicate this but I can't seem to get it to work I have also tried disabling my GPU all together but it seems to still use it???

I did realise one other thing while I went to update my drivers it said 20mins download at the time my computer was on 10% and it looks like when I was downloading my battery life went up so the download would complete I am going to keep testing this I will write back soon

Reply
Options

6 Posts

11-06-2019

CA

14 Signins

129 Page Views

  • Posts: 6
  • Registered: ‎11-06-2019
  • Location: CA
  • Views: 129
  • Message 9 of 15

Re: Hybrid Mode Not Working (Again)

2020-02-10, 21:12 PM
Hello StinkyAU,

I also tried to replicate with no success. This time even with hybrid disabled I was getting well over 2.5 hours with only 80% battery. Keep in mind Lenovo may have updated the software since then but I guess we won't be able to try with the older version.
Reply
Options

1 Posts

03-10-2020

US

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎03-10-2020
  • Location: US
  • Views: 0
  • Message 10 of 15

Re:Hybrid Mode Not Working (Again)

2020-03-10, 1:04 AM

As there are no solutions anywhere in Google, I found a solution (black screen after boot when turning hybrid mode on):

 

Open "Device manager"

 

Click "Batteries"

 

Disable your battery with right click on battery and disable device

 

Turn your hybrid mode on from Lenovo Vantage

 

Reboot

 

Now PC uses Intel graphics just without the battery.

 

Cheers

 

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete