cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SirhanSirhan
What's DOS?
Posts: 1
Registered: ‎01-12-2018
Location: US
Views: 126
Message 1 of 2

LEGION-Y530-15ICH detects wrong drive, doesn't always boot, and I have to keep resetting the system

When I turn my laptop on, it'll sit, and sometimes the powerbutton light will go off after a minute or so and it'll reset and try to boot again and fail with No bootable O/S found. If I go into the bios, the drive is either not there, labeled as another drive, or sometimes it appears correctly and it will boot.

 

BIOS is the very recent, I flashed it not long ago. I am using AHCI mode. But the drive / controller / something else is having intermittant issues.

 

Once it boots up and is recognized, everything appears fine.

 

What should I do?

 

Support Specialist
Posts: 743
Registered: ‎04-23-2019
Location: US
Views: 58
Message 2 of 2

Re: LEGION-Y530-15ICH detects wrong drive, doesn't always boot, and I have to keep resetting the sys

Hi SirhanSirhan,

 

Welcome to the Community Forums.

 

Thanks for reaching out, is it possible for you to try the drive on another machine to test if the storage is causing the issues?

 

I'll wait for your update.

Regards,

Jack_Lenovo1



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors