English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

0 Posts

06-29-2020

SA

3 Signins

30 Page Views

  • Posts: 0
  • Registered: ‎06-29-2020
  • Location: SA
  • Views: 30
  • Message 1 of 2

LEGION Y530 Awful WiFi disconnection FIX

2020-06-29, 10:39 AM

Hello Y530 owners ,  I am an owner of one of Y530s since Dec 2018 . I’ve been experiencing the major problem that most Y530 owners have . And it’s the Disconnection and high latency of the awful RTL8822BE card . About 6 months ago I tried to solve this problem by changing my power configuration and reinstalling the drivers but nothing of this worked ! . One of the drivers I tested is this( Realtek_WLAN2024.0.8.108 ), it seems more stable than the Realtek_2024.0.10.202 but they are all bad . So i tried another driver which is the RTLWlanE2023.56.0502.2017 and this is the 1st driver for this card and i’ve been testing it since the start of 2020 and it seems very reliable and stable in comparison to the other drivers such as :Realtek_WLAN2024.0.8.108 , Realtek_2024.0.10.202. The method to switch to the RTLWlanE2023.56.0502.2017 driver is very simple , You need to go to Device manager by right clicking on the start menu then choose device manager . Then you need to expand your network adapters to be able to see the adapter like the picture below 

Now you need to right click on the Realtek8822be wireless lan adapter . Now you need to go to the driver tab , after that you need to click on update driver then browse my computer for driver software . Now click on Let me pick from a list of available drivers on my computer then have disk then browse . after that you need to download RTLWlanE2023.56.0502.2017 driver from this site https://www.techspot.com/drivers/driver/file/information/18071/ then extract it to any folder you want ( new folder is preferred ) then you need to do this step again “you need to right click on the Realtek8822be wireless lan adapter . Now you need to go to the driver tab , after that you need to click on update driver then browse my computer for driver software . Now click on Let me pick from a list of available drivers on my computer then have disk then browse” after that head to the folder which you extracted the new driver in then click on RTWLANE_Driver and choose your OS and your system type x64 or x86 and double click on the netrtwlane.inf and then click next and it will update your driver to this new driver ( it’s not new to be exact but it’s the most reliable driver ) after that you can check your driver version in the driver tab . If it’s 2023.56.502.2017 then you are good to go . now we need to stop windows 10 from auto updating this driver to the awful driver which is Realtek_2024.0.10.202 and we can do this by going to this site https://support.microsoft.com/en-us/help/3073930/how-to-temporarily-prevent-a-driver-update-from-reinstalling-in-window and click on Download the troubleshooter from the Microsoft Download Center . Now we need to open this file we downloaded from Microsoft Download Center to temporarily stop windows update from updating the driver . now click on next then Hide updates then choose this update Realtek_2024.0.10.202 to disable it then next then exit if you finish . you should repeat this step once in a while to stop windows update from auto updating the driver . 

Y530 15ICH 

I7-8750h

1050 ti

1tb hdd 128gb m.2 

REALTEK 8822 BE 

 

 

 

I AM JUST A CUSTOMER AND THIS IS THE METHOD THAT FIXED MY PROBLEM , I AM NOT A LENOVO SPECIALIST OR ONE OF THE STAFF , THIS METHOD FIXED MY PROBLEM BUT IT MAY NOT WORK FOR YOURS SO YOU NEED TO TRY AND TEST 

Solved! See the solution
Reply
Options

274 Posts

03-11-2020

NO

47 Signins

1875 Page Views

  • Posts: 274
  • Registered: ‎03-11-2020
  • Location: NO
  • Views: 1875
  • Message 2 of 2

Re:LEGION Y530 Awful WiFi disconnection FIX

2020-06-29, 11:34 AM

Very nice Chofant.

 

 

You can also disable Automatic Hardware Driver updates from happening permanently through Windows own settings:

 

Disable Automatic Hardware drivers update

- Right click the Windows Icon, select the "Search" Function.

- Type "Control Panel" and select "Small icons" or "Large Icons" in the "View By" top right.

- Click the "System Icon"

- Navigate to "Advanced System Settings" -> "Hardware"

- Click "Device Installation Settings" and Select "No"

**This will prevent Windows from interfering with your hardware drivers in future updates, but keep crucial security updates rolling.

 

Regards

 

Voithos



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

I do not respond to private messages.

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete