Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

25 Posts

02-16-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

335 Page Views

  • Posts: 25
  • Registered: ‎02-16-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 335
  • Message 11 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-09, 15:32 PM

I suspect you're right about the ryzen processors, from looking at various forums it seems to be a problem for other lapop/desktop machines too.

 

https://community.amd.com/t5/processors/amd-ryzen-7-4800h-sound-and-screen-stuttering/td-p/79889

 

No official response to the problem from AMD either and the problem seems to have persisted for the last 2 generations of ryzen processors.

 

 

 

 

Reply
Options

81 Posts

01-10-2021

United Kingdom of Great Britain and Northern Ireland

58 Signins

530 Page Views

  • Posts: 81
  • Registered: ‎01-10-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 530
  • Message 12 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-13, 13:19 PM
Hello,

Apologies @cccat, I did not mean to hijack your thread. I am sorry I did not reply. Life stuff, and honestly had enough of this laptop. Waste of £1,200! I've been back to using my 10 yr old Acer more often than this!

It seems others are having similar issues based on replies.

Unfortunately I can't use the second slot (another issue of this wretched thing!) because it is not recognised. I bought a 1tb NVMe M.2 that I cannot use.
 
Latencymon shows various network spikes as well as other things, so you may be on to something, but I cannot decipher which is the offender, if any. It seems so random.
 
I have had some luck mitigating the lags/stutters, but I can't say this will help everyone. I had a few days with very few issues, but today it has been bad.
 
Whilst I doubt any of these are harmful "fixes", and may be common knowledge to most, please backup before trying anything. All used in "Balance mode" - Fn + Q.
 
Anyway, things that seemed to help me somewhat:
 
 
1) Enable the "High Performance Power Plan".
 
Command prompt - powercfg -duplicatescheme 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c
 
 
 
2) Control Panel > Power options > High Performance > Change plan settings  > Change advanced power settings
 
I made changes to the following, everything else was default to the high performance plan:
 
Desktop background settings:
    Slideshow:
        On battery: Paused
        Plugged in: Paused
 
Wireless Adapter Settings:
    Power Saving Mode:
        On Battery: Low Power Saving
        Plugged in: Low Power Saving
 
Sleep:
    Hibernate after:
        On Battery: 180 min
        Plugged in: 180 min
 
PCI Express:
    Link State Power Management:
        On Battery: Moderate power savings
        Plugged in: Off
 
Processor power management:
    Minimum processor state:
        On Battery: 65%
        Plugged in: 100%
 
    Maximum processor state:
        On Battery: 100%
        Plugged in: 100%
 
"High Performance" seems to have a huge impact on battery life. This model has the larger battery and I am only getting 3hrs max as opposed to 7hrs+ on "Balanced" and "Energy Star" with the same settings, so be aware if you have the smaller battery. Plugged in I guess it doesn't matter.
 
 
3) Settings app:
 
Settings > System > Battery
    Turn battery saver on automatically at: Never
    Lower screen brightness while in battery saver: Uncheck
 
Restart and check your settings saved.
 
 
4) bcdedit:
 
Open an elevated command prompt:
 
Enter: bcdedit /set disabledynamictick yes
 
Check the command status by entering: bcdedit
 
It should show disabledynamictick  - Yes, at the bottom of the list.
 
This has something to do with dynamic ticking... I don't have a clue to be honest, but it can help apparently and hasn't made things worse that's for sure.
 
If you need to revert it, enter: bcdedit /set disabledynamictick no
 
 
5) Device Manager:
 
I noticed my internet was dropping every 5-10min for around 5 - 8 seconds, especially while connected via Ethernet, so that had me searching too in case that was triggering spikes when reconnecting.
 
Go to Device Manager > Network adapters
 
Right-click your Ethernet driver - "Realtek PCIe GbE Family Controller" in my case > properties > Advanced tab
 
Change the following:
 
Energy-Efficient Ethernet - Disabled
Green Ethernet - Disabled
Wake on Magic Packet - Disabled
 
Same driver > properties > power management
    Allow the computer to turn off this device to save power: Uncheck
 
 
 
6) Wi-Fi
 
Device Manager > Network adapters
 
Wi-Fi 6 AX200 for me
 
Right click > properties > Advanced tab
 
Wake on Magic Packet - Disabled
 
Same driver > properties > power management
    Allow the computer to turn off this device to save power: Uncheck
 
 
7) I decided to uninstall my VPN just in case. I hate not having a VPN, but it seems to have helped. Uninstalling the traditional way left a lot of junk! Drivers etc So I reinstalled the VPN and uninstalled using BCUninstaller. I won't say what the BC stands for in case it is flagged for language, but it is the best uninstaller I've used so look that up. Geek Uninstaller is also good. Search Explorer for remains just in case.
 
Restart
 
 
8) Optional:
 
This did not work for me after a day's use, but people seem to have had success: https://www.speedguide.net/ download TCP Optimizer, run as administrator and setup according to your max internet speeds.
 
Restart
 
 
9) Throw in the bin! Joking of course.
 
 
Sorry this is so long, there may be other things I missed, but perhaps something above will help someone. I've had enough of this thing. Having reoccurring 0.38ghz throttling again too. It can be okay for a while then BZZZZZZZZZZ everything is out of sync. I have videos which support won't look at. I was offered a warranty repair, but I am not sending it back to be reset and returned in essentially the same condition. I have reset 4 times in 2 months. Cannot get a refund or replacement.
 
Despite the raving reviews, this has possibly been the worst purchase I have made!
 
BE WARNED!
 
Regards, and good luck, folks. Let's hope a fix will arrive.
 
AL
Reply
Options

81 Posts

01-10-2021

United Kingdom of Great Britain and Northern Ireland

58 Signins

530 Page Views

  • Posts: 81
  • Registered: ‎01-10-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 530
  • Message 13 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-13, 13:43 PM

Hello,

 

Your screenshot looks similar to mine, I have had massive spikes from different sources. It seems totally random.

 

See my other (long) post in this thread, I managed to tame it a little, but it still goes well into the red sometimes. It seems better now.

 

This is still way too high and incredibly frustrating.

Reply
Options

25 Posts

02-16-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

335 Page Views

  • Posts: 25
  • Registered: ‎02-16-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 335
  • Message 14 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-13, 13:51 PM

Same here. I thought I struck a bargain when I bought the thing off ebay currys clearance for £799.99 but I suspect they knew the underlying faults as I see the same deal pop up every few weeks. I suspect the laptop has passed a few hands and they're hoping that perspective owners won't pick up on the faults before the return period ends. Luckily I got my money back but many people didn't and from historic posts in this forum most of the reported issues are still being ignored.

 

I too am left with using a 10 year old clevo p150hm laptop and despite it's age is still a good machine but it just doesn't play modern games. I have been able to upgrade / change the CPU i7-2670qm, GPU 470gtx, RAM 16gb, 1tb ssd etc like a normal PC.

Reply
Options

81 Posts

01-10-2021

United Kingdom of Great Britain and Northern Ireland

58 Signins

530 Page Views

  • Posts: 81
  • Registered: ‎01-10-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 530
  • Message 15 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-13, 14:58 PM

Yep,

 

No doubt if you get a good one it would be great! The screen is a treat with the 2060! I suppose the good ones *puts tinfoil hat on* are sent to YouTube reviewers and work flawlessly!

 

Despite being labelled a "Gaming" laptop, I personally didn't buy it for that purpose, but I can imagine anyone using it for that and having similar problems it would be infuriating!

 

I was looking at a more expensive Thinkpad before buying this. In hindsight, I'm not sure whether I should have gone for that, or to be thankful I didn't pay more. These are not small change purchases and there is clearly something going on for so many similar issues. No one should have to troubleshoot brand-new machines to this degree.

 

If I speak to anyone thinking of buying a Lenovo I will do my best to warn them. It won't harm Lenovo's income in the grand scheme of things, but still.

 

Anyway, glad you got a refund. Here's hoping something will pop up and we can all actually enjoy our machines.

 

Regards,

 

AL

Reply
Options

24 Posts

03-04-2019

United States of America

35 Signins

146 Page Views

  • Posts: 24
  • Registered: ‎03-04-2019
  • Location: United States of America
  • Views: 146
  • Message 16 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-22, 17:57 PM

 

With the Vantage app I could reproduce the micro stutters, IRL it has a static cripp sound to it not just the mute. (the app is uptodate)
And during this the full windows LAGGS!!!!44!4!4
#bestlaptopEUNE #fixthis

(https://youtu.be/qNFfb7uFwDQ)

Reply
Options

25 Posts

02-16-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

335 Page Views

  • Posts: 25
  • Registered: ‎02-16-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 335
  • Message 17 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-22, 18:29 PM

That's insane that the entire system can be crippled by doing something like this. Further more it's been almost a year without a patch / firmware fix.

Reply
Options

81 Posts

01-10-2021

United Kingdom of Great Britain and Northern Ireland

58 Signins

530 Page Views

  • Posts: 81
  • Registered: ‎01-10-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 530
  • Message 18 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-23, 18:38 PM

Good job finding that.

 

I have honestly not tinkered with the Vantage toolbar, but I have just tested and got similar results.

 

Touch wood, mine still seems a little better running high performance and the tweaks I posted. But when it stutters like your video it seems a lot more aggressive! Similar, but more of a burst of juddering. What could be causing this randomly, though?

 

May I asked what caused you to test it this way?

 

AL

Reply
Options

24 Posts

03-04-2019

United States of America

35 Signins

146 Page Views

  • Posts: 24
  • Registered: ‎03-04-2019
  • Location: United States of America
  • Views: 146
  • Message 19 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-23, 18:50 PM

It was a random attempt (I was trying the toolbar functions  -- funfact 'cause Fn lock stuck (common Lenovo problem :) )). IRL the stutters more aggressive tho, yes. But when I try to record it its only a muted soundline, and lagg in the video. This stutter can randomly come (not only when you use the Vantage toolbar). Not a task oriented thing imo.  I dont know the fix to this thing tbh, I tried to reinstall Windows, but its the same. 

Reply
Options

81 Posts

01-10-2021

United Kingdom of Great Britain and Northern Ireland

58 Signins

530 Page Views

  • Posts: 81
  • Registered: ‎01-10-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 530
  • Message 20 of 421

Re:Legion 5P 15ARH05H micro stutters

2021-03-23, 19:25 PM

Yep, it is seriously annoying!

 

Even worse is that it is so hard to catch in the moment, so good job finding a way to simulate it that others can relate to.

 

Mine (slightly different model) grinds/judders then often throttles to 0.38ghz and the audio is horrendous! Just pure distortion.

 

I had issues with Fn too around the same time this started - Fn functions work correctly for the most part, but the on-screen notifications showing what function you'd activated or deactivated would stop showing. That and random muted audio. Activating and reactivating Airplane Mode - Fn + f8 fixes it for me everytime, but it is still a pain.

 

Honestly, I've stopped resetting, but I feel your pain having resorted to that. Support are quick to tell you to reset, which is a temporary fix a best. This happens in safe mode too, so it needs addressing!

 

I was told to run disk clean up and if that doesn't help reset. Absolutely unbelievable!

 

Thanks for the video though. I really hope this is sorted.

 

AL

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms